[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / mail / GNUMail

File: [cvs.NetBSD.org] / pkgsrc / mail / GNUMail / Makefile (download)

Revision 1.13, Sun Apr 11 00:03:10 2004 UTC (20 years ago) by rh
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.12: +10 -11 lines

Update GNUMail to 1.1.2.  Noteable changes include:

	* Now uses Addresses framework.
        * Updated the OS X version of the Filtering bundle.
	* Added Matt, Ken and Bjorn in the About panel.
	* Simplified and optimized the Filtering bundle
	  initialization code under GNUstep.
	* Removed some NSLog() calls in the Import bundle
	* We don't save an "empty MailWindow" in the prefs
        * We now disable the "Use secure connection" buttons
	  in the AccountEditorWindow if the SSL bundle is not
	  installed under GNUstep (it's always installed with
	  our dmg on the OS X version).
	* Updated the German translation. Work done by
	  Hermann Gundel <Hermann.Gundel@nussberg.de>
        * Modified AdvancedViewController to no longer
	  statically allocate everything.
	* Modified MailWindowController: -deleteMessage
	  to use the new Folder's method (-setFlags: messages:)
	  in order to accelerate IMAP messages deletion.
        * We no longer check all IMAP accounts
	  but only opened ones.
	* We no longer remove the DELTED message flag when
	  deleting from the keyboard.
        * Removed the "Open on startup" feature in the Mailboxes
	  window / drawer. GNUMail.app will now automatically
	  reopen the mailboxes that were opened when the app
	  was closed.
        * Added an extra check in MailboxManagerController: -outlineView:
	  acceptDrop: .. since the GNUstep's NSOutlineView code is
	  broken wrt DnD. Savannah is still down so I can't fix the
	  real bug :(
        * We now STATUS all IMAP folders for an opened IMAP connection
	  in a separate thread when clicking on the "Get" button. We no
	  longer only NOOP the IMAP store.
	* Added AddressBook framework to the Filtering target based on the
	  previous change.
	* Fixed crash on quitting on OS X.
        * Modified MailboxManagerController: -_reloadFoldersForIMAPStoreWithName: ...
	  to also use -reloadItem: under GNUstep since that method has been
	  fixed lately.
	* Reverted the change. -reloadItem is still plain broken.
	* Added a patch from Bjorn Giesler to enhance the filtering code
	  to support address book groups. The OS X nib NEEDs to be modified.
	* Added Bjorn in the AboutPanel's list of contributors.
	* Fixed a warning in MailWindowController: -windowWillClose.
	* Added Constants.m to the OS X project file.
        * Added Constants.m and cleaned the header. That
	  new file _must_ be added to the OS X project file.
        * Added Matt Ackeret and Ken Ferry to the About panel.
	* We now properly call -controlTextDidChange: in the
	  -takeTo* methods (in EditWindowController) in order
	  to correctly enable the Send button.
	* Updated ViewingView.nib
	* Updated AboutPanel.nib
	* Updated InfoPlist.strings
	* Fixed a compiler warning in GNUMail.m
	* Added patches from Bjorn Giesler to:
	   - improve address completion
	   - implement the "preferred label" in AddressBookPanel
	   - convert the Mailboxes window and Console window to
	     panels. This is a quick hack since the classes NEED
	     to be renamed eventually.
	* We no longer force the ADScreenNameFirstNameFirst since
	  we'll use the user's default in AddressManager.
	* Removed the "Mailbox" string the in Mailboxes's drawer
	  for the contextual menu.
	* Renamed Id -> Number in the Viewing pref panel under GNUstep.
	  The OS X nib needs to be modified.
	* We now save correctly the order of MailWindow's dataView columns.
	* Added a simple patch from David Ayers for key comparisons
	  in AccountViewController.m.
	* Improved AddressBookPanel.nib.
        * We now correctly synchronize our popups in the FilterEditorWindow.
	* We now correctly reload the table columns when changing the
	  dataview type in MailWindowController.
	* Added modal sheet to "Save message as text" action in GNUMail.
	* An address (to|cc|bcc) must be defined for the send button to
	  be active in EditWindowController.
	* Fixed color space in ColorsViewController (Colors bundle).
	* Improved behavior of modal sheet in EditWindowController when
	  closing an unsaved message.
        * Removed two more observers in GNUMail: -applicationShouldTerminate:
	  and reorganized all the calls in MailWindowController: -dealloc.
	* Defined ReloadMessageList in Constants.h so it's cleaner.
        * We no longer require the user to specify a To: recipient.
	* Also fixed a bug in the filtering code wrt trailing ">"
	  when the criteria operation is "has suffix". Issues reported
	  by Alistair Windsor <awindsor@onetel.com>.
        * Simplified the code a little bit in AddressBookController.
	* Simplified it some more and reactivated AddressBookController:
	  -addressesWithSubstring: so it's now possible to filter incoming
	  mails based on the recipients / Apple's Address Book (or
	  GNUstep's implementation). This fixes TODO #33.
	* Renamed a local variable to not conflict with an ivar on OS X.
	* Added AddressBook_32.tiff and modified the AddressBookPanel.nib
	  to use it.
	* Enhanced MailboxImport.nib.
	* Lots of very minor improvements wrt the Vera font.
	* Modified MailboxImportController: -dealloc to set the datasource
	  of our table view to nil.
	* Did the same thing for the outline view shown in MailWindow's drawer
	  under OS X.

# $NetBSD: Makefile,v 1.13 2004/04/11 00:03:10 rh Exp $
#

DISTNAME=	GNUMail-1.1.2
CATEGORIES=	mail gnustep
MASTER_SITES=	http://debian.uni-essen.de/misc/GNUstep/Apps/GNUMail/

MAINTAINER=	rh@NetBSD.org
HOMEPAGE=	http://www.collaboration-world.com/gnumail/
COMMENT=	GNUstep clone of NeXT's Mail.app application

WRKSRC=		${WRKDIR}/GNUMail
USE_BUILDLINK3=	yes
USE_X11=	yes
NO_CONFIGURE=	yes

.include "../../mail/Pantomime/buildlink3.mk"
.include "../../misc/Addresses/buildlink3.mk"
.include "../../x11/gnustep-back/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"