Up to [cvs.NetBSD.org] / pkgsrc / lang / zig
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.12 / (download) - annotate - [select for diffs], Thu Jan 19 12:32:18 2023 UTC (8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
HEAD
Changes since 1.11: +4 -4
lines
Diff to previous 1.11 (colored)
zig: updated to 0.10.1 0.10.1 LLVM 15.0.7 This release of Zig upgrades to LLVM 15.0.7 which fixed a handful of bugs, including regressions introduced in LLVM 15.0.0. At time of writing, this hyperlink 404s because LLVM project did not provide release notes for this version. Compiler cmake: move 'continue' statement to avoid cmake bug C backend: improve support for non-native float types C backend: enough fixes for compiler to to be able to build itself C backend: include zig.h with quotes instead of angle brackets. C backend: remove redundant definition of u16/i16 in zig.h C backend: fixed some C warnings and errors on gcc 11.3.0. c backend: Output string literals for array init of bytes Fixed typo in zig.h causing incorrect behavior. LLVM: mangle extern function names for Wasm target Fixed detection of MSVC installation on aarch64-windows. Fixed comptime array initialization. Fixed performance regression due to unnecessary copies. There is still another known similar performance regression that is not fixed in 0.10.1. Fixed CPU model detection for neoverse_n1 on aarch64-linux LLVM: fix canElideLoad behavior with loops Improved error messages. Fixed false positive dependency loops. Sema: resolve elem type for non-default aligned ptrs Compilation: fixed deadlock when compiling the same C source file twice Fixed compiler crashes. mingw: add missing vscprintf.c file LLVM: Respect alignment for `.union_init` Ensure f128 alignment matches c_longdouble alignment Support modifiers in inline assembly. Fixes bug in AVR codegen for LLVM backend Fixed compilation not failing when there are linker errors. cache: Fix LockViolation during C compilation paths Fix another LockViolation case on Windows Fixed C ABI bug regarding double types fix Nvptx backend outputing files at the top level of zig-cache Sema: make `InferredErrorSet` deterministic Sema: avoid breaking hash contract when instantiating generic functions Sema: fix missing struct layout for llvm backend Miscellaneous fixes to the experimental ARM and aarch64 backends. cli: set sysroot when --sysroot option was passed macho: do not zero-out file if there are no nonzerofill sects macho: parse weak imports in tbd descriptors fixes to the DWARF parser Fixed handling of explicitly provided pdb windows: add native CPU and features detection for Armv8 chips Improve aarch64 feature detection based on the readouts from privileged system registers Remove incorrect assertion in readMachODebugInfo panicking during panic Add missing clang opts: -install_name and -undefined macho: add missing defs of compact unwind info records Bug fix: Prevent uninitialized parse nodes Sema: resolve lazy align in zirReify for union fields llvm codegen: fix f16,f32,f64 nan bitcasts support building zig on BSDs with dynamic libstdc++/libc++ Elf: link libcompiler_rt after libc macos: enable -headerpad_max_install_names Translate-C Remainder Macro Fix Many compiler crashes are fixed. Many compile error messages are more helpful. LLVM: implement packed unions Sema: remove `block` and `src` parameters from `getBuiltin` translate-c: cast unsuffixed floats to f64 LLVM: fix x86_64 sysV ABI of big vectors on avx512 enabled CPUs LLVM: improve emitted debug info Improve debuggability of programs built by the self hosted compiler. windows: fix _tls_index not being defined if libc wasn't linked, and fix x86 name mangling zig-cache: support windows drive + fwd-slash paths Fix error reporting the wrong line for struct field inits Call ensureResultUsed before comptime .call is evaluated. add arm-features.h from glibc source Standard Library os: windows: fix unhandled error std.os.windows.ReadLink: add missing alignment of local data buffer Fixed condition variable (futex implementation) broadcast failing to wake all threads Fixes to make zig work better with BSD operating systems. uefi: Delete unneeded alignment and use default 4K Fixed update() method in PriorityQueue and PriorityDequeue std.c: Add definition for pthread_key_t std.os.linux: Add setitimer and getitimer syscalls Handle sentinel slices in `std.mem.zeroes` add missing std.c.pthread_sigmask std.big.int.Mutable: fix set(@as(DoubleLimb, 0)) wasi: fixes IterableDir.nextWasi for large directory Fix buffer overflow in fmt when DAZ is set std.os: fix alignment of Sigaction.handler_fn gzip: add missing header fields and bounds for header parsing os.windows.OpenFile: Add `USER_MAPPED_FILE` as a possible error Dir.openDirAccessMaskW: Add ACCESS_DENIED as a possible error wasi: fixes os.isatty on type mismatch Add 0-length buffer checks to os.read and os.write Fixes to linux/bpf/btf.zig std: fix bug in Pcg32 fill function std.net: check for localhost names before asking DNS std.os.linux.T: translate more MIPS values std.atomic.Queue: fix unget implementation and add doc std.Thread.Futex.PosixImpl.Address.from: fix `alignment` type crypto Ed25519.KeyPair.fromSecretKey() didn't compile after the API changes ed25519: recommend using the seed to recover a key pair std.crypto.ed25519 incremental signatures: hash the fallback noise std.crypto.pwhash.bcrypt: inline the Feistel network function crypto.salsa20: make the number of rounds a comptime parameter crypto.core.aes: process 6 block in parallel instead of 8 on aarch64 crypto.bcrypt: fix speed regression when using self-hosted compiler zig cc / zig c++ detect -z stack-size arguments support -stack in addition to --stack for linker arg fix wrong flag name from earlier commit compiler-rt Fixed duplicate symbol error when linking libc on arm64 Windows. Added aarch64 outline atomics. Avoid using weak aliases. Documentation langref: Simplify printing types in examples packed struct fix example and clarify least to most significant ordering langref: add appendix and explain 'container' terminology Add docstrings to some functions in std.meta Improve doc comments for two functions document std.heap.StackFallbackAllocator std.array_list: add a comment on every methods invalidating pointers.
Revision 1.11 / (download) - annotate - [select for diffs], Mon Nov 14 19:00:39 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.10: +4 -4
lines
Diff to previous 1.10 (colored)
zig: updated to 0.10.0 0.10.0: https://ziglang.org/download/0.10.0/release-notes.html
Revision 1.10 / (download) - annotate - [select for diffs], Tue Mar 15 05:36:15 2022 UTC (18 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.9: +4 -4
lines
Diff to previous 1.9 (colored)
zig: updated to 0.9.1 0.9.1: libcxx: fixed not building fs/filesystem when targeting Windows. libcxx: fixed duplicate __muloti4 symbol. Integration with --sysroot parameter Integration with --entry parameter Integration with --whole-archive, --no-whole-archive, --strip-all, and --strip-debug parameters. Integration with --hash-style parameter. Fixed a bug where passing a zig source file to zig cc would incorrectly punt to clang because it thought there were no positional arguments. Integration with CUDA source files Improved a warning message for some cases of using zig run -lc++. Ignore -lgcc_s when it is redundant with compiler-rt. Fixed Linux headers being named arm64 instead of aarch64 glibc: fixed passing of __GNU_MINOR__. glibc: fixed compatibility with glibc <= 2.33 for global initializers glibc: fixed MINSIGSTKSZ on glibcs older than 2.34
Revision 1.9 / (download) - annotate - [select for diffs], Tue Dec 21 09:16:26 2021 UTC (21 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.8: +4 -4
lines
Diff to previous 1.8 (colored)
zig: updated to 0.9.0 0.9.0: Language Changes Address Spaces More Builtins Return String Literals @minimum and @maximum @select SIMD @intToEnum Implicitly Performs @intCast Shadowing Declarations Keywords Deleted: true, false, undefined, null usingnamespace No Longer Affects Identifier Lookup c_void renamed to anyopaque Saturating Arithmetic Compile Errors for Unused Locals @export with Field Access Inline Assembly Requires String Literals @prefetch
Revision 1.8 / (download) - annotate - [select for diffs], Tue Oct 26 10:51:59 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
Changes since 1.7: +2 -2
lines
Diff to previous 1.7 (colored)
lang: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes The following distfiles could not be fetched (possibly fetched conditionally?): ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-musl.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-armv7-unknown-netbsd-eabihf.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-i686-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-sparc64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-apple-darwin.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-freebsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-musl.tar.gz ./lang/smlnj/distinfo smlnj-110.73/boot.ppc-unix.tgz ./lang/smlnj/distinfo smlnj-110.73/boot.sparc-unix.tgz ./lang/oracle-jre8/distinfo jce_policy-8.zip ./lang/oracle-jre8/distinfo jre-8u202-linux-i586.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-linux-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-macosx-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-solaris-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-i586.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-solaris-x64.tar.gz ./lang/ghc80/distinfo ghc-7.10.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-i386-unknown-freebsd.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-x86_64-unknown-freebsd.tar.xz ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/rust/distinfo rust-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-illumos.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-std-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/smlnj11072/distinfo smlnj-110.72/boot.ppc-unix.tgz ./lang/smlnj11072/distinfo smlnj-110.72/boot.sparc-unix.tgz ./lang/ghc84/distinfo ghc-8.0.2-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.10.3-boot-i386-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-i386-unknown-solaris2.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-powerpc-apple-darwin.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-8.10.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-aarch64-unknown-netbsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-i386-unknown-freebsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-apple-darwin.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-unknown-freebsd.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-netbsd-7-sparc64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.8.181-netbsd-8-aarch64-20180917.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.6-amd64-20140719.tar.bz2 ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.8-amd64-20140719.tar.bz2 ./lang/go-bin/distinfo go1.14.2.darwin-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-386.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-arm64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-armv6l.tar.gz ./lang/go-bin/distinfo go1.14.2.netbsd-arm64.tar.gz ./lang/go-bin/distinfo go1.16beta1.darwin-arm64.tar.gz ./lang/gcc6-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/ghc810/distinfo ghc-8.8.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/sun-jre7/distinfo UnlimitedJCEPolicyJDK7.zip ./lang/sun-jre7/distinfo jre-7u80-linux-x64.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-i586.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-x64.tar.gz ./lang/ghc88/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/gcc-aux/distinfo ada-bootstrap.i386.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/gcc6/distinfo ecj-4.5.jar ./lang/openjdk11/distinfo bootstrap-jdk-1.11.0.7.10-netbsd-9-aarch64-20200509.tar.xz ./lang/sun-jdk7/distinfo jdk-7u80-linux-x64.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-i586.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-x64.tar.gz
Revision 1.7 / (download) - annotate - [select for diffs], Thu Oct 7 14:21:17 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.6: +1 -2
lines
Diff to previous 1.6 (colored)
lang: Remove SHA1 hashes for distfiles
Revision 1.6 / (download) - annotate - [select for diffs], Mon Jul 12 18:58:25 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
zig: updated to 0.8.0 0.8.0: Language Changes No More Extern or Packed Enums Require Block After Suspend @extern Nameless Tests @TagType Removed nosuspend Add SysV Calling Convention Wrapping Negation on Unsigned Ints at comptime @import("builtin") no longer re-exports std.builtin
Revision 1.5 / (download) - annotate - [select for diffs], Sat Apr 18 08:08:07 2020 UTC (3 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.4: +5 -14
lines
Diff to previous 1.4 (colored)
zig: updated to 0.6.0 Language Changes in 0.6.0: Improved names of error sets when using merge error sets operator (||). pub syntax for container fields is removed. Type coercion from *[0]T to E![]const T is now allowed. This is an unambiguous, safe cast. asm now accepts comptime-known values, rather than requiring string literal syntax. Removed compile error for peer result ?comptime_int and null. Ability to pass comptime types and non comptime types to same parameter. @typeOf is renamed to @TypeOf. zig fmt automatically performs the conversion, and the next release of Zig after this one will remove the automatic conversion. Ability to switch on pointer types. Multiline strings in test and library names are disallowed. Zig language no longer requires the expression a else unreachable with comptime a to produce a comptime result. Timon Kruiper implemented casting between [*c]T and ?[*:0]T on fn parameter. Timon Kruiper improved @typeInfo to lazily resolve declarations. This way all the declarations in a namespace won't be resolved until the user actually uses the declarations slice in the builtin TypeInfo union. @ptrCast supports casting a slice to a pointer. LemonBoy implemented peer type resolution between ?[]T and *[N]T. There is now peer type resolution between mixed-const []T and *[N]T.
Revision 1.4 / (download) - annotate - [select for diffs], Wed Mar 25 22:27:20 2020 UTC (3 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.3: +14 -5
lines
Diff to previous 1.3 (colored)
zig: Update to 0.5.0. Unbreak. This version of zig supports the current version of llvm in pkgsrc (9). Some patches from TheLemonMan were backported by me to fix NetBSD support. Release notes: https://ziglang.org/download/0.5.0/release-notes.html
Revision 1.3 / (download) - annotate - [select for diffs], Sun Jun 2 15:02:27 2019 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.2: +5 -5
lines
Diff to previous 1.2 (colored)
zig: updated to 0.4.0 0.4.0: LLVM 8 FreeBSD Support NetBSD Support WebAssembly Support 64-bit ARM Linux Support UEFI Support Tier System
Revision 1.2 / (download) - annotate - [select for diffs], Wed Feb 27 10:46:16 2019 UTC (4 years, 6 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.1: +5 -24
lines
Diff to previous 1.1 (colored)
zig: update to today's (2019-02-27) snapshot of master. Allows us to drop all the local patches that were merged upstream. lld is not a dependency, zig by default bundles lld and doesn't use an external one. comment it. Andrew Kelley (62): Merge pull request #1975 from BenoitJGirard/master Merge pull request #1963 from matthew-mcallister/dedup-compile-log-warning Merge pull request #1972 from coypoop/netbsd README: add NetBSD to support table pull request fixups Merge branch 'emekoi-fix-1711' export _mh_execute_header with weak linkage docs: note top level declarations are order-independent docs: shadowing zig fmt: fix infix operator before multiline string literal add test for 74bdc1d1f898705 Merge branch 'kristate-zig-backport-issue1944' remove --no-rosegment workaround now that valgrind bug is fixed valgrind client requests for undefined values Merge branch 'slice-deref-failure' of https://github.com/matthew-mcallister/zig into matthew-mcallister-slice-deref-failure pull request fixups Merge branch 'matthew-mcallister-slice-deref-failure' deduplicate compile errors for undeclared identifiers packed structs support comptime bitcasting extern structs support comptime bitcasting `@sliceToBytes` works at comptime better handling of arrays in packed structs better field access of types which have one possible value fix `@bitCast` when src/dest types have mismatched handle_is_ptr docs for packed structs add regression test for bitcast to array implement vector negation better libc detection (#1996) introduce std.debug.captureStackTrace fix `zig fmt` arg0 handled incorrectly add `zig cc` command to act like a C compiler zig cc: remove "polly" which was an undefined symbol on macos zig cc: work around clang calling GetCommandLine on Windows Merge pull request #2003 from ziglang/zig-cc first class support for compiling C code building DLLs on Windows works better `@cImport` works with `--cache on` Merge pull request #2005 from ziglang/c-source zig build: 2 improvements fix infinite recursion in type_has_one_possible_value delete incorrect TODO comment add docs for zero bit types and pointers to zero bit types fix not finding libgcc_s when looking for native libc add a compile error note when C import fails and not linking libc better error message when forgetting to link against libc add a regression test for #704 fix incorrectly trying to memset at comptime fix the libc compile error tests to only run on linux use -nobuiltininc when compiling c code use -nostdinc++ when compiling C code use -nostdinc and sometimes -nolibc when compiling C code breaking changes to the way targets work in zig fix regressions on Windows introduce sys_include_dir for when sys/* files are not with stdlib.h add builder.addFmt API and use it to test stage1 zig fmt fix .gitignore file and add commit missing std lib file add test coverage for binary OR on error sets add test coverage for type used as switch case fix handling when there are multiple externs and fix stage1 zig fmt on macos improve docs for unions and switching on tagged unions windows returns EINVAL for fopen when there is an asterisk in the name Benoit Jauvin-Girard (1): Fix std.math.powi so powi(x, +-0) = 1 for any x. BenoitJGirard (2): Merge pull request #1 from ziglang/master Merge pull request #2 from ziglang/master Jimmi HC (1): Fixed std.testing.expectEqual John Schmidt (2): Some function doc tweaks (#1961) Add priority queue LemonBoy (4): Silence gcc8 class-memaccess warnings Add align attribute for params pointers Translate parameterless C functions (#1978) Prevent crash in tagged enums rendering (#1986) Matthew McAllister (3): Fix lvalue dereference type checking Deduplicate compile log statement warnings Check for duped error messages in compile tests Maya Rashish (3): Add NetBSD support Undo local, unneeded patch Don't provide a bogus definition of EVFILT_USER Quetzal Bradley (1): fix openWriteNoClobber and add test emekoi (1): make @enumToInt work on union(enum) kristopher tate (1): src/analyze.cpp: default to using `param_node` upon callconv error;
Revision 1.1 / (download) - annotate - [select for diffs], Sun Feb 17 12:33:40 2019 UTC (4 years, 7 months ago) by maya
Branch: MAIN
Add zig 0.3.0.20190217 Zig is an open-source programming language designed for robustness, optimality, and clarity. * Robust - behavior is correct even for edge cases such as out of memory. * Optimal - write programs the best way they can behave and perform. * Clear - precisely communicate your intent to the compiler and other programmers. The language imposes a low overhead to reading code.