[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / tcl

Annotation of pkgsrc/lang/tcl/Makefile, Revision 1.37

1.37    ! adam        1: # $NetBSD: Makefile,v 1.36 2004/09/19 19:51:04 he Exp $
1.1       jwise       2:
1.37    ! adam        3: DISTNAME=      tcl8.4.7-src
        !             4: PKGNAME=       tcl-8.4.7
        !             5: CATEGORIES=    lang
        !             6: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=tcl/}
        !             7:
        !             8: MAINTAINER=    jwise@NetBSD.org
        !             9: HOMEPAGE=      http://www.tcl.tk/
        !            10: COMMENT=       Ousterhout's Tool Command Language, a scripting language
1.2       jwise      11:
1.12      jlam       12: CONFLICTS+=            tclman80-[0-9]*
1.1       jwise      13:
1.22      jlam       14: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     15:
1.26      minskim    16: WRKSRC=                        ${WRKDIR}/${DISTNAME:C/-src//}/unix
1.1       jwise      17: GNU_CONFIGURE=         yes
1.10      jlam       18: MAKE_ENV+=             TOUCH="${TOUCH}"
1.17      dillo      19: TEST_TARGET=           test
1.1       jwise      20:
1.22      jlam       21: USE_BUILDLINK3=                yes
1.1       jwise      22: USE_LIBTOOL=           yes
                     23:
                     24: INSTALL_TARGET=                install
                     25:
1.10      jlam       26: # Initially install the man pages into ${WRKDIR}/man, as we need a staged
                     27: # install to avoid overwriting existing manpages in ${PREFIX}/man.
1.30      jlam       28: CONFIGURE_ARGS+=       --mandir=${WRKDIR}/man
1.36      he         29:
                     30: .include "../../mk/bsd.prefs.mk"
                     31:
                     32: .if ${OPSYS} == "NetBSD"
                     33: .if empty(OS_VERSION:M1.[56].*)
1.34      jwise      34: CONFIGURE_ARGS+=       --enable-threads
1.36      he         35: .else
                     36: CONFIGURE_ARGS+=       --disable-threads
                     37: .endif
                     38: .endif
1.11      jlam       39:
1.22      jlam       40: # Add ${VIEWBASE}/lib/tcl to the list of locations for Tcl packages.
                     41: CONFIGURE_ENV+=                TCL_PACKAGE_PATH="${VIEWBASE}/lib/tcl"
                     42:
1.11      jlam       43: # NetBSD-1.5.x-m68k platforms apparently have a compiler optimization bug
                     44: # tickled by the Tcl code that manifests in code generation problems.
                     45: .if (${MACHINE_PLATFORM:MNetBSD-1.5*-m68k} != "")
                     46: CONFIGURE_ENV+=                COMPILER_OPTIMIZATION_BUG=YES
                     47: .endif
1.10      jlam       48:
1.36      he         49: .if ${OPSYS} == "NetBSD"
                     50: .if empty(OS_VERSION:M1.[56].*)
1.34      jwise      51: .include "../../mk/pthread.buildlink3.mk"
1.36      he         52: .endif
                     53: .endif
1.30      jlam       54:
1.10      jlam       55: # Modify mkLinks script to remove the short-filename manpage if it was
                     56: # linked to a longer filename.
                     57: post-patch:
                     58:        @cd ${WRKSRC};                                                  \
                     59:        ${MV} -f mkLinks mkLinks.tmp;                                   \
                     60:        ${GREP} -v "^exit 0" mkLinks.tmp > mkLinks;                     \
                     61:        ${CAT} mkLinks.tmp                                              \
1.26      minskim    62:                | ${AWK} '/^  *ln / { print $$3 }'                      \
1.10      jlam       63:                | ${SORT} -u                                            \
                     64:                | ${GREP} -v ".*\.n"                                    \
                     65:                | ${SED} -e "s,^,${RM} -f ,"                            \
                     66:                >> mkLinks;                                             \
                     67:        ${RM} -f mkLinks.tmp;                                           \
                     68:        ${CHMOD} +x mkLinks;
1.15      jlam       69:
1.1       jwise      70: post-install:
1.24      minskim    71:        cd ${WRKDIR} && ${PAX} -rwpm man ${PREFIX}
1.25      minskim    72:        ${RM} -rf ${WRKDIR}/man
1.26      minskim    73:        cd ${PREFIX}/bin && ${LN} -s tclsh8.4 tclsh
1.7       hubertf    74:        ${INSTALL_DATA_DIR} ${PREFIX}/include/tcl
                     75:        ${INSTALL_DATA_DIR} ${PREFIX}/include/tcl/unix
                     76:        ${INSTALL_DATA_DIR} ${PREFIX}/include/tcl/generic
1.1       jwise      77:        ${INSTALL_DATA} ${WRKSRC}/tclUnixPort.h ${PREFIX}/include/tcl/unix
1.32      minskim    78: .for f in      regex.h tcl.h tclCompile.h tclDecls.h tclIO.h           \
                     79:                tclInitScript.h tclInt.h tclIntDecls.h tclIntPlatDecls.h\
                     80:                tclMath.h tclPlatDecls.h tclPort.h tclRegexp.h
                     81:        ${INSTALL_DATA} ${WRKSRC}/../generic/${f} ${PREFIX}/include/tcl/generic
                     82: .endfor
1.1       jwise      83:
                     84: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>