The NetBSD Project

CVS log for pkgsrc/lang/tcl/Makefile.version

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / lang / tcl

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.32: download - view: text, markup, annotated - select for diffs
Mon Jan 27 13:59:46 2025 UTC (3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.31: preferred, colored
Changes since revision 1.31: +1 -2 lines
*: clean up after tcl-pdflib removal

Revision 1.31: download - view: text, markup, annotated - select for diffs
Sat Jan 25 21:29:25 2025 UTC (3 months ago) by adam
Branches: MAIN
Diff to: previous 1.30: preferred, colored
Changes since revision 1.30: +6 -6 lines
tcl: updated to 8.6.16

8.6.16

* unneeded path normalization (sebres)
* zlib stream returns negative checksums (nadkarni)
* zlib-8.8, zlib-8.16 fail on Fedora 40 (nijtmans)
* win/makefile: wrong recipe to buid libtcl.a and
	missing dependencies (sebres)
* regression in tzdata, %z instead of offset
	TZ-name (sebres)
* Tcl will not start properly if there is an init.tcl
	file in the current dir (sebres)
* clock scan of leapsecond: wrong result (sebres)
* Segfault in TclOO with coroutines (goth,sebres)

8.6.15

* remove private unicode 0xE000-0xF8FF from unicode
	control group (nijtmans)
* TCL_PACKAGE_PATH in tclConfig.sh change from TCL list to ":"
	(UNIX) or ";" (Windows) separated items (nijtmans)
	*** POTENTIAL INCOMPATIBILITY ***
* Time zones added: Alaska Standard/Daylight (nijtmans)
* fix compiled mapped ensembles (sebres)
* fix encoding koi8-u codepoint 0xB4
* speedup op unicode transformation related operations (sebres)
* Add encodings: koi8-ru, koi8-t
* Fix Tcl_ParseArgsObjv with TCL_ARGV_GENFUNC option (gavilan)
* Hash speedup for pointer compare. Option TCL_HASH_KEY_DIRECT_COMPARE
	for hash tables (sebres)
* Deprecate Tcl_GetAlias()
* Correct tcl::tm::path autoload (nadkarni)
* Remove empty all items from tclConfig.sh path variables.
* Fix crash in oo+coroutine (fellows)
* fix crash in oo destructors in same namespace
* Fix crash in reflected channels
* Fix crash due to unchecked file descriptor size
* Fix report of non ASCII computer names on Windows (fasel)
* Fix error message caused by interp limit
* Source files with BOM also in safe interpreters
* Fix encoding system result for system locale ISO-8859-1
* Tcl_NewObjectInstance() errors on namespace re-use (fellows)
	*** POTENTIAL INCOMPATIBILITY -- breaks Itcl 4.2 ***
* for linked varnames (fellows)
* Unicode version 16 (nijtmans)
* with wide int increment
* Fix Windows NTFS alternate data streams (ADS) accessability

Revision 1.30: download - view: text, markup, annotated - select for diffs
Sat Apr 6 05:37:47 2024 UTC (12 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.29: preferred, colored
Changes since revision 1.29: +6 -6 lines
tcl, tk: updated to 8.6.14

Summary of Changes since Tcl/Tk 8.6.13:
--------------------------------------

This is a patch release, so it primarily includes bug fixes and corrections
to erratic behavior.  Highlighted changes are noted below.  The changes file
at the root of the source tree contains a more complete list.  The Timelines
of all changes are online.

               http://core.tcl-lang.org/tcl/timeline
               http://core.tcl-lang.org/tk/timeline

   * [TIP 402] revise path normalization for x-platform UNC path support
        *** POTENTIAL INCOMPATIBILITY ***

   * Harmonize Tk's parse of numbers (screen distance, etc) with Tcl
        *** POTENTIAL INCOMPATIBILITY ***

   * Iconlist ignores options db for fg text color; affects dialogs
        *** POTENTIAL INCOMPATIBILITY ***

   * Aqua: XPutImage() swaps red and blue channels
        *** POTENTIAL INCOMPATIBILITY ***

   * [encoding convertfrom] handling of incomplete code sequences
        *** POTENTIAL INCOMPATIBILITY ***

   * Harmonize handling of ~ in paths across platforms.
        *** POTENTIAL INCOMPATIBILITY ***

   * Fix menu clone binding misbehavior, menu-20.1[2-6].
        *** POTENTIAL INCOMPATIBILITY ***

   * Improved performance of [exec] and [open |$cmd] on unix-lke
     systems, especially with large memory footprints.

   * Improve performance of large treeview destruction.

   * Improve performance of large image insertions into text.

   * Improve widget creation performance due to poor font caching.

   * Fix notebook tab appearances when placed on edge other than top.

   * Enable treeview display of partial final line.

   * Win: restore [exec %var%] that was dropped in 8.6.13.

   * Allow [chan create {} $cmd].  Enables simulation of server channels.

   * Allow return from [tk scaling] in safe interps.

   * Prevent navigation by word exposing clues to masked entry contents.

   * Fix crashes or hangs in...
      - [chan pop] with pending input
      - thread finalization of reflected channels
      - [label .l -bitmap floppy]
      - [set tcl_precision 15; expr 6.4623485355705287e-27]
      - [tk busy forget] and [tk busy hold]
      - channel read into "string" Tcl_Obj can BO, and perform poorly
      - KVO crash after destroying Aqua's first root toplevel
      - Test treeview-6ee162c3f9
      - Test tailcall-bug-784befb0ba
      - Tests menu-40.[12]

   * Repair memory leaks and errors
      - Eliminate undefined realloc() calls
      - Silence many warnings from -fsanitize=function
      - Flawed interfacing with XIM
      - Tcl_UtfToExternal writing to one-byte buffer
      - Tcl_UtfToUniChar() handling of 0xC1.
      - Tk_ConfigureValue could call wrong free() routine.
      - tests getuncichar-1.* in utf.test
      - ...and many more

   * No more support for 32-bit Cygwin

   * ::tcl_platform(osVersion) updated to report Windows 11

   * Accommodate macOS deprecation of sprintf()

   * Silence macOS 14 warnings about secure restorable state.

   * Code changes to support ASan use-after-return detection

   * Revise Tcl_MakeFileChannel() to better partner with pledge()

   * Prevent false [clock format] error reports on FreeBSD

   * Region clip & copy make better use of OS facilities.

   * Update handling of Apple FourCC creator codes.

   * Text selection omits first character, text-38.1

   * Windows: improved support of non-BMP pathnames

   * Fixed some Y2038 limitations

   * Fix photo color drawing on X11 32-bit visuals.

   * Fix <<MenuSelect>> regression on menus with -tearoff

   * Correct rounding of [nsFont pointSize].

   * zlib comment/filename error handling (zlib-8.19, zlib-8.2[012])

   * Prevent theme change attempts after Tk finalize.

   * Make dialogs robust against parent destruction.

   * Make [tk_chooseColor] robust against failed grab.

   * Fix menu parsing of @x,y indices.  menu-22.[6-9]

   * Fix inconsistent results from [font measure].

   * Fixed [clock scan|add] handling of abbreviated options

   * Avoid endless loops replacing [unknown] or [history].

   * Fix polluted error messages from [send -option].

   * PNG photo image decoder missed a 0xFF entry.

   * Fix failing winTime-2.1 on Windows

   * test string-2.20.1 failed on big endian platforms

   * Updated bundled packages, libraries, standards, data
      - Itcl 4.2.4
      - sqlite3 3.44.2
      - Thread 2.8.9
      - TDBC* 1.1.7
      - tcltest 2.5.7
      - libtommath 1.2.1
      - zlib 1.3.1
      - Unicode 15.1
      - tzdata 2024a

Revision 1.29: download - view: text, markup, annotated - select for diffs
Mon Jun 26 15:51:55 2023 UTC (22 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.28: preferred, colored
Changes since revision 1.28: +6 -6 lines
tcl: updated to 8.6.13

8.6.13
2021-12-08 (update) tcltest package to version 2.5.4
2022-01-13 (bug)[26f132] Crash when sizeof(int) < sizeof(void *) (Plan 9 port)
2022-01-19 (TIP 623)[e9a271] Tcl_GetRange index args < 0 (petasis,nijtmans)
2022-03-08 (bug) test string-5.22 (porter)
2022-03-11 (bug)[8a7ec8] fat binary compile on Mac M1 (davis, nijtmans)
2022-04-04 (bug)[e5ed1b] numeric IPv6 in URLs (nijtmans)
=> http 2.9.6
2022-04-26 (bug)[27520c] test error-9.6 (goth,sebres)
2022-05-04 (bug)[8eb64b] http package tolerant again invalid reply header
2022-05-11 (bug)[6898f9] http package failed detection of shiftjis charset
2022-05-25 (bug)[76ad7a] tests string-6.13[23] (mistachkin, nijtmans)
2022-06-20 (bug)[55bf73] Avoid connection reuse after response code 101.
=> http 2.9.8
2022-07-22 (bug)[713653] FP rounding exposed by x86 musl (rubicon,sebres)
2022-07-22 More portable notation of microseconds in verbose output (sebres)
=> tcltest 2.5.5
2022-07-27 (bug)[b3977d] Process CR-LF split across packets (nadkarni,sebres)
2022-07-29 (bug)[4eb3a1] crash due to undetected bytecode invalidity (nadkarni)
2022-08-23 (new)[371080] Portability to CHERI-enabled Morello processor (jrtc27)
2022-09-06 (bug)[55a02f] Fallback init env(HOME) from USERPROFILE (nadkarni)
2022-09-13 (bug)[1073da] crash writing invalid utf-8 (nijtmans)
2022-09-14 (new) Update to Unicode-15 (nijtmans)
2022-10-14 tzdata updated to Olson's tzdata2022e (nijtmans)
Update bundled zlib to 1.2.13
Update bundled libtommath
Many code fixes to avoid overflow or undefined behavior.

Revision 1.28: download - view: text, markup, annotated - select for diffs
Tue Nov 16 16:24:39 2021 UTC (3 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +6 -6 lines
tcl: updated to 8.6.12

8.6.12:
Bug fixes

Revision 1.27: download - view: text, markup, annotated - select for diffs
Wed Jan 20 20:38:48 2021 UTC (4 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +6 -6 lines
tcl: updated to 8.6.11

8.6.11:

2019-12-03 (bug)[3cd9be] Corner case in surrogate handling (nijtmans)

2019-12-09 (new) Add tcltest::(Setup|Eval|Cleanup|)Test (coulter,sebres)
=> tcltest 2.5.2

2019-12-12 (new) Add 3 libtommath functions to stub table (nijtmans)

2019-12-23 (bug)[ce3b9f] compilation errors with clang, windows msys2 (nijtmans)

2019-12-27 (bug)[1de6b0] [expr 1e2147483648] => 0.0 (kbk)

2020-01-04 (bug)[912886] tis-620 encoding fails to load (coulter)

2020-01-13 (bug)[0b9332] Win: support system encoding init to utf-8 (jedlička)

2020-01-17 (bug)[8cd2fe] [unload] corrupted list of loaded packages (berc)

2020-01-17 (bug)[5d989f] segfault in lsort for large list length (sebres)

2020-01-30 (bug) Reset WSAGetLastError()/errno in channel close (nijtmans)

2020-02-17 (bug) Win: avoid create of legacy error-vars on init phase (sebres)

2020-02-25 (bug) release refs when setting class's superclasses fails (dkf)

2020-02-26 (bug) C++ compiler compatibility for registry and dde (nijtmans)
=> registry 1.4.3
=> dde 1.3.5

2020-03-05 (new) Update to Unicode-13 (nijtmans)

2020-03-16 (bug)[8f89e2] Win: env var encoding, env-2.5 (sebres, nijtmans)

2020-03-27 (bug)[767e07] Tcl_Get(Range|UniChar) validate index inputs (nijtmans)

2020-03-28 (bug)[8edfce] [binary encode base64] & multi-byte wrapchars (dgp)

2020-03-28 (bug)[ffeb20] [binary decode base64] ignore invalid chars (dgp)
See RFC 2045
        *** POTENTIAL INCOMPATIBILITY ***

2020-03-31 (bug)[b8e82d] some -maxlen values break uuencode round trip (dgp)
        *** POTENTIAL INCOMPATIBILITY ***

2020-04-01 (bug)[f58371] Fileevent run in proper thread (bron,sebres)

2020-04-13 (bug)[afa4b2] TclNeedSpace bug; tests util-8.5 .. util-8.11 (dgp)

2020-04-13 (bug)[085913] Tcl_DStringAppendElement # quoting precision (dgp)
        *** POTENTIAL INCOMPATIBILITY ***

2020-04-13 (bug)[a7f685] test util-5.52 (dgp)

2020-04-13 (bug)[c61818] Tcl_UtfPrev regression (dgp)

2020-04-15 (bug)[8af92d] zlib transform issue, bad inflate (sebres)

2020-04-16 (bug)[5e6346] Tcl_UtfPrev handling of overlong sequences (dgp)

2020-04-27 (bug)[45ca23] [string tolower] inconsistency (dgp)

2020-04-30 (bug)[da2352] init [info hostname] with DNS, not NetBIOS (nadkarni)

2020-05-11 (bug)[d402ff] Win32 potential crash when using main() (werner)

2020-05-13 (bug)[81242a] revised documentation for Tcl_UtfAtIndex() (nijtmans)
        *** POTENTIAL INCOMPATIBILITY ***

2020-05-13 (bug)[ed2980] Tcl_UtfToUniChar reads > TCL_UTF_MAX bytes (nijtmans)
        *** POTENTIAL INCOMPATIBILITY ***

2020-06-02 (bug) prevent segfault in parser (sebres)

2020-06-21 (bug)[f81bec] http POST a binary file (alakendu,nash)
=> http 2.9.2

2020-06-23 (bug)[41c985] auto_path nonsense in Safe Base (nash)

2020-06-24 (bug)[f70ce1] zlib multi-stream inflate acts only on first (sebres)

2020-07-09 (bug)[a1bd37] [clock scan] new ISO format (clock-34.(19-24)) (sebres)
        *** POTENTIAL INCOMPATIBILITY ***

2020-07-10 (bug)[501974] [clock scan] +time zone (clock-34.(53-68)) (sebres)
        *** POTENTIAL INCOMPATIBILITY ***

2020-07-15 (bug)[3c6e47] compiled [lappend] performance, avoid copy (sebres)

2020-07-16 (bug)[5bbd04] Fix index underflow (schwab)

2020-07-27 (bug)[cb0373] http::geturl -keepalive fixes (nash)
=> http 2.9.3

2020-08-10 (bug)[29e884] cmd resolution cycle (namespace-57.0) (coulter,sebres)

2020-08-12 (bug)[e87000] Tcl_BadChannelOption tolerate NULL (werner,nijtmans)

2020-08-31 (TIP #581) disfavor Master/Slave terminology (nijtmans)
=> opt 0.4.8

2020-09-11 (bug)[3bc0f4] UBSan complains about body.chars[] usage (nijtmans)

2020-09-17 (bug)[835c93] Support TIP 525 exit code for -singleproc 1 (nijtmans)
=> tcltest 2.5.3

2020-09-25 (new) force -eofchar \032 when evaluating library scripts (nijtmans)
        *** POTENTIAL INCOMPATIBILITY ***

2020-09-29 (bug)[0063cb] http::geturl -headers must be dict (oehlmann,nijtmans)

2020-10-19 (bug)[cb4582] Update install-sh script (stu,nijtmans)

2020-10-22 (bug)[c97593] Usage of gnu_printf in latest mingw-w64 (nijtmans)

2020-10-26 (new)[48898a] improve error message consistency (stu)
        *** POTENTIAL INCOMPATIBILITY ***

2020-11-06 (new) revised case of module names (nijtmans)
        *** POTENTIAL INCOMPATIBILITY ***

2020-12-10 (bug)[ed5be7] Win: recognize "comx:" as serial port (oehlmann)

2020-12-11 (new) support for msys2, Big Sur (nijtmans)
=> platform 1.0.15

2020-12-23 tzdata updated to Olson's tzdata2020e (jima)

Revision 1.26: download - view: text, markup, annotated - select for diffs
Thu Apr 16 17:07:07 2020 UTC (5 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +6 -6 lines
tcl/tk: updated to 8.6.10

Changes in Tcl/Tk 8.6.10

Tcl Changes
New unsupported commands
tcl::unsupported::timerate
tcl::unsupported::corotype

Tk Changes

New Commands
tk::mac::PerformService
tk::mac::LaunchURL
tk::mac::GetAppPath
tk::mac::PrintDocument

Expanded Syntax / New Options
menubutton post x y index
combobox current end

Updated packages
http 2.9.1
Itcl 4.2.0
Thread 2.8.5
sqlite 3.30.1
tdbc 1.1.1

Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Nov 3 19:04:09 2019 UTC (5 years, 5 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +5 -5 lines
lang: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sun Dec 9 18:33:55 2018 UTC (6 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +6 -6 lines
tcl: updated to 8.6.9

8.6.9:
* (enhance) stop blocking conversion of object to/from class
* (enhance) NR-enable [package require]
* (bug)[9fd5c6] crash in object deletion, test oo-11.5
* (bug)[3c32a3] crash deleting object with class mixed in
* (platform) stop using -lieee, removed from glibc-2.27
***POTENTIAL INCOMPATIBILITY for math programs that embed Tcl***
* (bug)[8e6a9a] bad binary [string match], test string-11.55
* (bug)[1873ea] repair multi-thread std channel init
* (bug)[db36fa] broken bytecode for index values
* (bug) broken compiled [string replace], test string-14.19
* (bug) [string trim*] engine crashed on invalid UTF
* (bug) missing trace in compiled [array set], test var-20.11
* (bug)[46a241] crash in unset array with search, var-13.[23]
* (bug)[27b682] race made [file delete] raise "no such file"
* (bug)[925643] 32/64 cleanup of filesystem DIR operations
* (bug) leaks in TclSetEnv and env cache
* (bug)[3592747] [yieldto] dying namespace, tailcall-14.1
* (bug)[270f78] race in [file mkdir]
* (bug)[3f7af0] [file delete] raised "permission denied"
* (bug)[d051b7] overflow crash in [format]
* revised quoting of [exec] args in generated command line
***POTENTIAL INCOMPATIBILITY***
* HTTP Keep-Alive with pipelined requests
=> http 2.9.0
* (new)[TIP 505] [lreplace] accepts all out of range indices
* (bug) Prevent crash from NULL keyName
=> registry 1.3.3
* (enhance) advance dde version
=> dde 1.4.1
* tzdata updated to Olson's tzdata2018g
* Update tcltest package for Travis support
=> tcltest 2.5.0
* (bug)[35a8f1] overlong string length of some lists
* (bug)[00d04c] Repair [binary encode base64]

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sat Feb 3 17:51:19 2018 UTC (7 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +6 -6 lines
tcl: updated to 8.6.8

8.6.8:
[array names -regexp] supports backrefs
Fix gcc build failures due to #pragma placement
(bug)[b50fb2] exec redir append stdout and stderr to file
(bug)[2a9465] http state 100 continue handling broken
(bug)[0e4d88] replace command, delete trace kills namespace
(bug)[1a5655] [info * methods] includes mixins
tzdata updated to Olson's tzdata2017c
(bug)[fc1409] segfault in method cloning, oo-15.15
(bug)[6f2f83] More robust [load] for ReactOS
(bug)[3298012] Stop crash when hash tables overflow 32 bits
(bug)[5d6de6] Close failing case of [package prefer stable]
(bug)[fab924] Fix misleading [load] message on Windows
(bug)[4f6a1e] Crash when ensemble map and list are same
(bug)[ce3a21] file normalize failure when tail is empty
(new)[TIP 477] nmake build system reform
(bug)[586e71] EvalObjv exception handling at level 0

Revision 1.22: download - view: text, markup, annotated - select for diffs
Fri Aug 25 11:05:33 2017 UTC (7 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +6 -4 lines
Changes 8.6.7:
Bug fixes.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Fri Oct 21 11:45:44 2016 UTC (8 years, 6 months ago) by kamil
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +4 -2 lines
Export TDBC_VERSION like ITCL_VERSION.

Use these versions as well in Makefile and PLIST.

It's unclear whether buildlink3.mk might include Makefile.version, this
is the reason to duplicate this information.

There are other packages that might be versioned similarily:
 - sqlite3,
 - thread.

No user-visible change in the main package.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Oct 21 01:44:24 2016 UTC (8 years, 6 months ago) by kamil
Branches: MAIN
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +3 -1 lines
Provide bundled itcl version (ITCL_VERSION) in buildlink3.mk

Packages need to know files with ITCL of current TCL version.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Sat Sep 3 11:58:01 2016 UTC (8 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
Changes 8.6.6:
Bug-fix release.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sun Mar 6 11:47:49 2016 UTC (9 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
Changes 8.6.5:
Bug fixes.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Sun Jun 28 17:11:12 2015 UTC (9 years, 10 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -1 lines
Fix build of tcl-pdflib against TCL 8.6.

Revision 1.16: download - view: text, markup, annotated - select for diffs
Thu May 21 10:37:59 2015 UTC (9 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
Changes 8.6.4:
Bug fixes and improvements.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sat Nov 22 15:57:17 2014 UTC (10 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
Changes 8.6.3:
Correct Method Search Order
Regression [lreplace {} 1 1]
Crash regression in [oo::class destroy]
Regress [regsub -all {\(.*} a(b) {}]
[try {} on ok {} - on return {} {}] panic
[tcl::unsupported::getbytecode] disassember
[string cat] bytecode optimization
segfault in mangled bytecode
Hang in some [read]s of limited size
segfault in [array set] of traced array
MSVC14 compile support
[fcopy] treats [blocked] as error
regression in Tcl_Write() interface
fix [gets] on non-blocking channels
restore [open comX: r+]
Restore [lappend v] return value
Stop forcing EOF to be permanent

Revision 1.14: download - view: text, markup, annotated - select for diffs
Fri Oct 31 21:11:18 2014 UTC (10 years, 6 months ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +6 -2 lines
Changes 8.6.2:
This is a bug-fix release.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Jan 11 14:41:05 2014 UTC (11 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -4 lines
Changes 8.6.1:
* object-oriented programming support
* a stackless evaluation implementation
and much more besides.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sat Nov 2 20:22:02 2013 UTC (11 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Changes 8.5.15:
Bug-fix release.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri May 31 20:15:04 2013 UTC (11 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
Changes 8.5.14:
Bug-fix release.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Nov 24 21:38:49 2012 UTC (12 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Changes 8.5.13:
* --enable-aqua build for Mac OS X is now a Cocoa implementation.
* Support has been added for Cygwin network pathnames.
* Updated to Unicode 6.2 support. Fixes for several crashes and bugs.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Tue Aug 21 21:31:47 2012 UTC (12 years, 8 months ago) by marino
Branches: MAIN
CVS tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +4 -2 lines
lang/tcl: Upgrade from version 8.4.18 to 8.5.12

Highlights of Tcl 8.5
  * Features: 8.5 has over 90 TIPs included to provide a wide variety of
     new features.
  * Bignums: Tcl now supports arbitrary-precision integers, which improves
    math operations on large integers.
  * Safer interps: Tcl's powerful safe interpreter mechanism now has
    improved control of time and command limits in slave interpreters.
  * clock command: More robust implementation of command for specifying
    time, with significant l10n and i18n improvements.
  * dict command: New data structure that allows access to data by value
    rather than a variable name, which is substantially faster.
  * Additional improvements: Faster list search, new and improved
    mathematics procedures, anonymous procedures, new ways to package Tcl
    extensions, Tcl-level custom channel types, file and line location
    information for each command, and more.

There is of course much, much more.
See [8.5 Changes](http://wiki.tcl.tk/10630) on the wiki for a complete
list of new features.

Revision 1.7.4.1: download - view: text, markup, annotated - select for diffs
Sun May 18 15:34:59 2008 UTC (16 years, 11 months ago) by spz
Branches: pkgsrc-2008Q1
Diff to: previous 1.7: preferred, colored; next MAIN 1.8: preferred, colored
Changes since revision 1.7: +2 -2 lines
Pullup ticket 2388 - requested by tron
security update for tcl

Revisions pulled up:
- pkgsrc/lang/tcl/Makefile.version		1.8
- pkgsrc/lang/tcl/distinfo			1.42

   Module Name:	pkgsrc
   Committed By:	bjs
   Date:		Mon Apr  7 15:16:40 UTC 2008

   Modified Files:
   	pkgsrc/lang/tcl: Makefile.version distinfo

   Log Message:
   Update to version 8.4.18.  Distilled list of non-Windows changes:

   	* generic/tclInterp.c (Tcl_GetAlias): fix for [Bug 1882373]

   	* generic/regguts.h, generic/regc_color.c, generic/regc_nfa.c:
   	Fixes for problems created when processing regular expressions that
   	generate very large automata. An enormous number of thanks to Will
   	Drewry <wad@google.com>, Tavis Ormandy <taviso@google.com>, and Tom
   	Lane <tgl@sss.pgh.pa.us> from the Postgresql crowd for their help in
   	tracking these problems down. [Bug 1810264]

   	* unix/tclUnixCompat.c (TclpGetHostByName): Really applied
   	the change noted on 2007-11-13 by dkf below.

   	* generic/tclIOUtil.c (TclGetOpenMode): Only set the O_APPEND flag
   	* tests/ioUtil.test (ioUtil-4.1):	on a channel for the 'a'
   	mode and not for 'a+'. [Bug 1773127] (backport from HEAD)

   	* generic/tclCmdIL.c (Tcl_LsearchObjCmd): Prevent shimmering crash
   	when -exact and -integer/-real are mixed. [Bug 1844789]

   	* generic/tclThread.c: Back-port locking changes from Tcl8.5
   	in Tcl_Mutex/ConditionFinlize. Now we properly master-lock
   	the finalization of sync primitives.

   	* generic/regc_nfa.c:	Fixed infinite loop in the regexp compiler
   	* generic/regcomp.c:	[Bug 1810038].  Corrected looping logic in
   	* tests/regexp.test:	fixempties() to avoid wasting time walking a
   	list of dead states [Bug 1832612].  Convert optst() from expensive
   	no-op to a cheap no-op.  Improve newline usage in debug output.

   	* unix/tclUnixCompat.c (TclpGetHostByName): The six-argument form of
   	getaddressbyname_r() uses the fifth argument to indicate whether the
   	lookup succeeded or not on at least one platform. [Bug 1618235]

   	* generic/regc_lex.c (lexescape): Ensure that backreference numbers
   	can't overflow a signed int in a way that breaks things. [Bug 1810264]

   	* generic/tclParse.c (Tcl_ParseBraces): fix for possible read
   	after the end of buffer, [Bug 1813528] (Joe Mistachkin).

   	* generic/tclObj.c (Tcl_FindCommandFromObj): fix finding a deleted
   	command; cannot trigger this from Tcl itself, but crash reported
   	on xotcl. This check is new to 8.4 but exists in 8.5, so this is a
   	backport or something. Thanks Gustaf Neumann.

   	* generic/tcl.h (Tcl_DecrRefCount): Update change from 2006-05-29
   	to make macro more warning-robust in unbraced if code.


   To generate a diff of this commit:
   cvs rdiff -r1.7 -r1.8 pkgsrc/lang/tcl/Makefile.version
   cvs rdiff -r1.41 -r1.42 pkgsrc/lang/tcl/distinfo

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Apr 7 15:16:40 2008 UTC (17 years ago) by bjs
Branches: MAIN
CVS tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines

Update to version 8.4.18.  Distilled list of non-Windows changes:

	* generic/tclInterp.c (Tcl_GetAlias): fix for [Bug 1882373]

	* generic/regguts.h, generic/regc_color.c, generic/regc_nfa.c:
	Fixes for problems created when processing regular expressions that
	generate very large automata. An enormous number of thanks to Will
	Drewry <wad@google.com>, Tavis Ormandy <taviso@google.com>, and Tom
	Lane <tgl@sss.pgh.pa.us> from the Postgresql crowd for their help in
	tracking these problems down. [Bug 1810264]

	* unix/tclUnixCompat.c (TclpGetHostByName): Really applied
	the change noted on 2007-11-13 by dkf below.

	* generic/tclIOUtil.c (TclGetOpenMode): Only set the O_APPEND flag
	* tests/ioUtil.test (ioUtil-4.1):	on a channel for the 'a'
	mode and not for 'a+'. [Bug 1773127] (backport from HEAD)

	* generic/tclCmdIL.c (Tcl_LsearchObjCmd): Prevent shimmering crash
	when -exact and -integer/-real are mixed. [Bug 1844789]

	* generic/tclThread.c: Back-port locking changes from Tcl8.5
	in Tcl_Mutex/ConditionFinlize. Now we properly master-lock
	the finalization of sync primitives.

	* generic/regc_nfa.c:	Fixed infinite loop in the regexp compiler
	* generic/regcomp.c:	[Bug 1810038].  Corrected looping logic in
	* tests/regexp.test:	fixempties() to avoid wasting time walking a
	list of dead states [Bug 1832612].  Convert optst() from expensive
	no-op to a cheap no-op.  Improve newline usage in debug output.

	* unix/tclUnixCompat.c (TclpGetHostByName): The six-argument form of
	getaddressbyname_r() uses the fifth argument to indicate whether the
	lookup succeeded or not on at least one platform. [Bug 1618235]

	* generic/regc_lex.c (lexescape): Ensure that backreference numbers
	can't overflow a signed int in a way that breaks things. [Bug 1810264]

	* generic/tclParse.c (Tcl_ParseBraces): fix for possible read
	after the end of buffer, [Bug 1813528] (Joe Mistachkin).

	* generic/tclObj.c (Tcl_FindCommandFromObj): fix finding a deleted
	command; cannot trigger this from Tcl itself, but crash reported
	on xotcl. This check is new to 8.4 but exists in 8.5, so this is a
	backport or something. Thanks Gustaf Neumann.

	* generic/tcl.h (Tcl_DecrRefCount): Update change from 2006-05-29
	to make macro more warning-robust in unbraced if code.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Oct 13 11:41:44 2007 UTC (17 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2008Q1-base, pkgsrc-2007Q4-base, pkgsrc-2007Q4
Branch point for: pkgsrc-2008Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Changes 8.4.16:
* Bug fixes
* Improvements

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu May 31 13:01:53 2007 UTC (17 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Changes 8.4.15:
* Minor bugfixes

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Nov 2 17:41:23 2006 UTC (18 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Changes 8.4.14:
  * Tk_PhotoPutBlock performance restored (JPEG image loading).
  * [namespace inscope] change reverted; harmed Itcl.
  * Made [expr {srand(.)}] accept wide integer argument.
  * Made [lappend $invalidList] raise an error.
  * Improved [text] delete performance.
  * Support for the WM_UNICHAR window message on Windows
  * Stopped excess variable writes by [scale].
  * Tcl_Main no longer blocks main loop start for one interactive command.
  * [console] made thread safe.
  * Thread-enabled configuration uses MT-safe system calls.
  * Many Aqua/Tk bug fixes and improvements, see changes file.
  * Made unthreaded notifier naked-fork-safe on Darwin.
  * Support for weak linking on Mac OS X.
  * msgcat support for CFLocale on Darwin (msgcat 1.3.4)
  * Fixed crashes due to alignment issues in encoding translation routines.
  * Fixed crash with [listbox -listvariable] on namespace variable.
  * Fixed crash when Tcl_DeleteTrace changes proc on the active stack.
  * Fixed crash when normalizing filesystem pathnames.
  * Fixed crash due to invalid font name from XServer.
  * Several 64-bit bugs fixed and platform support enhanced.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Apr 27 08:17:09 2006 UTC (19 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Changes 8.4.13:
* Win NT/XP: unicode console support taken back out.
* ${prefix}/share addition to ::tcl_pkgPath undone.
* Warning message for packages with incorrect index scripts silenced.
* Correct syntax error in configure script (bash 3.1 exposes it).
* Tk incompatibilities with SCIM resolved.
* Improved [file writable] support of Windows conventions.
* Tcl_GetIndexFromObj() support for exact matching of empty key.
* Tk Portuguese localization support (pt.msg).
* Tk more robust when X server does not recognize color name "Black".
* Tk_PhotoPutBlock() performance improvement.
* [lsearch -start $pastEnd] no longer finds match at end of list.
* Correct [expr abs($LONG_MIN)] result.
* Correct [string range] failures on some strings containing \x00.
* TCL_EVAL_GLOBAL and [uplevel 0] agreement when traces or [unknown] active.
* Corrections to context of auto-loading the target of an interp alias.
* Corrected some interference between enter and enterstep traces.
* Correct [$img configure -data] failure to change X display.
* Tk_GetBitmapFromData() thread safety.
* Crashes in [grid] for some invalid index arguments.
* Crash when all content of a [text] is elided.
* Crash in [$text edit undo/redo].
* Crash in animated GIF display with variable frame size.
* Crash related to pipe usage in thread-enabled Tcl on Windows.
* Crash when [$text dump -command] changes contents while dumping.
* Crash reading utf-8 when multibyte char spans multiple buffers at EOF.
* Several finalization crashes corrected.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Jan 16 14:47:35 2006 UTC (19 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Changes 8.4.12:
  * Repeated [namespace import] of same command now permitted.
  * ${prefix}/share added to ::tcl_pkgPath on some systems.
  * [exec]'s >> redirection has improved append behavior.
  * [info globals] returned only existing variables.
  * Recognize some Solaris variations of the cp1251 encoding.
  * Addressed [file mkdir] race condition.
  * Support opening >2GB files on RHEL 3.
  * Corrections to $argv formatting when [encoding system] is multibyte.
  * http 2.5.2: Update URL encoding rules to RFC 3986.
  * Fixed issue in recursive file delete with NFS lock files.
  * Stopped crash after use of Tcl_TraceCommand().
  * Win NT/XP: support unicode console.
  * Improved support for Tclkit to set [encoding system].
  * Added Korean timezone abbreviations.
  * Windows: exit codes can now exceed -128..127 range.
  * [load] support on LynxOS.
  * Packages with incorrect index scripts now cause a warning to be logged.
        *** POTENTIAL INCOMPATIBILITY ***
  * [lsearch -regexp] now accepts backrefs in the RE.
  * [selection get] made compatible with OpenOffice.org.
  * Dialog support for widget names containing spaces.
  * Improved Tk window manager event interaction on OS X Aqua.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Jul 19 11:11:58 2005 UTC (19 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Changes 8.4.11:
* Bug fixes

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Jan 13 14:37:43 2005 UTC (20 years, 3 months ago) by minskim
Branches: MAIN
CVS tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2, pkgsrc-2005Q1-base, pkgsrc-2005Q1
Define TCL_VERSION in a separate file so that it can be included by
other packages (e.g. tcl-tclX).

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>