File:  [cvs.NetBSD.org] / pkgsrc / lang / scm / Makefile
Revision 1.26: download - view: text, annotated - select for diffs
Wed Nov 25 12:51:17 2015 UTC (9 years, 3 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, HEAD
Remove mk/find-prefix.mk usage from the lang category.

The find-prefix infrastructure was required in a pkgviews world where
packages installed from pkgsrc could have different installation
prefixes, and this was a way for a dependency prefix to be determined.

Now that pkgviews has been removed there is no longer any need for the
overhead of this infrastructure.  Instead we use BUILDLINK_PREFIX.pkg
for dependencies pulled in via buildlink, or LOCALBASE/PREFIX where the
dependency is coming from pkgsrc.

Provides a reasonable performance win due to the reduction of `pkg_info
-qp` calls, some of which were redundant anyway as they were duplicating
the same information provided by BUILDLINK_PREFIX.pkg.

# $NetBSD: Makefile,v 1.26 2015/11/25 12:51:17 jperkin Exp $
#
# Convert the version number as follows 2d2 -> 2.4.2, where the d is
# changed to a 4, representing the 4th letter.
# Thus, 5e3 -> 5.5.3
#
# Do not forget to update InitXXX.scm in files/buildscm.scm

DISTNAME=	scm5e3
PKGNAME=	scm-5.5.3
PKGREVISION=	2
CATEGORIES=	lang
MASTER_SITES=	http://swissnet.ai.mit.edu/ftpdir/scm/
EXTRACT_SUFX=	.zip

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.swiss.ai.mit.edu/~jaffer/SCM
COMMENT=	Portable scheme interpreter

DEPENDS+=	slib>=3.1.1:../../devel/slib

WRKSRC=		${WRKDIR}/scm
INFO_FILES=	yes

LDFLAGS.SunOS+=	-lsocket -lnsl

SCM_MODULES+=	sc2 ramap dynl edline gsubr ioext posix record rgx socket
SCM_MODULES+=	unix  continue scm scmmain findexec script time repl scl eval
SCM_MODULES+=	sys subr debug unif rope unexelf
COMPILED_INITS+=init_edline

.include "options.mk"

SRCS=		${SCM_MODULES:=.c}
OBJS=		${SCM_MODULES:=.o}

BUILD_TARGET=	scmlit libscm.a
INSTALL_TARGET=	install installlib

INSTALL_MAKE_FLAGS+=	PREFIX=${DESTDIR}${PREFIX} \
			mandir=${DESTDIR}${PREFIX}/${PKGMANDIR}/

INSTALLATION_DIRS=	${PKGINFODIR} share/scm

.include "../../mk/readline.buildlink3.mk"

post-extract:
	${SED} -e "s|@SLIB_PREFIX@|"${LOCALBASE}"|g"		\
		${FILESDIR}/require.scm > ${WRKSRC}/require.scm
	${SED} -e "s|@PREFIX@|"${PREFIX:Q}"|g"				\
		-e "s|@COMPILED_INITS@|${COMPILED_INITS:=();}|g"	\
		${FILESDIR}/buildscm.sh  > ${WRKSRC}/buildscm.sh

post-build:
	cd ${WRKSRC} && env ${MAKE_ENV} LIBS=${LIBS:Q} \
		SRCS=${SRCS:Q} OBJS=${OBJS:Q} \
		${SH} ./buildscm.sh

post-install:
	${INSTALL_DATA} ${WRKSRC}/slibcat ${DESTDIR}${PREFIX}/share/scm
	cd ${WRKSRC}; for f in *.info *.info-[0-9]*; do			\
		${TEST} ! -f "$$f" ||					\
		${INSTALL_DATA} "$$f" ${DESTDIR}${PREFIX}/${PKGINFODIR};		\
	done

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>