The NetBSD Project

CVS log for pkgsrc/lang/ruby30-base/Attic/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / lang / ruby30-base

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.8, Sat Sep 9 14:18:19 2023 UTC (7 months ago) by taca
Branch: MAIN
CVS Tags: HEAD
Changes since 1.7: +1 -1 lines
FILE REMOVED

lang/ruby30-base: remove package

Removing Ruby 3.0 package.

* There is no need to use Ruby 3.0, Ruby 3.1 has enough compatibility.
* Ruby 3.0 dose not support OpenSSL 3.

So it cost to keep it now.

Revision 1.6.2.1 / (download) - annotate - [select for diffs], Sat Apr 16 09:23:40 2022 UTC (23 months, 3 weeks ago) by spz
Branch: pkgsrc-2022Q1
Changes since 1.6: +7 -1 lines
Diff to previous 1.6 (colored) next main 1.7 (colored)

Pullup ticket #6617 - requested by taca
lang/ruby30-base: security update

Revisions pulled up:
- lang/ruby/rubyversion.mk                                      1.248
- lang/ruby30-base/Makefile                                     1.6
- lang/ruby30-base/PLIST                                        1.7
- lang/ruby30-base/distinfo                                     1.8
- lang/ruby30/Makefile                                          1.3

-------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Tue Apr 12 14:52:27 UTC 2022

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk
   	pkgsrc/lang/ruby30: Makefile
   	pkgsrc/lang/ruby30-base: Makefile PLIST distinfo

   Log Message:
   lang/ruby30-base: update to 3.0.4

   Ruby 3.0.4 has been released.

   This release includes security fixes.  Please check the topics below for
   details.

   * CVE-2022-28738: Double free in Regexp compilation
   * CVE-2022-28739: Buffer overrun in String-to-Float conversion

   See the commit logs for further details.


   To generate a diff of this commit:
   cvs rdiff -u -r1.247 -r1.248 pkgsrc/lang/ruby/rubyversion.mk
   cvs rdiff -u -r1.2 -r1.3 pkgsrc/lang/ruby30/Makefile
   cvs rdiff -u -r1.5 -r1.6 pkgsrc/lang/ruby30-base/Makefile
   cvs rdiff -u -r1.6 -r1.7 pkgsrc/lang/ruby30-base/PLIST
   cvs rdiff -u -r1.7 -r1.8 pkgsrc/lang/ruby30-base/distinfo

Revision 1.7 / (download) - annotate - [select for diffs], Tue Apr 12 14:52:27 2022 UTC (2 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.6: +7 -1 lines
Diff to previous 1.6 (colored)

lang/ruby30-base: update to 3.0.4

Ruby 3.0.4 has been released.

This release includes security fixes.  Please check the topics below for
details.

* CVE-2022-28738: Double free in Regexp compilation
* CVE-2022-28739: Buffer overrun in String-to-Float conversion

See the commit logs for further details.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Jan 14 16:16:07 2022 UTC (2 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base
Branch point for: pkgsrc-2022Q1
Changes since 1.5: +13 -1 lines
Diff to previous 1.5 (colored)

lang/ruby30-base: take in ruby-fiddle pacakge

Stop separating ruby-fiddle package and take in it since devel/ruby-fiddle
lacks its rubygem's meta data and I have no idea to add them to it.

Bump PKGREVISION.

Revision 1.5 / (download) - annotate - [select for diffs], Fri Jan 14 15:42:09 2022 UTC (2 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.4: +1084 -1084 lines
Diff to previous 1.4 (colored)

lang/ruby: clean up some macro handling

1. Move some variables from gem-vars.mk to rubyversion.mk:

	GEM_EXTSBASE
	GEM_PATH
	GEM_PLUGINSDIR
	RUBYGEM
	RUBY_GEM_ARCH

2. Drop unused GEM_EXTSDIR_NEEDS_SUBDIR (it is always true).

3. Define bundled module's version as "MODULE_VER".

4. Generate PLIST_SUBST and PRINT_PLIST_AWK from bundled module's name
   if corresponding MODULE_VER is defined.

5. Do not run ${RUBYGEM} for RUYB_GEM_ARCH and RUBY_GEM_VER.

NFCI.

Revision 1.3.2.1 / (download) - annotate - [select for diffs], Sat Nov 27 22:11:20 2021 UTC (2 years, 4 months ago) by tm
Branch: pkgsrc-2021Q3
Changes since 1.3: +88 -29 lines
Diff to previous 1.3 (colored) next main 1.4 (colored)

Pullup ticket #6547 - requested by taca
lang/ruby30-base: security fix

Revisions pulled up:
- lang/ruby/rubyversion.mk                                      1.240
- lang/ruby30-base/PLIST                                        1.4
- lang/ruby30-base/distinfo                                     1.7
- lang/ruby30-base/patches/patch-lib_rubygems_installer.rb      1.2

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Thu Nov 25 16:35:52 UTC 2021

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk
   	pkgsrc/lang/ruby30-base: PLIST distinfo
   	pkgsrc/lang/ruby30-base/patches: patch-lib_rubygems_installer.rb

   Log Message:
   lang/ruby30-base: update to 3.0.3

   Ruby 3.0.3 Released
   Posted by nagachika on 24 Nov 2021

   Ruby 3.0.3 has been released.

   This release includes security fixes.  Please check the topics below for
   details.

   * CVE-2021-41817: Regular Expression Denial of Service Vulnerability of Date
     Parsing Methods

   * CVE-2021-41816: Buffer Overrun in CGI.escape_html

   * CVE-2021-41819: Cookie Prefix Spoofing in CGI::Cookie.parse

   See the commit logs for details.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Nov 25 16:35:52 2021 UTC (2 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.3: +88 -29 lines
Diff to previous 1.3 (colored)

lang/ruby30-base: update to 3.0.3

Ruby 3.0.3 Released
Posted by nagachika on 24 Nov 2021

Ruby 3.0.3 has been released.

This release includes security fixes.  Please check the topics below for
details.

* CVE-2021-41817: Regular Expression Denial of Service Vulnerability of Date
  Parsing Methods

* CVE-2021-41816: Buffer Overrun in CGI.escape_html

* CVE-2021-41819: Cookie Prefix Spoofing in CGI::Cookie.parse

See the commit logs for details.

Revision 1.2.2.1 / (download) - annotate - [select for diffs], Mon Jul 12 12:54:47 2021 UTC (2 years, 9 months ago) by bsiegert
Branch: pkgsrc-2021Q2
Changes since 1.2: +5 -2 lines
Diff to previous 1.2 (colored) next main 1.3 (colored)

Pullup ticket #6485 - requested by taca
lang/ruby30-base: security fix

Revisions pulled up:
- lang/ruby/rubyversion.mk                                      1.234-1.235
- lang/ruby30-base/PLIST                                        1.3
- lang/ruby30-base/distinfo                                     1.3

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Wed Jul  7 16:10:01 UTC 2021

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk
   	pkgsrc/lang/ruby30-base: PLIST distinfo

   Log Message:
   lang/ruby30-base: update to 3.0.2

   Ruby 3.0.2 has been released.

   This release includes security fixes.  Please check the topics below
   for details.

   * CVE-2021-31810: Trusting FTP PASV responses vulnerability in Net::FTP
   * CVE-2021-32066: A StartTLS stripping vulnerability in Net::IMAP
   * CVE-2021-31799: A command injection vulnerability in RDoc

   See the commit logs for details:
   <https://github.com/ruby/ruby/compare/v3_0_1...v3_0_2>.

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Wed Jul  7 16:11:57 UTC 2021

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk

   Log Message:
   lang/ruby: make sure to update ruby30's version

Revision 1.3 / (download) - annotate - [select for diffs], Wed Jul 7 16:10:01 2021 UTC (2 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base
Branch point for: pkgsrc-2021Q3
Changes since 1.2: +5 -2 lines
Diff to previous 1.2 (colored)

lang/ruby30-base: update to 3.0.2

Ruby 3.0.2 has been released.

This release includes security fixes.  Please check the topics below
for details.

* CVE-2021-31810: Trusting FTP PASV responses vulnerability in Net::FTP
* CVE-2021-32066: A StartTLS stripping vulnerability in Net::IMAP
* CVE-2021-31799: A command injection vulnerability in RDoc

See the commit logs for details:
<https://github.com/ruby/ruby/compare/v3_0_1...v3_0_2>.

Revision 1.1.2.1 / (download) - annotate - [select for diffs], Thu Apr 15 07:53:24 2021 UTC (2 years, 11 months ago) by bsiegert
Branch: pkgsrc-2021Q1
Changes since 1.1: +49 -32 lines
Diff to previous 1.1 (colored) next main 1.2 (colored)

Pullup ticket #6445 - requested by taca
lang/ruby30-base: security fix

Revisions pulled up:
- lang/ruby/Makefile                                            1.69
- lang/ruby/rubyversion.mk                                      1.230
- lang/ruby30-base/ALTERNATIVES                                 1.2
- lang/ruby30-base/Makefile                                     1.2
- lang/ruby30-base/PLIST                                        1.2
- lang/ruby30-base/distinfo                                     1.2

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Sun Apr 11 12:36:28 UTC 2021

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk
   	pkgsrc/lang/ruby30-base: ALTERNATIVES Makefile PLIST distinfo

   Log Message:
   lang/ruby30-base: update to 3.0.1

   Ruby 3.0.1 Released (2021-04-05)

   Ruby 3.0.1 has been released.

   This release includes security fixes.  Please check the topics below
   for details.

   * CVE-2021-28965: XML round-trip vulnerability in REXML
   * CVE-2021-28966: Path traversal in Tempfile on Windows

   See the commit logs for details.

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Sun Apr 11 12:43:17 UTC 2021

   Modified Files:
   	pkgsrc/lang/ruby: Makefile

   Log Message:
   lang/ruby: reset PKGREVISION

   Reset PKGREVISION with updates of all ruby{26,27,30}.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Apr 11 12:36:28 2021 UTC (3 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base
Branch point for: pkgsrc-2021Q2
Changes since 1.1: +50 -33 lines
Diff to previous 1.1 (colored)

lang/ruby30-base: update to 3.0.1

Ruby 3.0.1 Released (2021-04-05)

Ruby 3.0.1 has been released.

This release includes security fixes.  Please check the topics below
for details.

* CVE-2021-28965: XML round-trip vulnerability in REXML
* CVE-2021-28966: Path traversal in Tempfile on Windows

See the commit logs for details.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Feb 14 14:32:41 2021 UTC (3 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base
Branch point for: pkgsrc-2021Q1

lang/ruby30-base: add version 3.0.0 package

Ruby is the interpreted scripting language for quick and easy Object
Oriented Programming.  It has many features to process text files and to do
system management tasks (as in Perl).  It is simple, straight-forward, and
extensible.

Features of Ruby are shown below.

  + Simple Syntax
  + *Normal* Object-Oriented features (ex. class, method calls)
  + *Advanced* Object-Oriented features (ex. Mix-in, Singleton-method)
  + Operator Overloading
  + Exception Handling
  + Iterators and Closures
  + Garbage Collection
  + Dynamic Loading of Object files (on some architecture)
  + Highly Portable (works on many UNIX machines, and on DOS, Windows,
    Mac, etc.)

Ruby 3.0 introduces a number of new features and performance
improvements, most notably:

  * Performance
	- MJIT
  * Concurrency
	- Ractor
	- Fiber Scheduler
  * Typing (Static Analysis)
	- RBS
	- TypeProf

This package is Ruby 3.0 release minimum base package.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>