[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / ruby24-base

Annotation of pkgsrc/lang/ruby24-base/Makefile, Revision 1.2

1.2     ! jperkin     1: # $NetBSD: Makefile,v 1.1 2017/06/18 13:45:11 taca Exp $
1.1       taca        2:
                      3: DISTNAME=      ${RUBY_DISTNAME}
                      4: PKGNAME=       ${RUBY_PKGPREFIX}-base-${RUBY_VERSION}
                      5: CATEGORIES=    lang ruby
                      6: MASTER_SITES=  ${MASTER_SITE_RUBY}
                      7:
                      8: MAINTAINER=    taca@NetBSD.org
                      9: HOMEPAGE=      ${RUBY_HOMEPAGE}
                     10: COMMENT=       Ruby ${RUBY_VERSION} release minimum base package
                     11:
                     12: RUBY_VERSIONS_ACCEPTED=        24
                     13:
1.2     ! jperkin    14: USE_LANGUAGES=         c99
1.1       taca       15: USE_TOOLS+=            pax yacc pkg-config
                     16: GNU_CONFIGURE=         yes
                     17: TEST_TARGET=           test
                     18: CONFIGURE_ARGS+=       --enable-shared --enable-install-static-library
                     19: WRKSRC=                        ${RUBY_WRKSRC}
                     20:
                     21: .include "options.mk"
                     22: .include "../../lang/ruby/platform.mk"
                     23:
                     24: .if !empty(RUBY_SUFFIX)
                     25: CONFIGURE_ARGS+= --program-suffix=${RUBY_SUFFIX}
                     26: CONFIGURE_ARGS+= --with-soname=${RUBY_NAME}
                     27: CONFIGURE_ARGS+= --with-ruby-version=${RUBY_VER_DIR}
                     28: CONFIGURE_ARGS+= --with-ruby-pc="ruby-${RUBY_VERSION}.pc"
                     29: .endif
                     30:
                     31: DOCS=  BSDL COPYING COPYING.ja ChangeLog LEGAL NEWS README.EXT README.EXT.ja \
                     32:        README.ja.md README.md doc/ChangeLog-1.8.0 doc/ChangeLog-1.9.3 \
                     33:        doc/ChangeLog-2.0.0 doc/ChangeLog-2.1.0 doc/ChangeLog-2.2.0 \
                     34:        doc/ChangeLog-2.3.0 doc/ChangeLog-2.4.0 doc/ChangeLog-YARV \
                     35:        doc/NEWS-1.8.7 doc/NEWS-1.9.1 doc/NEWS-1.9.2 doc/NEWS-1.9.3 \
                     36:        doc/NEWS-2.0.0 doc/NEWS-2.1.0 doc/NEWS-2.2.0 doc/NEWS-2.3.0 \
                     37:        doc/contributing.rdoc doc/contributors.rdoc doc/dtrace_probes.rdoc \
                     38:        doc/etc.rd.ja doc/forwardable.rd.ja doc/globals.rdoc \
                     39:        doc/images/boottime-classes.png doc/irb/irb-tools.rd.ja \
                     40:        doc/irb/irb.rd.ja doc/keywords.rdoc doc/maintainers.rdoc \
                     41:        doc/marshal.rdoc doc/pty/README.expect.ja doc/pty/README.ja \
                     42:        doc/regexp.rdoc doc/security.rdoc doc/shell.rd.ja \
                     43:        doc/standard_library.rdoc doc/syntax/assignment.rdoc \
                     44:        doc/syntax/calling_methods.rdoc doc/syntax/control_expressions.rdoc \
                     45:        doc/syntax/exceptions.rdoc doc/syntax/literals.rdoc \
                     46:        doc/syntax/methods.rdoc doc/syntax/miscellaneous.rdoc \
                     47:        doc/syntax/modules_and_classes.rdoc doc/syntax/precedence.rdoc \
                     48:        doc/syntax/refinements.rdoc doc/syntax.rdoc
                     49: EXT_DOCS=      syslog/syslog.txt
                     50:
                     51: BIGDECIMAL_EXAMPLES=   linear.rb nlsolve.rb pi.rb
                     52: OPENSSL_EXAMPLES=      c_rehash.rb cert2text.rb certstore.rb cipher.rb \
                     53:                        crlstore.rb echo_cli.rb echo_svr.rb gen_csr.rb \
                     54:                        smime_read.rb smime_write.rb wget.rb
                     55: REPLACE_RUBY=          bin/erb bin/gem bin/irb bin/rake bin/rdoc bin/ri \
                     56:                        gems/rake-${RUBY_RAKE_VERSION}/exe/rake \
                     57:                        gems/net-telnet-${RUBY_NET_TELNET_VERSION}/bin/console \
                     58:                        gems/net-telnet-${RUBY_NET_TELNET_VERSION}/bin/setup
                     59: REPLACE_RUBY_DIRS=     ext lib sample
                     60: INSTALLATION_DIRS=     bin ${PKGMANDIR}/man1 ${RUBY_DOC}/images \
                     61:                        ${RUBY_DOC}/irb ${RUBY_DOC}/pty ${RUBY_DOC}/ripper \
                     62:                        ${RUBY_DOC}/stringio ${RUBY_DOC}/syntax \
                     63:                        ${RUBY_EG}/bigdecimal ${RUBY_EG}/pty
                     64: # ${RUBY_ARCHINC} ${RUBY_ARCHLIB}
                     65: EMPTY_DIRS=            generator/template markup/simple_markup
                     66:
                     67: pre-configure:
                     68:        ${RM} -f ${WRKSRC}/ext/gdbm/extconf.rb
                     69:        ${RM} -f ${WRKSRC}/ext/fiddle/extconf.rb
                     70:        ${RM} -f ${WRKSRC}/ext/readline/extconf.rb
                     71:        ${RM} -f ${WRKSRC}/ext/tk/extconf.rb
                     72:        ${RM} -f ${WRKSRC}/ext/tk/tkutil/extconf.rb
                     73:        ${TOUCH} ${WRKSRC}/prelude.c
                     74:
                     75: pre-install:
                     76:        cd ${WRKSRC}/lib; \
                     77:                ${FIND} . \( -name '*.orig' -o -name '*.orig_dist' \) \
                     78:                -exec ${RM} -f {} \;
                     79: .for f in ${EMPTY_DIRS}
                     80:        ${RMDIR} ${WRKSRC}/lib/rdoc/${f} 2>/dev/null || ${TRUE}
                     81: .endfor
                     82:
                     83: post-install:
                     84: .for f in ${DOCS}
                     85:        ${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/${RUBY_DOC}/${f:C/^doc\///}
                     86: .endfor
                     87: .for f in ${EXT_DOCS}
                     88:        ${INSTALL_DATA} ${WRKSRC}/ext/${f} ${DESTDIR}${PREFIX}/${RUBY_DOC}
                     89: .endfor
                     90:        cd ${WRKSRC}/ext/ripper; ${PAX} -rw README ${DESTDIR}${PREFIX}/${RUBY_DOC}/ripper
                     91:        cd ${WRKSRC}/ext/stringio; ${PAX} -rw README.md ${DESTDIR}${PREFIX}/${RUBY_DOC}/stringio
                     92:        cd ${WRKSRC}/sample; ${PAX} -rw . ${DESTDIR}${PREFIX}/${RUBY_EG}
                     93: .for f in ${BIGDECIMAL_EXAMPLES}
                     94:        ${INSTALL_DATA} ${RUBY_WRKSRC}/ext/bigdecimal/sample/${f} \
                     95:                ${DESTDIR}${PREFIX}/${RUBY_EG}/bigdecimal
                     96: .endfor
                     97: .for f in ${OPENSSL_EXAMPLES}
                     98:        ${INSTALL_DATA} ${RUBY_WRKSRC}/sample/openssl/${f} \
                     99:                ${DESTDIR}${PREFIX}/${RUBY_EG}/openssl
                    100: .endfor
                    101:        ${CHMOD} -R g-w ${DESTDIR}${PREFIX}/${GEM_HOME}/gems
                    102:        ${RUBY_GENERATE_PLIST}
                    103:
                    104: .include "../../mk/bdb.buildlink3.mk"
                    105: .include "../../converters/libiconv/buildlink3.mk"
                    106: .include "../../devel/zlib/buildlink3.mk"
                    107: .include "../../security/openssl/buildlink3.mk"
                    108: .include "../../textproc/libyaml/buildlink3.mk"
                    109: .include "../../lang/ruby/Makefile.common"
                    110: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>