[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / ruby18-base

Annotation of pkgsrc/lang/ruby18-base/Makefile, Revision 1.59.2.1

1.59.2.1! sbd         1: # $NetBSD$
1.1       taca        2: #
                      3:
                      4: DISTNAME=      ${RUBY_DISTNAME}
1.29      taca        5: PKGNAME=       ${RUBY_PKGPREFIX}-base-${RUBY_VERSION_SUFFIX}
1.59.2.1! sbd         6: PKGREVISION=   3
1.1       taca        7: CATEGORIES=    lang ruby
                      8: MASTER_SITES=  ${MASTER_SITE_RUBY}
                      9:
                     10: MAINTAINER=    taca@NetBSD.org
                     11: HOMEPAGE=      ${RUBY_HOMEPAGE}
1.2       minskim    12: COMMENT=       Ruby 1.8 based release minimum package
1.58      taca       13: LICENSE=       gnu-gpl-v2 OR ruby-license
1.1       taca       14:
1.29      taca       15: RUBY_VERSION=  ${RUBY18_VERSION}
1.10      taca       16:
1.29      taca       17: CONFLICTS=     ${RUBY_PKGPREFIX}-dbm-[0-9]* \
                     18:                ${RUBY_PKGPREFIX}-digest-[0-9]* \
                     19:                ${RUBY_PKGPREFIX}-iconv-[0-9]* \
                     20:                ${RUBY_PKGPREFIX}-openssl-[0-9]* \
                     21:                ${RUBY_PKGPREFIX}-tcltk-[0-9]*
                     22:
1.40      ghen       23: PKG_DESTDIR_SUPPORT=   user-destdir
                     24:
1.29      taca       25: USE_LANGUAGES= c
1.43      taca       26: USE_TOOLS+=    pax yacc
1.29      taca       27: GNU_CONFIGURE= yes
                     28: TEST_TARGET=   test
                     29: CONFIGURE_ARGS+= --enable-shared \
1.10      taca       30:                --with-ssl-include="${BUILDLINK_PREFIX.openssl}/include" \
                     31:                --with-ssl-lib="${BUILDLINK_PREFIX.openssl}/lib"
1.31      taca       32: WRKSRC=                ${RUBY_WRKSRC}
1.35      dmcmahil   33:
1.57      taca       34: #
                     35: # Don't refrect pkgsrc's INSTALL macro since Ruby expect it could
                     36: # execute by unprivileged user.
                     37: #
                     38: CONFIGURE_ENV+=        INSTALL="${INSTALL} ${COPY}" \
                     39:                INSTALL_DATA= INSTALL_PROGRAM= INSTALL_SCRIPT=
                     40:
1.35      dmcmahil   41: .include "../../mk/compiler.mk"
                     42:
                     43: .if !empty(PKGSRC_COMPILER:Msunpro)
1.39      grant      44: LIBS.SunOS+=   -B static -lsunmath -B dynamic -lm
1.54      taca       45: LDFLAGS.SunOS+=        -L${SUNWSPROBASE}/lib ${COMPILER_RPATH_FLAG}${SUNWSPROBASE}/lib
1.46      taca       46: CONFIGURE_ENV+=        LDSHARED="${CC} -G"
1.35      dmcmahil   47: .else
                     48: LIBS.SunOS+=   -lm
                     49: .endif
1.1       taca       50:
                     51: # Ruby build process depends on config.status's content
                     52: CONFIG_STATUS_OVERRIDE=        # empty
                     53:
1.10      taca       54: MAKE_DIRS+=    ${RUBY_SITERIDIR}
1.30      taca       55: FILES_SUBST+=  DATE=${DATE:Q}
                     56:
                     57: .include "options.mk"
1.10      taca       58:
1.1       taca       59: .include "../../lang/ruby/rubyversion.mk"
                     60:
                     61: .if !empty(RUBY_SUFFIX)
1.13      rillig     62: CONFIGURE_ARGS+= --program-suffix=${RUBY_SUFFIX:Q}
1.1       taca       63: .endif
                     64:
1.10      taca       65: #
1.15      taca       66: # IRIX work around which should be fixed.
1.10      taca       67: #
1.41      jlam       68: PLIST_VARS+=   io
                     69: .if ${OPSYS} != "IRIX"
                     70: PLIST.io=      yes
1.5       jschauma   71: .endif
                     72:
1.19      taca       73: #
1.51      hasso      74: # Work around for ucontext(3). It was broken in older DragonFly
                     75: # versions and is slow in newer ones.
1.34      joerg      76: #
1.51      hasso      77: .if ${OPSYS} == "DragonFly"
1.34      joerg      78: CONFIGURE_ENV+=        ac_cv_header_ucontext_h=no
                     79: .endif
                     80:
                     81: #
1.27      taca       82: # work around for getaddrinfo(3)
1.19      taca       83: #
1.27      taca       84: .if ${OPSYS} == "Linux" || ${OPSYS} == "SunOS"
1.19      taca       85: CONFIGURE_ARGS+=       --enable-wide-getaddrinfo
                     86: .endif
                     87:
1.31      taca       88: DOCS=          COPYING COPYING.ja ChangeLog NEWS README \
1.1       taca       89:                README.EXT README.EXT.ja README.ja ToDo \
1.31      taca       90:                doc/ChangeLog-1.8.0 doc/NEWS-1.8.0 \
1.1       taca       91:                doc/forwardable.rd doc/forwardable.rd.ja \
1.31      taca       92:                doc/irb/irb-tools.rd.ja doc/irb/irb.rd doc/irb/irb.rd.ja \
                     93:                doc/shell.rd doc/shell.rd.ja
1.1       taca       94: EXT_DOCS=      bigdecimal/bigdecimal_en.html bigdecimal/bigdecimal_ja.html \
1.43      taca       95:                dl/doc/dl.txt etc/etc.txt etc/etc.txt.ja syslog/syslog.txt \
1.10      taca       96:                zlib/doc/zlib.rd
1.1       taca       97:
                     98: BIGDECIMAL_EXAMPLES=   linear.rb nlsolve.rb pi.rb
                     99: DL_EXAMPLES=           c++sample.C c++sample.rb drives.rb getch.rb libc.rb \
                    100:                        msgbox.rb msgbox2.rb stream.rb
1.10      taca      101: OPENSSL_EXAMPLES=      c_rehash.rb cert2text.rb cert_store_view.rb \
                    102:                        certstore.rb cipher.rb crlstore.rb echo_cli.rb \
                    103:                        echo_svr.rb gen_csr.rb smime_read.rb smime_write.rb \
                    104:                        wget.rb
1.1       taca      105: PTY_EXAMPLES=          expect_sample.rb script.rb shl.rb
                    106:
1.42      jlam      107: REPLACE_RUBY_DIRS=     bin ext lib sample
1.48      taca      108: REPLACE_RUBY=          ext/dl/h2rb
1.43      taca      109: INSTALLATION_DIRS=     bin ${RUBY_ARCHLIB} ${RUBY_DOC}/irb ${RUBY_DOC}/pty \
1.44      obache    110:                        ${RUBY_EG}/bigdecimal ${RUBY_EG}/dl \
1.43      taca      111:                        ${RUBY_EG}/openssl ${RUBY_EG}/pty
                    112: FIX_PERM=              ${RUBY_ARCHLIB}/digest.h ${RUBY_ARCHLIB}/dl.h \
                    113:                        ${RUBY_ARCHLIB}/dlconfig.h
1.1       taca      114:
                    115: pre-configure:
1.58      taca      116:        ${ECHO} >> ${WRKSRC}/version.h          # workaround for no EOL.
1.1       taca      117:        ${RM} -f ${WRKSRC}/ext/curses/extconf.rb
                    118:        ${RM} -f ${WRKSRC}/ext/gdbm/extconf.rb
                    119:        ${RM} -f ${WRKSRC}/ext/readline/extconf.rb
                    120:        ${RM} -f ${WRKSRC}/ext/tk/extconf.rb
                    121:
1.21      taca      122: pre-install:
1.29      taca      123:        cd ${WRKSRC}; ${FIND} . \( -name '*.orig' -o -name '*.orig_dist' \) \
                    124:                -exec ${RM} -f {} \;
1.1       taca      125:
                    126: post-install:
1.43      taca      127:        ${INSTALL_DATA} ${FILESDIR}/CHANGES.pkgsrc ${DESTDIR}${PREFIX}/${RUBY_DOC}
1.1       taca      128: .for f in ${DOCS}
1.43      taca      129:        ${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/${RUBY_DOC}/${f:C/^doc\///}
1.1       taca      130: .endfor
1.40      ghen      131:        ${INSTALL_SCRIPT} ${WRKSRC}/ext/dl/h2rb ${DESTDIR}${PREFIX}/bin/h2rb${RUBY_VER}
1.1       taca      132: .for f in ${EXT_DOCS}
1.43      taca      133:        ${INSTALL_DATA} ${WRKSRC}/ext/${f} ${DESTDIR}${PREFIX}/${RUBY_DOC}
1.1       taca      134: .endfor
1.43      taca      135:        cd ${WRKSRC}/ext/pty; ${PAX} -rw README.* ${DESTDIR}${PREFIX}/${RUBY_DOC}/pty
                    136:        cd ${WRKSRC}/sample; ${PAX} -rw . ${DESTDIR}${PREFIX}/${RUBY_EG}
1.1       taca      137: .for f in ${BIGDECIMAL_EXAMPLES}
                    138:        ${INSTALL_DATA} ${RUBY_WRKSRC}/ext/bigdecimal/sample/${f} \
1.43      taca      139:                ${DESTDIR}${PREFIX}/${RUBY_EG}/bigdecimal
1.1       taca      140: .endfor
                    141: .for f in ${DL_EXAMPLES}
                    142:        ${INSTALL_DATA} ${RUBY_WRKSRC}/ext/dl/sample/${f} \
1.43      taca      143:                ${DESTDIR}${PREFIX}/${RUBY_EG}/dl
1.1       taca      144: .endfor
1.10      taca      145: .for f in ${OPENSSL_EXAMPLES}
                    146:        ${INSTALL_DATA} ${RUBY_WRKSRC}/sample/openssl/${f} \
1.43      taca      147:                ${DESTDIR}${PREFIX}/${RUBY_EG}/openssl
1.10      taca      148: .endfor
1.1       taca      149: .for f in ${PTY_EXAMPLES}
1.43      taca      150:        ${INSTALL_DATA} ${WRKSRC}/ext/pty/${f} ${DESTDIR}${PREFIX}/${RUBY_EG}/pty
                    151: .endfor
                    152: .for f in ${FIX_PERM}
                    153:        ${CHMOD} ${SHAREMODE} ${DESTDIR}${PREFIX}/${f}
1.1       taca      154: .endfor
1.25      taca      155:        ${RUBY_GENERATE_PLIST}
1.1       taca      156:
                    157: .include "../../lang/ruby/Makefile.common"
                    158: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>