[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / ruby18-base

Annotation of pkgsrc/lang/ruby18-base/Makefile, Revision 1.33

1.33    ! rillig      1: # $NetBSD: Makefile,v 1.32 2007/04/06 14:47:52 taca Exp $
1.1       taca        2: #
                      3:
                      4: DISTNAME=      ${RUBY_DISTNAME}
1.32      taca        5: PKGREVISION=   1
1.29      taca        6: PKGNAME=       ${RUBY_PKGPREFIX}-base-${RUBY_VERSION_SUFFIX}
1.1       taca        7: CATEGORIES=    lang ruby
                      8: MASTER_SITES=  ${MASTER_SITE_RUBY}
                      9:
                     10: MAINTAINER=    taca@NetBSD.org
                     11: HOMEPAGE=      ${RUBY_HOMEPAGE}
1.2       minskim    12: COMMENT=       Ruby 1.8 based release minimum package
1.1       taca       13:
1.29      taca       14: RUBY_VERSION=  ${RUBY18_VERSION}
1.10      taca       15:
1.29      taca       16: CONFLICTS=     ${RUBY_PKGPREFIX}-dbm-[0-9]* \
                     17:                ${RUBY_PKGPREFIX}-digest-[0-9]* \
                     18:                ${RUBY_PKGPREFIX}-iconv-[0-9]* \
                     19:                ${RUBY_PKGPREFIX}-openssl-[0-9]* \
                     20:                ${RUBY_PKGPREFIX}-tcltk-[0-9]*
                     21:
                     22: USE_LANGUAGES= c
                     23: USE_TOOLS+=    yacc
                     24: GNU_CONFIGURE= yes
                     25: TEST_TARGET=   test
                     26: CONFIGURE_ARGS+= --enable-shared \
1.10      taca       27:                --with-ssl-include="${BUILDLINK_PREFIX.openssl}/include" \
                     28:                --with-ssl-lib="${BUILDLINK_PREFIX.openssl}/lib"
1.12      rillig     29: CONFIGURE_ENV+=                PREFIX=${PREFIX:Q}
1.31      taca       30: WRKSRC=                ${RUBY_WRKSRC}
1.33    ! rillig     31: LIBS.SunOS+=   -lsunmath -lm
1.1       taca       32:
                     33: # Ruby build process depends on config.status's content
                     34: CONFIG_STATUS_OVERRIDE=        # empty
                     35:
1.10      taca       36: MAKE_DIRS+=    ${RUBY_SITERIDIR}
1.30      taca       37: FILES_SUBST+=  DATE=${DATE:Q}
                     38:
                     39: .include "options.mk"
1.10      taca       40:
1.1       taca       41: .include "../../lang/ruby/rubyversion.mk"
                     42:
                     43: .if !empty(RUBY_SUFFIX)
1.13      rillig     44: CONFIGURE_ARGS+= --program-suffix=${RUBY_SUFFIX:Q}
1.1       taca       45: .endif
                     46:
1.10      taca       47: #
1.15      taca       48: # IRIX work around which should be fixed.
1.10      taca       49: #
1.5       jschauma   50: .if ${OPSYS} == "IRIX"
1.20      taca       51: PLIST_SUBST+=  HAS_IO="@comment "
1.5       jschauma   52: .else
1.20      taca       53: PLIST_SUBST+=  HAS_IO=
1.5       jschauma   54: .endif
                     55:
1.19      taca       56: #
1.27      taca       57: # work around for getaddrinfo(3)
1.19      taca       58: #
1.27      taca       59: .if ${OPSYS} == "Linux" || ${OPSYS} == "SunOS"
1.19      taca       60: CONFIGURE_ARGS+=       --enable-wide-getaddrinfo
                     61: .endif
                     62:
1.31      taca       63: DOCS=          COPYING COPYING.ja ChangeLog NEWS README \
1.1       taca       64:                README.EXT README.EXT.ja README.ja ToDo \
1.31      taca       65:                doc/ChangeLog-1.8.0 doc/NEWS-1.8.0 \
1.1       taca       66:                doc/forwardable.rd doc/forwardable.rd.ja \
1.31      taca       67:                doc/irb/irb-tools.rd.ja doc/irb/irb.rd doc/irb/irb.rd.ja \
                     68:                doc/shell.rd doc/shell.rd.ja
1.1       taca       69: EXT_DOCS=      bigdecimal/bigdecimal_en.html bigdecimal/bigdecimal_ja.html \
                     70:                dl/doc/dl.txt enumerator/enumerator.txt \
1.10      taca       71:                etc/etc.txt etc/etc.txt.ja syslog/syslog.txt \
                     72:                zlib/doc/zlib.rd
1.1       taca       73:
                     74: BIGDECIMAL_EXAMPLES=   linear.rb nlsolve.rb pi.rb
                     75: DL_EXAMPLES=           c++sample.C c++sample.rb drives.rb getch.rb libc.rb \
                     76:                        msgbox.rb msgbox2.rb stream.rb
1.10      taca       77: OPENSSL_EXAMPLES=      c_rehash.rb cert2text.rb cert_store_view.rb \
                     78:                        certstore.rb cipher.rb crlstore.rb echo_cli.rb \
                     79:                        echo_svr.rb gen_csr.rb smime_read.rb smime_write.rb \
                     80:                        wget.rb
1.1       taca       81: PTY_EXAMPLES=          expect_sample.rb script.rb shl.rb
                     82:
1.10      taca       83: REPLACE_RUBY_DIRS=     ${WRKSRC}/bin ${WRKSRC}/ext ${WRKSRC}/lib \
                     84:                        ${WRKSRC}/sample
1.1       taca       85:
                     86: pre-configure:
                     87:        ${RM} -f ${WRKSRC}/ext/curses/extconf.rb
                     88:        ${RM} -f ${WRKSRC}/ext/gdbm/extconf.rb
                     89:        ${RM} -f ${WRKSRC}/ext/readline/extconf.rb
                     90:        ${RM} -f ${WRKSRC}/ext/tk/extconf.rb
                     91:
1.21      taca       92: pre-install:
1.29      taca       93:        cd ${WRKSRC}; ${FIND} . \( -name '*.orig' -o -name '*.orig_dist' \) \
                     94:                -exec ${RM} -f {} \;
1.1       taca       95:
                     96: post-install:
                     97:        ${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/irb
                     98:        ${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/pty
1.10      taca       99:        ${INSTALL_DATA} ${FILESDIR}/CHANGES.pkgsrc ${RUBY_DOCDIR}
1.1       taca      100: .for f in ${DOCS}
                    101:        ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${f:C/^doc\///}
                    102: .endfor
                    103:        ${INSTALL_SCRIPT} ${WRKSRC}/ext/dl/h2rb ${PREFIX}/bin/h2rb${RUBY_VER}
                    104: .for f in ${EXT_DOCS}
                    105:        ${INSTALL_DATA} ${WRKSRC}/ext/${f} ${RUBY_DOCDIR}
                    106: .endfor
                    107:        ${CP} -r ${WRKSRC}/ext/pty/README.* ${RUBY_DOCDIR}/pty
                    108:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/pty
                    109:        ${CP} -r ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
                    110:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/bigdecimal
                    111: .for f in ${BIGDECIMAL_EXAMPLES}
                    112:        ${INSTALL_DATA} ${RUBY_WRKSRC}/ext/bigdecimal/sample/${f} \
                    113:                ${RUBY_EXAMPLESDIR}/bigdecimal
                    114: .endfor
                    115:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/dl
                    116: .for f in ${DL_EXAMPLES}
                    117:        ${INSTALL_DATA} ${RUBY_WRKSRC}/ext/dl/sample/${f} \
                    118:                ${RUBY_EXAMPLESDIR}/dl
                    119: .endfor
1.10      taca      120:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/openssl
                    121: .for f in ${OPENSSL_EXAMPLES}
                    122:        ${INSTALL_DATA} ${RUBY_WRKSRC}/sample/openssl/${f} \
                    123:                ${RUBY_EXAMPLESDIR}/openssl
                    124: .endfor
1.1       taca      125: .for f in ${PTY_EXAMPLES}
                    126:        ${INSTALL_DATA} ${WRKSRC}/ext/pty/${f} ${RUBY_EXAMPLESDIR}/pty
                    127: .endfor
1.25      taca      128:        ${RUBY_GENERATE_PLIST}
1.1       taca      129:
                    130: .include "../../lang/ruby/Makefile.common"
                    131: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>