File:  [cvs.NetBSD.org] / pkgsrc / lang / rakudo / Makefile
Revision 1.39: download - view: text, annotated - select for diffs
Mon Dec 30 22:20:57 2024 UTC (3 months, 2 weeks ago) by mef
Branches: MAIN
CVS tags: HEAD
(lang/rakudo) Updated 2024.10 to 2024.12

New in 2024.12:

+ Improvements:
    + Re-imagine .polymod as an iterator [c81d9cfe]
    + Simplify Cool.substr-eq candidates [da291b55]
    + Allow *-x (aka a Callable) for position in .substr-eq [c32cb4f6]
    + Re-imagine .substr-rw handling [6182ed58][ba526e30]
    + when starting a Thread, also set its thread name [34cd4c58]
    + Allow a value of 0 with :vent-at [c972df68]
    + Fail gracefully when REPL is initialized without TTY [6c088c8c]
    + Make .trans only assign to $/ if it's assignable [097d6680]
    + Check positional .trans args earlier [59bfd7f6]
    + Some .trans optimizations (upto 50% faster in some cases)
      [de79080d][f5322142][e0c25da2]
    + Make $*USER / $*GROUP provide some string values on Windows [0911eca2]
    + Issue a warning for .trans(abc => ...) [03e2ee74]
    + Make .trans(Regex => Str) about 3 as fast [8365a5de]

+ Additions:
    + Add VM.remote-debugging method [4a93b413]

+ Fixes:
    + Fix using Iterables as indices in multidim array slice [0ff3efff]
    + Re-imagine IO::CatHandle internals [00a09d92]
    + Fix t/04-nativecall/25-embedded.c [76f62fe7]
    + Make "AAS" .. "ABS" use standard .succ semantics in 6.e [7c412a11]
    + Remove the auto-wrapping rlwrap hack [dc034250]
    + Don't use ANSI color in error messages always [a917cf03]
    + Restore old logic in find_best_dispatchee [65a98ce2]
    + [JVM] Remove workarounds for broken deserialization of nqp::null
      [3470f838]
    + [JVM] Unbreak usage of "hash" with named args [d3d08962]
    + Make sure Map.new has an NQP hash always [ba3b24cf]
    + Fix `dir` to give "." and ".." again [b1c40624]
    + Restore error message on Junction sub-sig binding error [5ff3eafe]
    + Have to make sure scalars don't make it into nativecallcast. [8765d617]
    + Fix .Str / .gist / .raku on self-referencing QuantHashes [1340c2b0]
    + Don't use Match::chomp on string [ca7933b8]
    + Type second param of proto for Stash::ASSIGN-KEY [ef46c8e9]
    + Handle classes that don't have a find_method also [e7945cf9]
    + Make (almost) any Failure in a slice throw immediately [a4b87c91]
    + Fix stringification of self referential Hashes [a047a8f7]
    + Decont Routine object when looking for attribute (#5708) [JVM]
      [e4e22694]
    + Fix issues with slices with N..* ranges [65ec7f30]
    + Fix issue with .polymod and fixed number of divisors [c6872fb0]
    + Fix remaining issue with polymod [818a543a]
    + Fix support for .substr-rw(Callable, x) [0ceb4be2]

+ Deprecations:

+ Internal:
    + Some minor tweaks in Main [c697cf04]
    + Remove most of NQP in Range.iterator [f1e2ad94]
    + Internally document the REPL.ctxsave method better [55e40088]
    + Add test for successful use of adverbs on hashes with infixes [d00d8497]
    + Azure run rakuast tests [ad3e9c57][cfa5115c]
    + Assorted test related fixes on Windows [f2c70c7f][686a65d1][65451f83]
      [c772ad8e][82dd2f6d][3820a9ba]
    + Fix tests on Win/cl/debug, make runner resilient to long paths [3b2fb62a]
      [61ee2fdf]
    + Reimagine Azure CI [2208db21][81f2dbe4][e7928e83]
    + don't call nqp::rebless on every statement [38e655f4]
    + Update release guide and Akefile to align with current practice.
      [aa385bb9]

+ RakuAST Development:
    + 3 commits, 142/153 (make test), and 1158/1355 (make spectest)
      [3f0f974e][485474df][d1c99054]

# $NetBSD: Makefile,v 1.39 2024/12/30 22:20:57 mef Exp $

DISTNAME=	rakudo-2024.12
CATEGORIES=	lang perl6
MASTER_SITES=	${MASTER_SITE_GITHUB:=rakudo/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://rakudo.org/
COMMENT=	Perl 6 reference implementation
LICENSE=	artistic-2.0

MAKE_JOBS_SAFE=	no

USE_LANGUAGES=		c c++
USE_TOOLS+=		perl gmake

TEST_TARGET=		test

HAS_CONFIGURE=		yes
CONFIG_SHELL=		${PERL5}
CONFIGURE_SCRIPT=	Configure.pl
CONFIGURE_ARGS=		--prefix=${PREFIX} --backends=moar

REPLACE_INTERPRETER+=	raku
REPLACE.raku.old=	/usr/bin/env raku
REPLACE.raku.new=	${PREFIX}/bin/raku
REPLACE_FILES.raku=	tools/install-dist.raku

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin"
PLIST_SUBST+=	EXT=dylib
.else
PLIST_SUBST+=	EXT=so
.endif

INSTALLATION_DIRS=	share/perl6/bin

#do-configure:
#	(cd ${WRKSRC} ; \
#	perl Configure.pl                      --backends=moar --prefix=$HOME/raku ; \
#	)
#	perl Configure.pl --gen-moar --gen-nqp --backends=moar --prefix=$HOME/raku ;

# gmake: *** No rule to make target '3rdparty/nqp-configure/lib/NQP/Config.pm', needed by 'gen/moar/main-version.nqp'.  Stop.
# hard coding should be corrected ..
pre-build:
	${MKDIR} -p  ${WRKSRC}/3rdparty/nqp-configure/lib/NQP
	cp -p ${PREFIX}/lib/perl5/site_perl/5.40.0/NQP/Config.pm ${WRKSRC}/3rdparty/nqp-configure/lib/NQP/
	cp -p ${PREFIX}/lib/perl5/site_perl/5.40.0/NQP/Macros.pm ${WRKSRC}/3rdparty/nqp-configure/lib/NQP/


post-install:
	${RM} -rf ${DESTDIR}${PREFIX}/share/perl6/core/precomp/*
	${RM} -rf ${DESTDIR}${PREFIX}/share/perl6/precomp/*
	${INSTALL_SCRIPT} ${WRKSRC}/tools/install-dist.raku ${DESTDIR}${PREFIX}/share/perl6/bin/
	${RM} -f ${DESTDIR}${PREFIX}/share/perl6/core/short/38673F0433DE95B90DD16424ED7B5B6520D383C5/E14CAA5C7DE5B1A1BAC1ED1155377A9AF4962C18
	${RM} -f ${DESTDIR}${PREFIX}/share/perl6/core/sources/85FD80E5C2ED76D28F0A55D85C2F3F0EC168B638

.include "../../devel/MoarVM/buildlink3.mk"
.include "../../lang/nqp/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>