Up to [cvs.NetBSD.org] / pkgsrc / lang / py-mypy
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.41 / (download) - annotate - [select for diffs], Fri Aug 25 11:13:08 2023 UTC (5 weeks, 1 day ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
HEAD
Changes since 1.40: +4 -4
lines
Diff to previous 1.40 (colored)
py-mypy: updated to 1.5.1 1.5.1 Drop Support for Python 3.7 Optional Check to Require Explicit @override More Flexible TypedDict Creation and Update Deprecated Flag: --strict-concatenate Optionally Show Links to Error Code Documentation Consistently Avoid Type Checking Unreachable Code Experimental Improved Type Inference for Generic Functions Partial Support for Python 3.12 Improvements to Dataclasses Mypyc Improvements Stubgen Improvements Documentation Updates
Revision 1.40 / (download) - annotate - [select for diffs], Thu Jul 6 10:08:57 2023 UTC (2 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.39: +4 -4
lines
Diff to previous 1.39 (colored)
py-mypy: updated to 1.4.1 Mypy 1.4.0 The Override Decorator Propagating Type Narrowing to Nested Functions Narrowing Enum Values Using ãà=ãàPerformance Improvements Improvements to Plugins Fixes to Crashes Improvements to Error Messages Documentation Updates Mypyc Improvements Changes to Stubgen Other Notable Fixes and Improvements Typeshed Updates
Revision 1.39 / (download) - annotate - [select for diffs], Mon May 15 20:48:50 2023 UTC (4 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2
Changes since 1.38: +4 -4
lines
Diff to previous 1.38 (colored)
py-mypy: updated to 1.3.0 1.3.0 Performance Improvements Stub Tooling Improvements Improvements to attrs Documentation Updates Error Reporting Improvements Mypyc Improvements
Revision 1.38 / (download) - annotate - [select for diffs], Tue Apr 25 12:49:43 2023 UTC (5 months ago) by adam
Branch: MAIN
Changes since 1.37: +4 -4
lines
Diff to previous 1.37 (colored)
py-mypy: updated to 1.2.0 1.2.0 Improvements to Dataclass Transforms Mypyc: Native Floats Mypyc: Native Integers
Revision 1.37 / (download) - annotate - [select for diffs], Thu Mar 9 08:12:17 2023 UTC (6 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base,
pkgsrc-2023Q1
Changes since 1.36: +4 -4
lines
Diff to previous 1.36 (colored)
py-mypy: updated to 1.1.1 Mypy 1.1.1 This release includes new features, performance improvements and bug fixes.
Revision 1.36 / (download) - annotate - [select for diffs], Wed Feb 22 12:47:25 2023 UTC (7 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.35: +4 -4
lines
Diff to previous 1.35 (colored)
py-mypy: updated to 1.0.1 1.0.1 Bug fixes
Revision 1.35 / (download) - annotate - [select for diffs], Tue Feb 14 19:09:59 2023 UTC (7 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.34: +4 -4
lines
Diff to previous 1.34 (colored)
py-mypy py-mypy_extensions: updated to 1.0.0 Mypy 1.0 Released Now that mypy reached 1.0, weãàÑÍl switch to a new versioning scheme. Mypy version numbers will be of form x.y.z. Mypy 1.0 is up to 40% faster than mypy 0.991 when type checking the Dropbox internal codebase. We also set up a daily job to measure the performance of the most recent development version of mypy to make it easier to track changes in performance. Mypy will now generate an error if you use a variable before itãàÑÔ defined. This feature is enabled by default. By default mypy reports an error when it infers that a variable is always undefined. A new experimental possibly-undefined error code is now available that will detect variables that may be undefined. There is now a simpler syntax for declaring generic self types introduced in PEP 673: the Self type. You no longer have to define a type variable to use ãà×Ôelf typesãà and you can use them with attributes.
Revision 1.34 / (download) - annotate - [select for diffs], Tue Nov 22 13:28:32 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.33: +4 -4
lines
Diff to previous 1.33 (colored)
py-mypy: updated to 0.991 Mypy 0.991 Basic Python 3.11 Support Breaking Change: No Implicit Optional Types for Arguments Breaking Change: Namespace Packages Enabled by Default Recursive Types Enabled By Default Error Codes Shown by Default Safe Handling of Empty Function Bodies Enabling Experimental Features Individually Configuring Packages/Modules in the Config File Warn about Variable Annotations in Unchecked Functions Error Code for Using an Abstract Class as type[T] Performance Improvements
Revision 1.33 / (download) - annotate - [select for diffs], Tue Nov 8 08:57:44 2022 UTC (10 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.32: +4 -4
lines
Diff to previous 1.32 (colored)
py-mypy: updated to 0.990 v0.990 Remove +dev from version
Revision 1.32 / (download) - annotate - [select for diffs], Thu Oct 6 19:38:55 2022 UTC (11 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.31: +4 -4
lines
Diff to previous 1.31 (colored)
py-mypy: updated to 0.982 0.981 * Support for Python 3.6 and 2 Dropped * Generate Error on Unbound TypeVar Return Type * Methods with Empty Bodies in Protocols Are Abstract * Implicit Optional Types Will Be Disabled by Default * Precise Types for **kwds Using TypedDict * Experimental Support for General Recursive Types * Generic NamedTuples and TypedDicts * Better Support for Callable Attributes * Per-Module Error Code Configuration * Experimental Support for Interactive Inspection of Expressions
Revision 1.31 / (download) - annotate - [select for diffs], Thu Aug 18 07:33:45 2022 UTC (13 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3
Changes since 1.30: +4 -4
lines
Diff to previous 1.30 (colored)
py-mypy: updated to 0.971 0.971 Speed up accessing always defined native attributes Reduce the overhead of reference counting Fix Python 3.11 C API errors Generate smaller code for casts and some implicit type coercions Optimize calling Python objects with zero or one arguments Replace integer floor division by a power of two with a shift Add primitives for faster access of float and tuple type objects Fix compile error related to operator assignment in a generator function
Revision 1.30 / (download) - annotate - [select for diffs], Fri Jul 1 17:13:49 2022 UTC (14 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.29: +4 -4
lines
Diff to previous 1.29 (colored)
py-mypy: updated to 0.961 0.961: Unknown changes
Revision 1.29 / (download) - annotate - [select for diffs], Sat May 28 11:46:13 2022 UTC (16 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2
Changes since 1.28: +4 -4
lines
Diff to previous 1.28 (colored)
py-mypy: updated to 0.960 Mypy 0.960 Minimal Support for LiteralString Per-file Timing Stats Performance Improvements Experimental Fast Module Lookup Documentation Updates Improvements to Plugin System ParamSpec Improvements Fixes to Crashes
Revision 1.28 / (download) - annotate - [select for diffs], Mon May 2 08:19:25 2022 UTC (16 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.27: +4 -4
lines
Diff to previous 1.27 (colored)
py-mypy: updated to 0.950 0.950 Pinning Third-Party Library Stub Versions Concatenate and Literals with ParamSpec Detect Unused Coroutines and Awaitables assert_type
Revision 1.27 / (download) - annotate - [select for diffs], Thu Mar 31 07:30:09 2022 UTC (18 months ago) by adam
Branch: MAIN
Changes since 1.26: +4 -4
lines
Diff to previous 1.26 (colored)
py-mypy: updated to 0.942 0.942: Fixes to Regressions Let overload item have a more general return type than the implementation Fix inheritance false positives with dataclasses/attrs Support overriding dunder attributes in Enum subclass Fix small conditional overload regression Other Fixes Fix issues related to the order of processing in the builtins import cycle Fix crash in match statement if class name is undefined Allow non-final __match_args__ and overriding
Revision 1.26 / (download) - annotate - [select for diffs], Tue Mar 15 05:53:26 2022 UTC (18 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.25: +4 -4
lines
Diff to previous 1.25 (colored)
py-mypy: updated to 0.941 0.940: Miscellaneous New Features Add support for conditionally defined overloads Give "as" variables in with statements separate scopes when it is safe to do so Add an optional error code ignore-without-code to require ignore comments to have error codes Add support for typing.Never and typing_extensions.Never as alternative spellings of NoReturn Add support for typing.reveal_type Support universal2 macOS wheels Add match_args support to attr.s() Enum Improvements Check Enum definition for invalid base classes Understand the self-destructing nature of Enum._ignore_ Add StrEnum support for Python 3.11 Make enum values final Improve final detection for Enum Fix Enum final properties and writable special members Enum now accepts String literals and final values as 2nd argument Fix false positive about member name reuse in enum Fix enum inheritance regression Mypyc Fixes and Improvements Use Py_TYPE and Py_IsNone Implement additional internal consistency checks Raise AttributeError also for non-refcounted types Fix invalid unlikely() in certain rare branches Skip no-op super calls to object.__init__() Use latest pythoncapi_compat Add helpful message to assert Documentation Updates Add documentations about Enum types Update Enum documentation Improve documentation of allow_redefinition Fix intelligent indexing example Explain generic Protocol[T1, T2, ...] shorthand Clarify that stub-only packages need to be installed Small documentation improvements for conditional overloads Improved Error Messages Improve the "Argument must be a mapping" error message Coalesce Literals when printing unions Suggest typing.Callable when using callable as type Suggest typing.Any when using any as type Add note about wrong error code in type: ignore Add no-overload-impl error code Display ellipsis when formatting variadic tuple[T, ...] Deduplicate error codes for ignore-without-code Tweak ignore-without-code error message Mention common resolutions for build errors Stubtest Improvements Ignore more dunder positional-only errors Fix wrong assumption about relative path Catch more getattr errors Error if module level dunder is missing, housekeeping Ignore __main__ module Error if a dunder method is missing from a stub Error if a function is async at runtime but not in the stub Do not error if a stub is async, but runtime is not Error if a class should be decorated with @final Use VERSIONS for submodules Treat dicts as a subtype of typeddict Ignore more exceptions in stubtest Other Notable Fixes and Improvements Fix non-default keyword-only argument positioning in stubgen Remove orjson stubs from default list Use __truediv__ for Python 2 with __future__ import Fix Python 2 compatibility issue Use type variable bound to infer constraints Handle raise Exception(), None on Python 2.7 Fix inference of protocol against overloaded function Fix an issubclass failure for protocols with overloaded methods Fix crashes in class scoped imports Fix use of TypeAlias from aliased imports Delete open plugin Read pyproject.toml with correct encoding on Windows Fix issue with implicit type aliases in import cycles Forbid extra ParamSpec arguments Fix crash involving explicit any flag and Required Fix join of Any against a union type Simplify unions when erasing last known values Fix crash with yield in comprehension Fix handling of NoReturn in union return types Fix __init__ in dataclasses inheriting from Any Narrow NamedTuple to bool correctly when __bool__ is defined Improve type of __attrs_attrs__ in attrs classes Install dependencies needed for reports via pip install mypy[reports] Consider import * to be an explicit re-export Fix --no-implicit-reexport inconsistency Fix crash if "_" is in builtins Fixes crash on subclassing Annotated without args
Revision 1.25 / (download) - annotate - [select for diffs], Tue Jan 11 07:07:42 2022 UTC (20 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.24: +4 -4
lines
Diff to previous 1.24 (colored)
py-mypy: updated to 0.931 0.931 Fixes to Regressions Fix mypyc binary wheel Revert to treating multi-line strings as a single value for exclude in TOML files Revert to treating exclude in .ini as a single value Fix __slots__ regression Fix regression with __module__ and similar non-final Enum attributes Fix regression when a contextmanager yields a generic function Fix __reduce__ regression Fix NoReturn type aliases Fix regression in None handling with --no-strict-optional Fix crash related to generics Restore removed builtin_type() plugin API method Other Fixes Always allow the use of type[T] in stubs Fix PEP 585 type aliases in stubs Fix bug with literal types in stubtest
Revision 1.24 / (download) - annotate - [select for diffs], Thu Dec 30 21:19:26 2021 UTC (20 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.23: +4 -4
lines
Diff to previous 1.23 (colored)
py-mypy: updated to 0.930 Mypy 0.930 New Feature: Explicit Type Aliases (PEP 613) New Feature: NotRequired in TypedDicts New Feature: ParamSpec (Experimental) Optimizations This release includes some optimizations that make mypy a bit faster (in addition to mypyc performance improvements discussed below): Enable --fast-exit by default to speed up mypy Only read the stdlib versions dictionary once per run Optimize commonly used function Minor optimization/cleanup Reduce the number of executed local imports Mypyc Fixes and Improvements Add missing type coercions Support --allow-redefinition Constant fold integer operations and string concatenation Use optimized implementation for builtins.sum Move mypyc to console_scripts to fix running on Windows 10 Make min(x, y) faster Make max(x, y) faster Speed up reference counting operations by inlining them in commonly executed blocks Add support for attrs classes Port mypyc to Python 3.11 Reduce the amount of debug information included in compiled extension modules
Revision 1.23 / (download) - annotate - [select for diffs], Thu Dec 16 07:43:44 2021 UTC (21 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.22: +4 -4
lines
Diff to previous 1.22 (colored)
py-mypy: updated to 0.920 0.920: Unknown changes
Revision 1.22 / (download) - annotate - [select for diffs], Tue Oct 26 10:51:49 2021 UTC (23 months ago) by nia
Branch: MAIN
Changes since 1.21: +2 -2
lines
Diff to previous 1.21 (colored)
lang: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes The following distfiles could not be fetched (possibly fetched conditionally?): ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-musl.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-armv7-unknown-netbsd-eabihf.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-i686-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-sparc64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-apple-darwin.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-freebsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-musl.tar.gz ./lang/smlnj/distinfo smlnj-110.73/boot.ppc-unix.tgz ./lang/smlnj/distinfo smlnj-110.73/boot.sparc-unix.tgz ./lang/oracle-jre8/distinfo jce_policy-8.zip ./lang/oracle-jre8/distinfo jre-8u202-linux-i586.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-linux-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-macosx-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-solaris-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-i586.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-solaris-x64.tar.gz ./lang/ghc80/distinfo ghc-7.10.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-i386-unknown-freebsd.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-x86_64-unknown-freebsd.tar.xz ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/rust/distinfo rust-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-illumos.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-std-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/smlnj11072/distinfo smlnj-110.72/boot.ppc-unix.tgz ./lang/smlnj11072/distinfo smlnj-110.72/boot.sparc-unix.tgz ./lang/ghc84/distinfo ghc-8.0.2-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.10.3-boot-i386-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-i386-unknown-solaris2.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-powerpc-apple-darwin.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-8.10.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-aarch64-unknown-netbsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-i386-unknown-freebsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-apple-darwin.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-unknown-freebsd.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-netbsd-7-sparc64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.8.181-netbsd-8-aarch64-20180917.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.6-amd64-20140719.tar.bz2 ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.8-amd64-20140719.tar.bz2 ./lang/go-bin/distinfo go1.14.2.darwin-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-386.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-arm64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-armv6l.tar.gz ./lang/go-bin/distinfo go1.14.2.netbsd-arm64.tar.gz ./lang/go-bin/distinfo go1.16beta1.darwin-arm64.tar.gz ./lang/gcc6-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/ghc810/distinfo ghc-8.8.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/sun-jre7/distinfo UnlimitedJCEPolicyJDK7.zip ./lang/sun-jre7/distinfo jre-7u80-linux-x64.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-i586.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-x64.tar.gz ./lang/ghc88/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/gcc-aux/distinfo ada-bootstrap.i386.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/gcc6/distinfo ecj-4.5.jar ./lang/openjdk11/distinfo bootstrap-jdk-1.11.0.7.10-netbsd-9-aarch64-20200509.tar.xz ./lang/sun-jdk7/distinfo jdk-7u80-linux-x64.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-i586.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-x64.tar.gz
Revision 1.21 / (download) - annotate - [select for diffs], Thu Oct 7 14:21:07 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.20: +1 -2
lines
Diff to previous 1.20 (colored)
lang: Remove SHA1 hashes for distfiles
Revision 1.20 / (download) - annotate - [select for diffs], Fri Jun 25 21:08:04 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3
Changes since 1.19: +5 -5
lines
Diff to previous 1.19 (colored)
py-mypy: updated to 0.910 Mypy 0.910 released 22 Jun 2021: Mypy 0.910 was released. This release includes the --non-interactive command-line option to install stubs without user interaction, plus other fixes and improvements. Python 3.5 is now deprecated. Read the blog post for the details. Mypy 0.901 released 8 Jun 2021: Mypy 0.901 was released. This release moves third-party library stubs to stub packages, allowing newer stubs to be easily used without updating mypy. Mypy now supports pyproject.toml and type guards, and ships wheels for Apple Silicon. Plus, there are many other features and bug fixes. Read the blog post for the details.
Revision 1.19 / (download) - annotate - [select for diffs], Tue Mar 9 11:26:20 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.18: +5 -5
lines
Diff to previous 1.18 (colored)
py-mypy: updated to 0.812 0.812: This release fixes a regression in module finding behavior and adds the --exclude flag for excluding certain paths when searching for modules.
Revision 1.18 / (download) - annotate - [select for diffs], Thu Jan 28 08:19:09 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.17: +5 -5
lines
Diff to previous 1.17 (colored)
py-mypy: updated to 0.800 Mypy 0.800 was released. This release adds Python 3.9 support, typing usability improvements (PEP 585 and PEP 604), and other features and bug fixes.
Revision 1.17 / (download) - annotate - [select for diffs], Mon Nov 9 13:36:24 2020 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Changes since 1.16: +5 -5
lines
Diff to previous 1.16 (colored)
py-mypy: updated to 0.790 0.790: Bug Fixes Fix disable_error_code config file option Fix partial type crash during protocol checking Store the type for assignment expression Always type check arguments when using --disallow-untyped-calls Make None compatible with Hashable Don't infinite loop on self dependencies in --follow-imports=normal Don't simplify away Any when joining union types Check for deleted vars in raise from Fix corner case for comparing nested overloads Fix issues with async for and with statements Fix internal error on list/dict comprehension with walrus operator in global scope Fix propagation of module-specific options to the parser Fix crash when super is called outside a method Fix untyped decorator overload error on class decorator with __call__ overloads Clean up terminal width handling Add keyword arguments for functional Enum API Validate follow_imports values in mypy.ini Fix *expr in an assigned expression Don't consider comparing True and False as a dangerous comparison Make reveal_type work with call expressions returning None Error Reporting Improvements Improve missing module error for subdirectories Clarify bytes formatting error messages Fix misleading follow_imports error message in dmypy Use [arg-type] error code for additional argument type error messages Report some additional serious errors in junit.xml Report note about binary operation on the same location as error message Documentation Updates Document disable_error_code config file option Add cross references to config file values Add cross references to additional config values, and missing plugins config value, and document --help option for stubgen Remove note that Final is experimental and suggest importing it from typing Discuss unreachable code as a common issue Stubgen Improvements Improve property type detection in extension modules Fix type stubgen crash caused by invalid type annotation Import Iterable and Iterator from typing in generated stubs Other Improvements Speed up type checking of unions containing many literal string types Add scripts to misc/
Revision 1.16 / (download) - annotate - [select for diffs], Wed Jul 1 16:05:25 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Changes since 1.15: +5 -5
lines
Diff to previous 1.15 (colored)
py-mypy: updated to 0.782 0.782: Bug fixes
Revision 1.15 / (download) - annotate - [select for diffs], Sat Jun 20 07:07:40 2020 UTC (3 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.14: +5 -5
lines
Diff to previous 1.14 (colored)
py-mypy: updated to 0.781 0.781: Bug fixes
Revision 1.14 / (download) - annotate - [select for diffs], Wed Jun 17 11:58:57 2020 UTC (3 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.13: +5 -5
lines
Diff to previous 1.13 (colored)
py-mypy: updated to 0.780 0.780: Unknown changes
Revision 1.13 / (download) - annotate - [select for diffs], Tue Mar 17 20:18:43 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.12: +5 -5
lines
Diff to previous 1.12 (colored)
py-mypy: updated to 0.770 Mypy 0.770 was released. This release includes various fixes and improvements and improved type inference in some cases.
Revision 1.12 / (download) - annotate - [select for diffs], Fri Jan 3 11:53:09 2020 UTC (3 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.11: +5 -5
lines
Diff to previous 1.11 (colored)
py-mypy: updated to 0.761 Mypy 0.760 was released. This release includes various fixes and improvements, and a type signature suggestion feature for tools.
Revision 1.11 / (download) - annotate - [select for diffs], Wed Dec 11 19:06:55 2019 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.10: +5 -5
lines
Diff to previous 1.10 (colored)
py-mypy: updated to 0.750 Mypy 0.750 was released. This release has better support for self-types, improved stub generator, experimental static inference of annotations, and other improvements and bug fixes. Read the blog post for more details.
Revision 1.10 / (download) - annotate - [select for diffs], Fri Oct 18 12:28:37 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.9: +5 -5
lines
Diff to previous 1.9 (colored)
py-mypy: updated to 0.740; py-mypy_extensions updated to 0.4.3 This release includes many features, bug fixes and library stub (typeshed) updates.
Revision 1.9 / (download) - annotate - [select for diffs], Mon Aug 12 07:38:53 2019 UTC (4 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Changes since 1.8: +5 -5
lines
Diff to previous 1.8 (colored)
py-mypy: updated to 0.720 Mypy 0.720 was released. This release uses the new semantic analyzer by default, adds a flag to warn about unreachable code, and has other improvements and bug fixes.
Revision 1.8 / (download) - annotate - [select for diffs], Wed Jul 3 19:40:41 2019 UTC (4 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.7: +5 -5
lines
Diff to previous 1.7 (colored)
py-mypy: updated to 0.711 0.711: The following two issues in mypy 0.710 were fixed: Revert typeshed (ãà×¥efine functools.partial as overloaded function instead of its own classãà. This caused too many false positive errors in real-world code. Fix MYPYC_BLACKLIST on Windows. This broke running dmypy on Windows.
Revision 1.7 / (download) - annotate - [select for diffs], Thu Jun 20 11:20:08 2019 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.6: +5 -5
lines
Diff to previous 1.6 (colored)
py-mypy: updated to 0.710 0.710: This release features a new, experimental semantic analyzer and inline configuration options.
Revision 1.6 / (download) - annotate - [select for diffs], Fri Apr 19 10:07:18 2019 UTC (4 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
py-mypy: updated to 0.701 0.701: Unknown changes
Revision 1.5 / (download) - annotate - [select for diffs], Thu Apr 4 09:40:17 2019 UTC (4 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.4: +5 -5
lines
Diff to previous 1.4 (colored)
py-mypy: updated to 0.700 0.700: Much Improved performance Stricter Equality Checks Python 3.4 Unsupported for Running Mypy Plugin System Improvements
Revision 1.4 / (download) - annotate - [select for diffs], Fri Feb 15 13:23:54 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.3: +5 -5
lines
Diff to previous 1.3 (colored)
py-mypy: updated to 0.670 Mypy 0.670: New Feature: Variable Redefinition Stubgen Improvements Other Improvements - Expand getting started docs to discuss type hints in more detail - Always infer in operator as returning bool - Allow star args in ctypes.Array constructor - Fix plugin invocation for __call__ methods - Implement the XDG directory spec for config files: $XDG_CONFIG_HOME/mypy/config is now included in the search path for config files - When using the --junit-xml flag, the Python version and platform in the junit.xml file are now formatted as mypy-py3_6-windows ãàpreviously this was mypy-py3.6-windows but the dot was misinterpreted by some tools - Update the typed_ast dependency to version 1.3.1; this means we now officially support Python 3.7 - Temporarily delete pyproject.toml from the repo in order to work around a pip bu g - Include mypy_bootstrap.ini in PyPI packages
Revision 1.3 / (download) - annotate - [select for diffs], Mon Jan 21 10:37:09 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.2: +5 -5
lines
Diff to previous 1.2 (colored)
py-mypy: updated to 0.660 0.660: - Literal Types - Quick Mode Removed - Plugin Improvements * Add documentation for plugin system * Make name lookup available to all plugin hooks * Add more information to FunctionContext and MethodContext - Other Improvements and Notable Bugs Fixed * Introduce an optional sqlite backed incremental cache, enabled with --sqlite-cache * Fix a daemon crash when there is a decode error * Allow setting python_executable from config file * Short-circuit if expression for always true/always false variables and MYPY/TYPE_CHECKING * Don't map actual kwargs to formal *args * Disable cache when producing reports * Fix issues with pointer arrays in the ctypes plugin * Support kw_only=True in the attrs plugin * Fix some daemon crash bugs * Better error messages when __eq__ has unexpected signature * Collect additional timing stats and allow reporting them from the daemon * Fix dmypy run when bad options passed to mypy * Improve error messages from multiple inheritance compatibility checks * Fix an incremental mode crash that can occur in situations with import cycles and star imports
Revision 1.2 / (download) - annotate - [select for diffs], Sun Dec 9 20:37:29 2018 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4
Changes since 1.1: +5 -5
lines
Diff to previous 1.1 (colored)
py-mypy: updated to 0.650 Mypy 0.650 This release includes new features, bug fixes and library stub (typeshed) updates.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Nov 28 08:15:31 2018 UTC (4 years, 10 months ago) by adam
Branch: MAIN
py-mypy: added version 0.641 Add type annotations to your Python programs, and use mypy to type check them. Mypy is essentially a Python linter on steroids, and it can catch many programming errors by analyzing your program, without actually having to run it. Mypy has a powerful type system with features such as type inference, gradual typing, generics and union types.