[BACK]Return to Makefile.php CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / php5

File: [cvs.NetBSD.org] / pkgsrc / lang / php5 / Attic / Makefile.php (download)

Revision 1.19.4.1, Sun Oct 29 16:47:58 2006 UTC (17 years, 5 months ago) by ghen
Branch: pkgsrc-2006Q3
Changes since 1.19: +1 -4 lines

Pullup ticket 1889 - requested by adrianp
security fix for php

Revisions pulled up:
- pkgsrc/lang/php5/Makefile			1.44-1.45
- pkgsrc/lang/php5/Makefile.php			1.20
- pkgsrc/lang/php5/distinfo			1.30
- pkgsrc/lang/php5/patches/patch-aa		1.1
- pkgsrc/lang/php5/patches/patch-ab		1.2
- pkgsrc/lang/www/ap-php/Makefile		1.12
- pkgsrc/lang/www/php4/Makefile			1.71-1.72
- pkgsrc/lang/www/php4/Makefile.php		1.36
- pkgsrc/lang/www/php4/distinfo			1.58
- pkgsrc/lang/www/php4/patches/patch-au		1.3

   Module Name:	pkgsrc
   Committed By:	jdolecek
   Date:		Fri Oct 20 22:10:34 UTC 2006

   Modified Files:
	pkgsrc/lang/php5: Makefile Makefile.php
	pkgsrc/www/ap-php: Makefile
	pkgsrc/www/php4: Makefile Makefile.php

   Log Message:
   remove --enable-memory-limit - 8MB is too low, and this just
   duplicates process resource limits, which already provide necessary
   "safety net" protection against rogue scripts

   bump PKGREVISION for this

   adressess PR pkg/32007 by "pancake"

   also remove --enable-track-vars, since that configure argument
   is long gone from PHP
---
   Module Name:	pkgsrc
   Committed By:	adrianp
   Date:		Sun Oct 22 13:16:42 UTC 2006

   Modified Files:
	pkgsrc/www/php4: Makefile distinfo
   Added Files:
	pkgsrc/www/php4/patches: patch-au

   Log Message:
   Fix for CVE-2006-4625
   Bump nb
---
   Module Name:	pkgsrc
   Committed By:	adrianp
   Date:		Sun Oct 22 13:19:19 UTC 2006

   Modified Files:
	pkgsrc/lang/php5: Makefile distinfo
   Added Files:
	pkgsrc/lang/php5/patches: patch-aa patch-ab

   Log Message:
   Fixes for CVE-2006-4812 and CVE-2006-4625
   Bump nb

# $NetBSD: Makefile.php,v 1.19.4.1 2006/10/29 16:47:58 ghen Exp $
#

.include "../../lang/php5/Makefile.common"

DISTINFO_FILE=	${.CURDIR}/../../lang/php5/distinfo
PATCHDIR=	${.CURDIR}/../../lang/php5/patches

BUILD_DEFS+=		USE_INET6

USE_LIBTOOL=		YES
GNU_CONFIGURE=		YES

CONFIGURE_ENV+=		EXTENSION_DIR="${PREFIX}/${PHP_EXTENSION_DIR}"

PHP_EXTENSION_DIR=	lib/php/20040412
PLIST_SUBST+=		PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR:Q}

.include "../../mk/bsd.prefs.mk"

CONFIGURE_ARGS+=	--with-config-file-path=${PKG_SYSCONFDIR:Q}

CONFIGURE_ARGS+=	--with-regex=system

CONFIGURE_ARGS+=	--without-mysql
CONFIGURE_ARGS+=	--without-sqlite
CONFIGURE_ARGS+=	--without-iconv

CONFIGURE_ARGS+=	--disable-posix
CONFIGURE_ARGS+=	--disable-dom
CONFIGURE_ARGS+=	--disable-pdo

CONFIGURE_ARGS+=	--enable-xml
CONFIGURE_ARGS+=	--with-libxml-dir=${PREFIX:Q}
.include "../../textproc/libxml2/buildlink3.mk"

# Note: This expression is the same as ${PKGBASE}, but the latter is
# not defined yet, so we cannot use it here.
PKG_OPTIONS_VAR=	PKG_OPTIONS.${PKGNAME:C/-[0-9].*//}
PKG_SUPPORTED_OPTIONS+=	inet6 ssl
PKG_SUGGESTED_OPTIONS+=	ssl

.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+=	--enable-ipv6
.else
CONFIGURE_ARGS+=	--disable-ipv6
.endif

.if !empty(PKG_OPTIONS:Mssl)
.  include "../../security/openssl/buildlink3.mk"
CONFIGURE_ARGS+=	--with-openssl=${BUILDLINK_PREFIX.openssl}
.else
CONFIGURE_ARGS+=	--without-openssl
.endif