[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / php5

File: [cvs.NetBSD.org] / pkgsrc / lang / php5 / Attic / Makefile.common (download)

Revision 1.13.2.1, Wed Feb 15 14:12:20 2006 UTC (18 years, 2 months ago) by salo
Branch: pkgsrc-2005Q4
Changes since 1.13: +5 -2 lines

Pullup ticket 1136 - requested by Martti Kuparinen
security update for php5

Revisions pulled up:
- pkgsrc/lang/php5/Makefile			1.24, 1.25, 1.27
- pkgsrc/lang/php5/Makefile.common		1.14, 1.15
- pkgsrc/lang/php5/PLIST			1.9, 1.10
- pkgsrc/lang/php5/buildlink3.mk		1.10
- pkgsrc/lang/php5/distinfo			1.14
- pkgsrc/lang/php5/patches/patch-ag		1.2
- pkgsrc/lang/php5/patches/patch-ak		1.2
- pkgsrc/lang/php5/patches/patch-aj		1.3
- pkgsrc/lang/php5/patches/patch-ao		1.3

   Module Name:		pkgsrc
   Committed By:	reed
   Date:		Wed Jan  4 17:44:24 UTC 2006

   Modified Files:
    	pkgsrc/lang/php5: Makefile

   Log Message:
   Use PKGMANDIR instead of "man".
---
   Module Name:		pkgsrc
   Committed By:	rillig
   Date:		Thu Feb  2 20:31:17 UTC 2006

   Modified Files:
    	pkgsrc/lang/php5: Makefile PLIST


   Log Message:
   Added two missing files to the PLIST. Bumped PKGREVISION.
---
   Module Name:		pkgsrc
   Committed By:	martti
   Date:		Mon Feb  6 06:39:59 UTC 2006

   Modified Files:
    	pkgsrc/lang/php5: Makefile Makefile.common PLIST buildlink3.mk
		distinfo
    	pkgsrc/lang/php5/patches: patch-ag patch-aj patch-ak patch-ao

   Log Message:
   Updated lang/php5 to 5.1.2

   * HTTP Response Splitting has been addressed in ext/session and in
     the header() function.
   * Fixed format string vulnerability in ext/mysqli.
   * Fixed possible cross-site scripting problems in certain error
     conditions.
   * Hash & XMLWriter extensions added and enabled by default.
   * Upgraded OCI8 extension.
   * Over 85 various bug fixes.

   (I haven't heard anything from the MAINTAINER but since this works fine
   on my servers and as this fixes security issues I checked in this)
---
   Module Name:		pkgsrc
   Committed By:	jdolecek
   Date:		Mon Feb  6 20:12:55 UTC 2006

   Modified Files:
    	pkgsrc/lang/php5: Makefile.common

   Log Message:
   add fix to build php-xmlrpc and php5-dom successfully with 5.1.2

# $NetBSD: Makefile.common,v 1.13.2.1 2006/02/15 14:12:20 salo Exp $
#

DISTNAME?=		php-${PHP_BASE_VERS}
CATEGORIES+=		www php5

.if !defined(PECL_VERSION)
MASTER_SITES?=		http://www.php.net/distributions/ \
			http://php3.de/distributions/ \
			ftp://ftp.php.net/pub/distributions/
EXTRACT_SUFX?=		.tar.bz2
.endif

MAINTAINER?=		jdolecek@NetBSD.org
HOMEPAGE?=		http://www.php.net/

PHP_BASE_VERS=		5.1.2

PHP_EXTENSION_DIR=	lib/php/20040412
PLIST_SUBST+=		PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR:Q}

PKG_SYSCONFVAR?=	php

# needed due to (broken?) configure checks in php-xmlrpc and php5-dom
CONFIGURE_ENV+=		PHP_LIBXML_SHARED="1"

.include "../../mk/bsd.prefs.mk"