The NetBSD Project

CVS log for pkgsrc/lang/perl5/Makefile.common

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / lang / perl5

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2011Q2-base


Revision 1.9 / (download) - annotate - [select for diffs], Thu Sep 9 20:35:43 2010 UTC (13 years, 6 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Updating lang/perl5 from 5.12.1nb2 to 5.12.2

Upstream changes:
Incompatible Changes
	There are no changes intentionally incompatible with 5.12.1.
	If any exist, they are bugs and reports are welcome.

Core Enhancements
	Other than the bug fixes listed below, there should be no
	user-visible changes to the core language in this release.

Modules and Pragmata

New Modules and Pragmata
	This release does not introduce any new modules or pragmata.

Pragmata Changes
	In the previous release, no VERSION; statements triggered a bug
	which could cause feature bundles to be loaded and strict mode
	to be enabled unintentionally.

Updated Modules

Carp
    Upgraded from version 1.16 to 1.17.

    Carp now detects incomplete caller() overrides and avoids using bogus
	@DB::args. To provide backtraces, Carp relies on particular behaviour
	of the caller built-in. Carp now detects if other code has overridden
	this with an incomplete implementation, and modifies its backtrace
	accordingly. Previously incomplete overrides would cause incorrect
	values in backtraces (best case), or obscure fatal errors (worst case)

    This fixes certain cases of Bizarre copy of ARRAY caused by modules
	overriding caller() incorrectly.

CPANPLUS
    A patch to cpanp-run-perl has been backported from CPANPLUS 0.9004.
	This resolves [perl #55964] and [perl #57106], both of which related
	to failures to install distributions that use Module::Install::DSL.

File::Glob
    A regression which caused a failure to find CORE::GLOBAL::glob after
	loading File::Glob to crash has been fixed. Now, it correctly falls
	back to external globbing via pp_glob.

File::Copy
    File::Copy::copy(FILE, DIR) is now documented.

File::Spec
    Upgraded from version 3.31 to 3.31_01.

    Several portability fixes were made in File::Spec::VMS: a colon is now
	recognized as a delimiter in native filespecs; caret-escaped
	delimiters are recognized for better handling of extended filespecs;
	catpath() returns an empty directory rather than the current
	directory if the input directory name is empty; abs2rel() properly
	handles Unix-style input.

Utility Changes
    * perlbug now always gives the reporter a chance to change the email
      address it guesses for them.
    * perlbug should no longer warn about uninitialized values when using
      the -d and -v options.

Changes to Existing Documentation
    * The existing policy on backward-compatibility and deprecation has
      been added to perlpolicy, along with definitions of terms like
      deprecation.
    * "srand" in perlfunc's usage has been clarified.
    * The entry for "die" in perlfunc was reorganized to emphasize its role
      in the exception mechanism.
    * Perl's INSTALL file has been clarified to explicitly state that Perl
      requires a C89 compliant ANSI C Compiler.
    * IO::Socket's getsockopt() and setsockopt() have been documented.
    * alarm()'s inability to interrupt blocking IO on Windows has been
      documented.
    * Math::TrulyRandom hasn't been updated since 1996 and has been removed
      as a recommended solution for random number generation.
    * perlrun has been updated to clarify the behaviour of octal flags to
      perl.
    * To ease user confusion, $# and $*, two special variables that were
      removed in earlier versions of Perl have been documented.
    * The version of perlfaq shipped with the Perl core has been updated
      from the official FAQ version, which is now maintained in the
      briandfoy/perlfaq branch of the Perl repository at
      git://perl5.git.perl.org/perl.git.

Installation and Configuration Improvements
Configuration improvements
    * The d_u32align configuration probe on ARM has been fixed.

Compilation improvements
    * An "incompatible operand types" error in ternary expressions when
      building with clang has been fixed.
    * Perl now skips setuid File::Copy tests on partitions it detects to
      be mounted as nosuid.

Selected Bug Fixes
    * A possible segfault in the T_PRTOBJ default typemap has been fixed.
    * A possible memory leak when using caller() to set @DB::args has been
      fixed.
    * Several memory leaks when loading XS modules were fixed.
    * unpack() now handles scalar context correctly for %32H and %32u,
      fixing a potential crash. split() would crash because the third item
      on the stack wasn't the regular expression it expected.
      unpack("%2H", ...) would return both the unpacked result and the
      checksum on the stack, as would unpack("%2u", ...). [perl #73814]
    * Perl now avoids using memory after calling free() in pp_require when
      there are CODEREFs in @INC.
    * A bug that could cause "Unknown error" messages when
      "call_sv(code, G_EVAL)" is called from an XS destructor has been fixed.
    * The implementation of the open $fh, '>' \$buffer feature now supports
      get/set magic and thus tied buffers correctly.
    * The pp_getc, pp_tell, and pp_eof opcodes now make room on the stack
      for their return values in cases where no argument was passed in.
    * When matching unicode strings under some conditions inappropriate
      backtracking would result in a Malformed UTF-8 character (fatal)
      error. This should no longer occur. See [perl #75680]

Platform Specific Notes
AIX
    * README.aix has been updated with information about the XL C/C++ V11
      compiler suite.

Windows
    * When building Perl with the mingw64 x64 cross-compiler incpath,
      libpth, ldflags, lddlflags and ldflags_nolargefiles values in
      Config.pm and Config_heavy.pl were not previously not being set
      correctly because, with that compiler, the include and lib
      directories are not immediately below $(CCHOME).

VMS
    * git_version.h is now installed on VMS. This was an oversight in
      v5.12.0 which caused some extensions to fail to build.
    * Several memory leaks in stat() have been fixed.
    * A memory leak in Perl_rename() due to a double allocation has been
      fixed.
    * A memory leak in vms_fid_to_name() (used by realpath() and
      realname()) has been fixed.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>