[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / parrot

File: [cvs.NetBSD.org] / pkgsrc / lang / parrot / Makefile (download)

Revision 1.41, Wed Dec 22 21:29:31 2010 UTC (13 years, 3 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.40: +2 -3 lines

Update parrot from version 2.10.1 to 2.11.0.

Pkgsrc changes:
 o Adapt PLIST to changes in the set of installed files
 o Adjust one patch to match the changed source

Upstream changes:
- Core
 + Just In Time native call frame generation using LibFFI
 + PIR op find_codepoint is no longer experimental, it is now supported
 + Several public functions in libparrot have been brought up to standard
   naming conventions.
 + Improved linked-list implementation in GC
 + set_addr opcode is being replaced with the new set_label opcode
   in core libraries
 + Removed deprecated CodeString PMC
 + Added close, is_closed, read, readline methods to Socket
 + Added experimental MappedByteArray PMC type
 + Added Parrot_warn_experimental, to warn the user about experimental features
 + Code for frontend executables moved from src/ to frontend/
 + Support for chunked receive in LWP library.
 + Added a "quickcover" make target
- Languages
 + PIRC
   - left the nest and is currently at https://github.com/parrot/pirc/
 + Community
   - Our README was translated into the following languages
    by Google Code-In students and mentors:
        Polish      README.polski
        Spanish     README.espanol
        German      README.deutsch
- Documentation
- Tests
 + Test coverage increase on PMCs: String, Integer, NameSpace,
   Complex, EventHandler
 + 'make quickcover' target added to speed up most essential
   parts of coverage analysis
 + 'tools/dev/headerizer.pl' refactored to improve maintainability
   (no change in functionality)

# $NetBSD: Makefile,v 1.41 2010/12/22 21:29:31 he Exp $
#

VERSION=		2.11.0
RTYPE=			devel
DISTNAME=		parrot-${VERSION}
CATEGORIES=		lang
MASTER_SITES=		ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/

MAINTAINER=		he@NetBSD.org
HOMEPAGE=		http://www.parrotcode.org/
COMMENT=		Virtual machine made to run Perl 6 and other languages
LICENSE=		artistic-2.0

PKG_DESTDIR_SUPPORT=	user-destdir
USE_LANGUAGES=		c c++
USE_TOOLS+=		perl
PTHREAD_OPTS+=		require
BUILD_TARGET=		world
TEST_TARGET=		test
HAS_CONFIGURE=		yes

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.prefs.mk"

CONFIG_SHELL=		perl
CONFIGURE_SCRIPT=	Configure.pl
CONFIGURE_ARGS+=	--prefix=${PREFIX:Q} \
			--icu-config=${PREFIX}/bin/icu-config \
			--optimize

SUBST_CLASSES+=		pthread
SUBST_STAGE.pthread=	post-configure
SUBST_FILES.pthread=	Makefile
SUBST_SED.pthread=	-e 's|-pthread||g'
SUBST_SED.pthread+=	-e 's|-lpthread||g'
SUBST_SED.pthread+=	-e 's|-lc_r||g'
SUBST_SED.pthread+=	-e '/^CFLAGS /s|$$|${PTHREAD_CFLAGS:Q}|'
SUBST_SED.pthread+=	-e '/^LINKFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
SUBST_SED.pthread+=	-e '/^LDFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'

PLIST_SUBST+=		VERSION=${VERSION:Q}
PLIST_SRC+=		${PLIST_SRC_DFLT}
# Default this to ELF shared libs with .so,
# Darwin has PLIST.Darwin which gets included automatically.
.if (${OPSYS} != "Darwin")
PLIST_SRC+=		PLIST.shared
.endif

REPLACE_PERL+=		tools/build/ops2c.pl
REPLACE_PERL+=		tools/build/pmc2c.pl
REPLACE_PERL+=		tools/dev/create_language.pl
REPLACE_PERL+=		tools/dev/gen_makefile.pl
REPLACE_PERL+=		tools/dev/mk_language_shell.pl
REPLACE_PERL+=		tools/dev/pprof2cg.pl
REPLACE_PERL+=		tools/dev/reconfigure.pl

REPLACE_INTERPRETER+=	parrot
REPLACE.parrot.old=	.*parrot[^[:space:]]*
REPLACE.parrot.new=	${PREFIX}/bin/parrot
REPLACE_FILES.parrot+= 	tools/dev/pbc_to_exe.pir

# Does relink internally, so allow local rpath entries
BUILDLINK_PASSTHRU_RPATHDIRS+=	${WRKSRC}

pre-install:
	${CHMOD} -R g-w ${WRKSRC}

.include "../../textproc/icu/buildlink3.mk"
.include "../../devel/gmp/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"