[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / parrot

Annotation of pkgsrc/lang/parrot/Makefile, Revision 1.33

1.33    ! he          1: # $NetBSD: Makefile,v 1.32 2010/04/23 14:08:17 he Exp $
1.1       agc         2: #
                      3:
1.33    ! he          4: VERSION=               2.4.0
        !             5: RTYPE=                 devel
1.16      he          6: DISTNAME=              parrot-${VERSION}
1.8       wiz         7: CATEGORIES=            lang
1.16      he          8: MASTER_SITES=          ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/
1.1       agc         9:
1.15      he         10: MAINTAINER=            he@NetBSD.org
1.8       wiz        11: HOMEPAGE=              http://www.parrotcode.org/
                     12: COMMENT=               Virtual machine made to run Perl 6 and other languages
1.16      he         13: LICENSE=               artistic-2.0
1.8       wiz        14:
1.16      he         15: PKG_DESTDIR_SUPPORT=   user-destdir
1.12      obache     16: USE_LANGUAGES=         c c++
1.9       wiz        17: USE_TOOLS+=            perl
                     18: PTHREAD_OPTS+=         require
                     19: BUILD_TARGET=          world
                     20: TEST_TARGET=           test
1.13      obache     21: HAS_CONFIGURE=         yes
1.8       wiz        22:
1.9       wiz        23: .include "../../mk/pthread.buildlink3.mk"
1.8       wiz        24: .include "../../mk/bsd.prefs.mk"
                     25:
1.13      obache     26: CONFIG_SHELL=          perl
                     27: CONFIGURE_SCRIPT=      Configure.pl
1.9       wiz        28: CONFIGURE_ARGS+=       --prefix=${PREFIX:Q} \
1.33    ! he         29:                        --icu-config=${PREFIX}/bin/icu-config \
        !            30:                        --optimize
1.8       wiz        31:
1.13      obache     32: SUBST_CLASSES+=                pthread
                     33: SUBST_STAGE.pthread=   post-configure
                     34: SUBST_FILES.pthread=   Makefile
                     35: SUBST_SED.pthread=     -e 's|-pthread||g'
                     36: SUBST_SED.pthread+=    -e 's|-lpthread||g'
                     37: SUBST_SED.pthread+=    -e 's|-lc_r||g'
                     38: SUBST_SED.pthread+=    -e '/^CFLAGS /s|$$|${PTHREAD_CFLAGS:Q}|'
                     39: SUBST_SED.pthread+=    -e '/^LINKFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
                     40: SUBST_SED.pthread+=    -e '/^LDFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
1.8       wiz        41:
1.23      he         42: PLIST_SUBST+=          VERSION=${VERSION:Q}
                     43: PLIST_SRC+=            ${PLIST_SRC_DFLT}
                     44: # Default this to ELF shared libs with .so,
                     45: # Darwin has PLIST.Darwin which gets included automatically.
                     46: .if (${OPSYS} != "Darwin")
                     47: PLIST_SRC+=            PLIST.shared
                     48: .endif
                     49:
1.25      he         50: REPLACE_PERL+=         tools/build/ops2c.pl
                     51: REPLACE_PERL+=         tools/build/pmc2c.pl
                     52: REPLACE_PERL+=         tools/dev/gen_makefile.pl
                     53: REPLACE_PERL+=         tools/dev/mk_language_shell.pl
                     54: REPLACE_PERL+=         tools/dev/reconfigure.pl
                     55: REPLACE_PERL+=         lib/Parrot/Op.pm
                     56: REPLACE_PERL+=         lib/Parrot/OpsFile.pm
                     57:
                     58:
                     59: REPLACE_INTERPRETER+=  parrot
                     60: REPLACE.parrot.old=    .*parrot[^[:space:]]*
                     61: REPLACE.parrot.new=    ${PREFIX}/bin/parrot
                     62: REPLACE_FILES.parrot+=         tools/dev/pbc_to_exe.pir
                     63:
1.30      joerg      64: # Does relink internally, so allow local rpath entries
                     65: BUILDLINK_PASSTHRU_RPATHDIRS+= ${WRKSRC}
1.23      he         66:
1.16      he         67: pre-install:
                     68:        ${CHMOD} -R g-w ${WRKSRC}
                     69:
1.8       wiz        70: .include "../../textproc/icu/buildlink3.mk"
1.33    ! he         71: .include "../../devel/gmp/buildlink3.mk"
1.1       agc        72: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>