[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / npm

File: [cvs.NetBSD.org] / pkgsrc / lang / npm / Makefile (download)

Revision 1.55, Thu Jul 14 07:17:14 2022 UTC (8 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.54: +2 -2 lines

npm: updated to 8.14.0

v8.14.0 (2022-07-13)

Features

feat: add npm audit signatures (@feelepxyz)
feat: Add web auth type (@jumoel)
feat(arborist): add support for dependencies script (@nlf)
feat: notify on adduser of upcoming cmds, login and register (@fritzy)
feat: warn on config --auth-type=sso/saml/oauth, undeprecate --auth-type (@fritzy)

Bug Fixes

fix: properly open package arg repo inside workspace (@wraithgar)

Documentation

docs: typo in npm command (@crisanmm)
docs: update reference to deprecated spdx package (@kachick)
docs: naming of files in example code should be consistent (@xc1427)
docs: document dependencies script

# $NetBSD: Makefile,v 1.55 2022/07/14 07:17:14 adam Exp $

DISTNAME=	npm-8.14.0
CATEGORIES=	lang
MASTER_SITES=	${MASTER_SITE_GITHUB:=npm/}
GITHUB_PROJECT=	cli
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/npm/cli
COMMENT=	Package manager for JavaScript
LICENSE=	artistic-2.0

USE_TOOLS+=	bash gmake perl

DEPENDS+=	nodejs-[0-9]*:../../lang/nodejs

MAKE_JOBS_SAFE=	no	# building man-pages

REPLACE_INTERPRETER+=	node
REPLACE.node.old=	.*node
REPLACE.node.new=	${PREFIX}/bin/node
REPLACE_FILES.node=	bin/npm-cli.js
REPLACE_FILES.node+=	bin/npx-cli.js

SUBST_CLASSES+=		python
SUBST_STAGE.python=	pre-configure
SUBST_FILES.python=	node_modules/node-gyp/lib/configure.js
SUBST_MESSAGE.python=	Fixing path to Python
SUBST_VARS.python=	PYTHONBIN

SUBST_CLASSES+=			man-directory
SUBST_STAGE.man-directory=	pre-configure
SUBST_FILES.man-directory=	node_modules/bin-links/lib/man-target.js
SUBST_MESSAGE.man-directory=	Changing installation to PREFIX/man
SUBST_VARS.man-directory=	DESTDIR PREFIX PKGMANDIR

CHECK_INTERPRETER_SKIP+=	lib/node_modules/npm/*

INSTALLATION_DIRS+=	lib/node_modules

.include "../../mk/bsd.prefs.mk"

do-install:
	${FIND} ${WRKSRC} -type f -name '*.orig' -delete
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_ENV} ${PREFIX}/bin/node \
		bin/npm-cli.js pack
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_ENV} ${PREFIX}/bin/node \
		bin/npm-cli.js install -g -f ${PKGNAME_NOREV}.tgz

.include "../../lang/python/pyversion.mk"
.include "../../mk/bsd.pkg.mk"