[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / npm

File: [cvs.NetBSD.org] / pkgsrc / lang / npm / Makefile (download)

Revision 1.50, Fri Jun 17 08:04:03 2022 UTC (9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.49: +2 -3 lines

npm: updated to 8.12.2

v8.12.2 (2022-06-15)

Dependencies

* deps: make-fetch-happen@10.1.7
* deps: cacache@16.1.1
v8.12.1 (2022-06-02)

Bug Fixes

* fix: undeprecate and remove warnings for --global, -g, --local (@fritzy)
v8.12.0 (2022-06-01)

Features

* feat(init): reify on init new workspace (@ruyadorno)
* feat: Add --auth-type=webauthn flag (@jumoel)
Bug Fixes

* fix(arborist): use rawSpec for bundled and shrinkwrapped deps (@nlf)
* fix(libnpmexec): fix bug not install latest pkg (@jihunleekr)
Dependencies

* deps: make-fetch-happen@10.1.6
* deps: pacote@13.6.0
* deps: glob@8.0.3
* deps: minimatch@5.1.0
* deps: tap@16.2.0
* deps: @npmcli/arborist@5.2.1
* deps: libnpmexec@4.0.6
v8.11.0 (2022-05-25)

Features

* feat: deprecated set-script, birthday, --global, and --local (@fritzy)
* feat(libnpmpack): bump pacote for better workspace awareness (@nlf)
Bug Fixes

* fix(ci): remove node_modules post-validation (@wraithgar)
* fix: clean up npm cache tests (@wraithgar)
ee3308a fix: remove dead code from get-identity (@wraithgar)
* fix: pass prefix and workspaces to libnpmpack (@nlf)
* fix: add global getter to npm class (@nlf)
Documentation

* docs: update roadmap link in readme (@OmriBarZik)
* docs: fix broken link in changelog (@yonran)
Dependencies

* deps: cacache@16.1.0
* deps: make-fetch-happen@10.1.5
* deps: pacote@13.4.1
* deps: ssri@9.0.1
* deps: npm-packlist@5.0.4
* deps: pacote@13.5.0 npm-packlist@5.1.0
* deps: libnpmpack@4.1.0
v8.10.0 (2022-05-11)

Features

* feat: add --iwr alias for --include-workspace-root (@fritzy)
* feat: add flag --omit-lockfile-registry-resolved (@fritzy) (Caleb åãEverett)
Bug Fixes

* fix: remove test coverage map (@wraithgar)
* fix: cleanup star/unstar (@wraithgar)
* fix: consolidate bugs, docs, repo command logic (@wraithgar)
* fix(arborist): link deps lifecycle scripts (@ruyadorno)

# $NetBSD: Makefile,v 1.50 2022/06/17 08:04:03 adam Exp $

DISTNAME=	npm-8.12.2
CATEGORIES=	lang
MASTER_SITES=	${MASTER_SITE_GITHUB:=npm/}
GITHUB_PROJECT=	cli
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/npm/cli
COMMENT=	Package manager for JavaScript
LICENSE=	artistic-2.0

USE_TOOLS+=	bash gmake perl

MAKE_JOBS_SAFE=	no	# building man-pages

REPLACE_INTERPRETER+=	node
REPLACE.node.old=	.*node
REPLACE.node.new=	${PREFIX}/bin/node
REPLACE_FILES.node=	bin/npm-cli.js
REPLACE_FILES.node+=	bin/npx-cli.js

SUBST_CLASSES+=		python
SUBST_STAGE.python=	pre-configure
SUBST_FILES.python=	node_modules/node-gyp/lib/configure.js
SUBST_MESSAGE.python=	Fixing path to Python
SUBST_VARS.python=	PYTHONBIN

SUBST_CLASSES+=			man-directory
SUBST_STAGE.man-directory=	pre-configure
SUBST_FILES.man-directory=	node_modules/bin-links/lib/man-target.js
SUBST_MESSAGE.man-directory=	Changing installation to PREFIX/man
SUBST_VARS.man-directory=	DESTDIR PREFIX PKGMANDIR

CHECK_INTERPRETER_SKIP+=	lib/node_modules/npm/*

INSTALLATION_DIRS+=	lib/node_modules

.include "../../mk/bsd.prefs.mk"

do-install:
	${FIND} ${WRKSRC} -type f -name '*.orig' -delete
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_ENV} ${PREFIX}/bin/node \
		bin/npm-cli.js pack
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_ENV} ${PREFIX}/bin/node \
		bin/npm-cli.js install -g -f ${PKGNAME_NOREV}.tgz

.include "../../lang/nodejs/nodeversion.mk"
.include "../../lang/python/pyversion.mk"
.include "../../mk/bsd.pkg.mk"