[BACK]Return to patch-node.gypi CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / nodejs / patches

File: [cvs.NetBSD.org] / pkgsrc / lang / nodejs / patches / patch-node.gypi (download)

Revision 1.1, Sat May 12 08:59:56 2018 UTC (11 months, 1 week ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, HEAD

lang/nodejs: Use pkgsrc http-parser, libuv, libcares instead of bundled versions.
Switch back to bundled nghttp2 on lang/nodejs to reconcile a conflict
of OpenSSL versions.

$NetBSD: patch-node.gypi,v 1.1 2018/05/12 08:59:56 fhajny Exp $

Linking in libcares requires libsocket.

--- node.gypi.orig	2018-04-24 14:41:37.000000000 +0000
+++ node.gypi
@@ -251,6 +251,7 @@
     [ 'OS=="solaris"', {
       'libraries': [
         '-lkstat',
+        '-lsocket',
         '-lumem',
       ],
       'defines!': [