[BACK]Return to distinfo CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / nodejs

File: [cvs.NetBSD.org] / pkgsrc / lang / nodejs / distinfo (download)

Revision 1.56, Tue Feb 23 11:23:32 2016 UTC (8 years, 1 month ago) by fhajny
Branch: MAIN
Changes since 1.55: +5 -5 lines

Update lang/nodejs to 5.7.0.

* buffer:
  - You can now supply an encoding argument when filling a Buffer
    Buffer#fill(string[, start[, end]][, encoding]), supplying an
    existing Buffer will also work with Buffer#fill(buffer[, start[,
    end]]). See the API documentation for details on how this works.
  - Buffer#indexOf() no longer requires a byteOffset argument if
    you also wish to specify an encoding: Buffer#indexOf(val[,
    byteOffset][, encoding]).
* child_process: spawn() and spawnSync() now support a 'shell'
  option to allow for optional execution of the given command inside
  a shell. If set to true, cmd.exe will be used on Windows and
  /bin/sh elsewhere. A path to a custom shell can also be passed to
  override these defaults. On Windows, this option allows .bat. and
  .cmd files to be executed with spawn() and spawnSync().
* http_parser: Update to http-parser 2.6.2 to fix an unintentionally
  strict limitation of allowable header characters
* dgram: socket.send() now supports accepts an array of Buffers or
  Strings as the first argument. See the API docs for details on how
  this works.
* http: Fix a bug where handling headers will mistakenly trigger an
  'upgrade' event where the server is just advertising its protocols.
  This bug can prevent HTTP clients from communicating with HTTP/2
  enabled servers.
* net: Added a listening Boolean property to net and http servers to
  indicate whether the server is listening for connections.
* node: The C++ node::MakeCallback() API is now reentrant and
  calling it from inside another MakeCallback() call no longer causes
  the nextTick queue or Promises microtask queue to be processed out
  of order.
* tls: Add a new tlsSocket.getProtocol() method to get the negotiated
  TLS protocol version of the current connection.
* vm: Introduce new 'produceCachedData' and 'cachedData' options to
  new vm.Script() to interact with V8's code cache. When a new
  vm.Script object is created with the 'produceCachedData' set to
  true a Buffer with V8's code cache data will be produced and stored
  in cachedData property of the returned object. This data in turn
  may be supplied back to another vm.Script() object with a
  'cachedData' option if the supplied source is the same. Successfully
  executing a script from cached data can speed up instantiation time.
* performance: Improvements in:
  - process.nextTick()
  - path module
  - querystring module
  - streams module when processing small chunks

$NetBSD: distinfo,v 1.56 2016/02/23 11:23:32 fhajny Exp $

SHA1 (node-v5.7.0.tar.gz) = 790c72e3f9cbb299ece2e0a0ec25dba3bc447513
RMD160 (node-v5.7.0.tar.gz) = 76e3a6caf05ee8ff89b368e7e31e2d0c7db41c7e
SHA512 (node-v5.7.0.tar.gz) = 82ff8d6339c0b065684f02f79bb739365eda3110f8e69e9296453eb5a63584c978d93c87d8ef2350498abaa7b16cabfa62954dce401e82730cac61d6af62f8fe
Size (node-v5.7.0.tar.gz) = 22496101 bytes
SHA1 (patch-common.gypi) = 5b3a50617358637a6f910de28bb5a14f037317a6
SHA1 (patch-deps_cares_cares.gyp) = 2235eb44bc984fa2e745fdf1786f1ae6de6ef80f
SHA1 (patch-deps_npm_node__modules_node-gyp_gyp_pylib_gyp_generator_make.py) = 78d6ddd37ae30e869e0da666a78baad86a638c50
SHA1 (patch-deps_uv_common.gypi) = ba9caa1f6d9d6df1913d0d72a8d18ea6db0a32ff
SHA1 (patch-deps_v8_src_arm_cpu-arm.cc) = 854a7b0c6392d4568066b961da0958073b7ac62e
SHA1 (patch-deps_v8_src_base_atomicops.h) = 65b6508f5260ae672b9efc5672ba2c93223355ff
SHA1 (patch-deps_v8_src_base_atomicops__internals__arm__gcc.h) = 39ba63d8c397c7f076c108173f1ee2b5839ad4d6
SHA1 (patch-deps_v8_src_base_platform_platform-freebsd.cc) = 686c2054838a25cfeed7fb9870a959e48dc4de35
SHA1 (patch-deps_v8_src_base_platform_platform-openbsd.cc) = 0abf6a541f24da87dbbd22f57abcd5534999b3df
SHA1 (patch-deps_v8_src_base_platform_platform-posix.cc) = eff609b75125dab536934bd8afa640955dcee674
SHA1 (patch-deps_v8_src_base_platform_semaphore.cc) = dd8cafadd2668f069dab8625f57fbd71a304db3e
SHA1 (patch-deps_v8_src_log-utils.h) = 32bbf2de2af7a8ab6900a4d5e968dcc1357f6de2
SHA1 (patch-deps_v8_src_types.h) = a15d1f13a577135a006e8ef0617c9476eb971fa3
SHA1 (patch-deps_v8_tools_run-llprof.sh) = 39aa3faf77492ef8dd35b411b7b0e4605b469af3
SHA1 (patch-src_cares__wrap.cc) = d9510afd0cd4b0156a604d9197d9f97d6e3b291f
SHA1 (patch-tools_gyp_pylib_gyp_common.py) = 132008f362ea696e43a4d19bf9d8a0ac754ef55c
SHA1 (patch-tools_gyp_pylib_gyp_generator_make.py) = be3cc1aaa85c3d59b6f2758df813cb5ad8d8f74e
SHA1 (patch-tools_install.py) = 5755e67dce5261b84e43acee281c7e8810708bb4