[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / nodejs

File: [cvs.NetBSD.org] / pkgsrc / lang / nodejs / Makefile (download)

Revision 1.135, Thu Jun 14 10:54:26 2018 UTC (5 years, 10 months ago) by fhajny
Branch: MAIN
Changes since 1.134: +2 -2 lines

lang/nodejs: Update to 10.4.1.

- Fixes memory exhaustion DoS (CVE-2018-7164): Fixes a bug introduced
  in 9.7.0 that increases the memory consumed when reading from the
  network into JavaScript using the net.Socket object directly as a
  stream.
- http2
  - (CVE-2018-7161): Fixes Denial of Service vulnerability by updating
    the http2 implementation to not crash under certain circumstances
    during cleanup
  - (CVE-2018-1000168): Fixes Denial of Service vulnerability by
    upgrading nghttp2 to 1.32.0
- tls (CVE-2018-7162): Fixes Denial of Service vulnerability by
  updating the TLS implementation to not crash upon receiving
- n-api: Prevent use-after-free in napi_delete_async_work

# $NetBSD: Makefile,v 1.135 2018/06/14 10:54:26 fhajny Exp $

DISTNAME=	node-v10.4.1

USE_LANGUAGES=	c gnu++14

# Stated by the changelog as of 8.2.0
GCC_REQD+=	4.9.4

.include "../../mk/bsd.prefs.mk"

# Optional OpenSSL support in nghttp2 conflicts with OpenSSL 1.1.x
# bundled and built by lang/nodejs.
# Uncomment when we switch to openssl>=1.1
# CONFIGURE_ARGS+=	--shared-nghttp2
CONFIGURE_ARGS+=	--with-intl=system-icu

CHECK_PORTABILITY_SKIP+=	deps/openssl/openssl/.travis-create-release.sh

.include "options.mk"

.include "../../lang/nodejs/Makefile.common"
.include "../../textproc/icu/buildlink3.mk"
# Uncomment when we switch to openssl>=1.1
# .include "../../www/nghttp2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"