[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / kaffe

File: [cvs.NetBSD.org] / pkgsrc / lang / kaffe / Makefile (download)

Revision 1.60, Sat Aug 20 19:16:23 2005 UTC (18 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.59: +2 -2 lines

Use REQD_DIRS instead of MAKE_DIRS for directories under ${PREFIX} so
that these directories will be conditionally removed (based on reference
counts), regardless of the value of PKG_CONFIG.  Bump the PKGREVISION
for packages that were modified as a result.

# $NetBSD: Makefile,v 1.60 2005/08/20 19:16:23 jlam Exp $
#

.include "Makefile.common"

PKGREVISION=		7

CONFLICTS+=		kaffe-nox11-[0-9]*

JAVA_WRAPPERS=		appletviewer jar java javac javadoc javah javakey \
			javap jdb rmic rmiregistry serialver

CONF_FILES=		${JAVA_HOME}/jre/lib/security/java.security.default \
			${JAVA_HOME}/jre/lib/security/java.security

.include "../../mk/bsd.prefs.mk"

PRINT_PLIST_AWK+=	/^java\/kaffe\/jre\/lib\/security\/java.security$$/ \
				{ next; }

post-install:
	${INSTALL_DATA} ${WRKSRC}/license.terms ${JAVA_HOME}

.include "../../devel/libltdl/convenience.mk"
.include "../../mk/java-env.mk"
.include "../../mk/bsd.pkg.mk"