Up to [cvs.NetBSD.org] / pkgsrc / lang / janet
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.27 / (download) - annotate - [select for diffs], Wed Sep 27 23:58:51 2023 UTC (5 days, 15 hours ago) by charlotte
Branch: MAIN
CVS Tags: HEAD
Changes since 1.26: +4 -4
lines
Diff to previous 1.26 (colored)
lang/janet: Update to 1.31.0. ## 1.31.0 - 2023-09-17 - Report line and column when using `janet_dobytes` - Add `:unless` loop modifier - Allow calling `reverse` on generators. - Improve performance of a number of core functions including `partition`, `mean`, `keys`, `values`, `pairs`, `interleave`. - Add `lengthable?` - Add `os/sigaction` - Change `every?` and `any?` to behave like the functional versions of the `and` and `or` macros. - Fix bug with garbage collecting threaded abstract types. - Add `:signal` to the `sandbox` function to allow intercepting signals.
Revision 1.26 / (download) - annotate - [select for diffs], Tue Aug 15 15:13:55 2023 UTC (7 weeks ago) by charlotte
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3
Changes since 1.25: +4 -4
lines
Diff to previous 1.25 (colored)
lang/janet: Update to 1.30.0 ## 1.30.0 - 2023-08-05 - Change indexing of `array/remove` to start from -1 at the end instead of -2. - Add new string escape sequences `\\a`, `\\b`, `\\?`, and `\\'`. - Fix bug with marshalling channels - Add `div` for floored division - Make `div` and `mod` variadic - Support `bnot` for integer types. - Define `(mod x 0)` as `x` - Add `ffi/pointer-cfunction` to convert pointers to cfunctions
Revision 1.25 / (download) - annotate - [select for diffs], Wed Jun 21 06:37:06 2023 UTC (3 months, 1 week ago) by charlotte
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2
Changes since 1.24: +4 -4
lines
Diff to previous 1.24 (colored)
lang/janet: Update to 1.29.1 Changes from 1.28.0: ## 1.29.1 - 2023-06-19 - Add support for passing booleans to PEGs for "always" and "never" matching. - Allow dictionary types for `take` and `drop` - Fix bug with closing channels while other fibers were waiting on them: `ev/take`, `ev/give`, and `ev/select` will now return the correct (documented) value when another fiber closes the channel. - Add `ffi/calling-conventions` to show all available calling conventions for FFI. - Add `net/setsockopt` - Add `signal` argument to `os/proc-kill` to send signals besides `SIGKILL` on Posix. - Add `source` argument to `os/clock` to get different time sources. - Various combinator functions now are variadic like `map` - Add `file/lines` to iterate over lines in a file lazily. - Reorganize test suite to be sorted by module rather than pseudo-randomly. - Add `*task-id*` - Add `env` argument to `fiber/new`. - Add `JANET_NO_AMALG` flag to Makefile to properly incremental builds - Optimize bytecode compiler to generate fewer instructions and improve loops. - Fix bug with `ev/gather` and hung fibers. - Add `os/isatty` - Add `has-key?` and `has-value?` - Make imperative arithmetic macros variadic - `ev/connect` now yields to the event loop instead of blocking while waiting for an ACK.
Revision 1.24 / (download) - annotate - [select for diffs], Sat May 27 06:29:51 2023 UTC (4 months, 1 week ago) by charlotte
Branch: MAIN
Changes since 1.23: +4 -4
lines
Diff to previous 1.23 (colored)
lang/janet: Update to 1.28.0 ## 1.28.0 - 2023-05-13 - Various bug fixes - Make nested short-fn's behave a bit more predictably (it is still not recommended to nest short-fns). - Add `os/strftime` for date formatting. - Fix `ev/select` on threaded channels sometimes live-locking. - Support the `NO_COLOR` environment variable to turn off VT100 color codes in repl (and in scripts). See http://no-color.org/ - Disallow using `(splice x)` in contexts where it doesn't make sense rather than silently coercing to `x`. Instead, raise a compiler error. - Change the names of `:user8` and `:user9` sigals to `:interrupt` and `:await` - Change the names of `:user8` and `:user9` fiber statuses to `:interrupted` and `:suspended`. - Add `ev/all-tasks` to see all currently suspended fibers. - Add `keep-syntax` and `keep-syntax!` functions to make writing macros easier.
Revision 1.23 / (download) - annotate - [select for diffs], Tue Mar 7 06:09:02 2023 UTC (6 months, 3 weeks ago) by charlotte
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base,
pkgsrc-2023Q1
Changes since 1.22: +4 -4
lines
Diff to previous 1.22 (colored)
lang/janet: Update to 1.27.0 ## 1.27.0 - 2023-03-05 - Change semantics around bracket tuples to no longer be equal to regular tuples. - Add `index` argument to `ffi/write` for symmetry with `ffi/read`. - Add `buffer/push-at` - Add `ffi/pointer-buffer` to convert pointers to buffers the cannot be reallocated. This allows easier manipulation of FFI memory, memory mapped files, and buffer memory shared between threads. - Calling `ev/cancel` on a fiber waiting on `ev/gather` will correctly cancel the child fibers. - Add `(sandbox ...)` function to core for permission based security. Also add `janet_sandbox` to C API. The sandbox allows limiting access to the file system, network, ffi, and OS resources at runtime. - Add `(.locals)` function to debugger to see currently bound local symbols. - Track symbol -> slot mapping so debugger can get symbolic information. This exposes local bindings in `debug/stack` and `disasm`. - Add `os/compiler` to detect what host compiler was used to compile the interpreter - Add support for mingw and cygwin builds (mingw support also added in jpm).
Revision 1.22 / (download) - annotate - [select for diffs], Sat Mar 4 02:18:59 2023 UTC (7 months ago) by charlotte
Branch: MAIN
Changes since 1.21: +4 -4
lines
Diff to previous 1.21 (colored)
lang/janet: Update to 1.26.0 ## 1.26.0 - 2023-01-07 - Add `ffi/malloc` and `ffi/free`. Useful as tools of last resort. - Add `ffi/jitfn` to allow calling function pointers generated at runtime from machine code. Bring your own assembler, though. - Channels can now be marshalled. Pending state is not saved, only items in the channel. - Use the new `.length` function pointer on abstract types for lengths. Adding a `length` method will still work as well. - Support byte views on abstract types with the `.bytes` function pointer. - Add the `u` format specifier to printf family functions. - Allow printing 64 integer types in `printf` and `string/format` family functions. - Allow importing modules from custom directories more easily with the `@` prefix to module paths. For example, if there is a dynamic binding :custom-modules that is a file system path to a directory of modules, import from that directory with `(import @custom-modules/mymod)`. - Fix error message bug in FFI library.
Revision 1.21 / (download) - annotate - [select for diffs], Sat Nov 19 02:40:00 2022 UTC (10 months, 2 weeks ago) by charlotte
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.20: +4 -4
lines
Diff to previous 1.20 (colored)
janet: update to 1.25.1 CHANGELOG: ## 1.25.1 - 2022-10-29 - Add `memcmp` function to core library. - Fix bug in `os/open` with `:rw` permissions not correct on Linux. - Support config.mk for more easily configuring the Makefile. ## 1.25.0 - 2022-10-10 - Windows FFI fixes. - Fix PEG `if-not` combinator with captures in the condition - Fix bug with `os/date` with nil first argument - Fix bug with `net/accept` on Linux that could leak file descriptors to subprocesses - Reduce number of hash collisions from pointer hashing - Add optional parameter to `marshal` to skip cycle checking code ## 1.24.1 - 2022-08-24 - Fix FFI bug on Linux/Posix - Improve parse error messages for bad delimiters. - Add optional `name` parameter to the `short-fn` macro. ## 1.24.0 - 2022-08-14 - Add FFI support to 64-bit windows compiled with MSVC - Don't process shared object names passed to dlopen. - Add better support for windows console in the default shell.c for auto-completion and other shell-like input features. - Improve default error message from `assert`. - Add the `tabseq` macro for simpler table comprehensions. - Allow setting `(dyn :task-id)` in fibers to improve context in supervisor messages. Prior to this change, supervisor messages over threaded channels would be from ambiguous threads/fibers.
Revision 1.20 / (download) - annotate - [select for diffs], Tue Aug 9 01:48:07 2022 UTC (13 months, 3 weeks ago) by charlotte
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3
Changes since 1.19: +4 -4
lines
Diff to previous 1.19 (colored)
janet: Update to 1.23.0 CHANGELOG: Janet 1.23.0 ------------ This release brings a number of new features that will make Janet useful in even more domains, including mutexes and reader-writer locks to the ev module to improve interactions with multi-threaded, native code, better named arguments support, and an experimental FFI module. Also a number of improvements and simplification to Janet's debugging capabilities have been made, and exposed with the new debugger function. - Add experimental ffi/ module for interfacing with dynamic libraries and raw function pointers. Only available on 64 bit linux, mac, and bsd systems. - Allow using &named in function prototypes for named arguments. This is a more ergonomic variant of &keys that isn't as redundant, more self documenting, and allows extension to things like default arguments. - Add delay macro for lazy evaluate-and-save thunks. - Remove pthread.h from janet.h for easier includes. - Add debugger - an easy to use debugger function that just takes a fiber. - dofile will now start a debugger on errors if the environment it is passed has :debug set. - Add debugger-on-status function, which can be passed to run-context to start a debugger on abnormal fiber signals. - Allow running scripts with the -d flag to use the built-in debugger on errors and breakpoints. - Add mutexes (locks) and reader-writer locks to ev module for thread coordination. - Add parse-all as a generalization of the parse function. - Add os/cpu-count to get the number of available processors on a machine Janet 1.22.0 ------------ - Prohibit negative size argument to table/new. - Add module/value. - Remove file/popen. Use os/spawn with the :pipe options instead. - Fix bug in peg thru and to combinators. - Fix printing issue in doc macro. - Numerous updates to function docstrings - Add defdyn aliases for various dynamic bindings used in core. - Install janet.h symlink to make Janet native libraries and applications easier to build without jpm. Janet 1.21.2 ------------ - Fix patch release - (version info) Janet 1.21.1 ------------ - Patch release to fix some versioning issues in the previous 1.21.0 release. No new changes here. Janet 1.21.0 ------------ - C functions janet_dobytes and janet_dostring will now enter the event loop if it is enabled. - Fix hashing regression - hash of negative 0 must be the same as positive 0 since they are equal. - The flycheck function no longer pollutes the module/cache - Fix quasiquote bug in compiler - Disallow use of cancel and resume on fibers scheduled or created with ev/go, as well as the root fiber. Janet 1.20.0 ------------ Add :missing-symbol hook to compile that will act as a catch-all macro for undefined symbols. - Add :redef dynamic binding that will allow users to redefine top-level bindings with late binding. This is intended for development use. - Fix a bug with reading from a stream returned by os/open on Windows and Linux. - Add :ppc64 as a detectable OS type. - Add & more support for destructuring in the match macro. - Add & more support for destructuring in all binding forms (def). Janet 1.19.2 ------------ - Fix bug with missing status lines in some stack traces. - Update hash function to have better statistical properties. Janet 1.19.1 ------------ - Add an optional prefix parameter to debug/stacktrace to allow printing prettier error messages. - Remove appveyor for CI pipeline - Fixed a bug that prevented sending threaded abstracts over threaded channels. - Fix bug in the map function with arity at least 3. Janet 1.19.0 ------------ - Add math/log-gamma to replace math/gamma, and change math/gamma to be the expected gamma function. - Fix leaking file-descriptors in os/spawn and os/execute. - Ctrl-C will now raise SIGINT. - Allow quoted literals in the match macro to behave as expected in patterns. - Fix windows net related bug for TCP servers. - Allow evaluating ev streams with dofile. - Fix ev related bug with operations on already closed file descriptors. - Add struct and table agnostic getproto function. - Add a number of functions related to structs. - Add prototypes to structs. Structs can now inherit from other structs, just like tables. - Create a struct with a prototype with struct/with-proto. - Deadlocked channels will no longer exit early - instead they will hang, which is more intuitive.
Revision 1.19 / (download) - annotate - [select for diffs], Thu Nov 4 13:52:23 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.18: +4 -4
lines
Diff to previous 1.18 (colored)
janet: update to 1.18.1. jpm is now a separate package. ## 1.18.1 - 2021-10-16 - Fix some documentation typos - Fix - Set pipes passed to subprocess to blocking mode. - Fix `-r` switch in repl. ## 1.18.0 - 2021-10-10 - Allow `ev/cancel` to work on already scheduled fibers. - Fix bugs with ev/ module. - Add optional `base` argument to scan-number - Add `-i` flag to janet binary to make it easier to run image files from the command line - Remove `thread/` module. - Add `(number ...)` pattern to peg for more efficient number parsing using Janet's scan-number function without immediate string creation. ## 1.17.2 - 2021-09-18 - Remove include of windows.h from janet.h. This caused issues on certain projects. - Fix formatting in doc-format to better handle special characters in signatures. - Fix some marshalling bugs. - Add optional Makefile target to install jpm as well. - Supervisor channels in threads will no longer include a wasteful copy of the fiber in every message across a thread. - Allow passing a closure to `ev/thread` as well as a whole fiber. - Allow passing a closure directly to `ev/go` to spawn fibers on the event loop. ## 1.17.1 - 2021-08-29 - Fix docstring typos - Add `make install-jpm-git` to make jpm co-install simpler if using the Makefile. - Fix bugs with starting ev/threads and fiber marshaling. ## 1.17.0 - 2021-08-21 - Add the `-E` flag for one-liners with the `short-fn` syntax for argument passing. - Add support for threaded abstract types. Threaded abstract types can easily be shared between threads. - Deprecate the `thread` library. Use threaded channels and ev instead. - Channels can now be marshalled. - Add the ability to close channels with `ev/chan-close` (or `:close`). - Add threaded channels with `ev/thread-chan`. - Add `JANET_FN` and `JANET_REG` macros to more easily define C functions that export their source mapping information. - Add `janet_interpreter_interupt` and `janet_loop1_interrupt` to interrupt the interpreter while running. - Add `table/clear` - Add build option to disable the threading library without disabling all threads. - Remove JPM from the main Janet distribution. Instead, JPM must be installed separately like any other package. - Fix issue with `ev/go` when called with an initial value and supervisor. - Add the C API functions `janet_vm_save` and `janet_vm_load` to allow saving and restoring the entire VM state.
Revision 1.18 / (download) - annotate - [select for diffs], Tue Oct 26 10:51:39 2021 UTC (23 months, 1 week ago) by nia
Branch: MAIN
Changes since 1.17: +2 -2
lines
Diff to previous 1.17 (colored)
lang: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes The following distfiles could not be fetched (possibly fetched conditionally?): ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-linux-musl.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-aarch64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-armv7-unknown-netbsd-eabihf.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-i686-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-sparc64-unknown-netbsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-apple-darwin.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-freebsd.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust-bin/distinfo rust-bin-1.54.0/rust-1.54.0-x86_64-unknown-linux-musl.tar.gz ./lang/smlnj/distinfo smlnj-110.73/boot.ppc-unix.tgz ./lang/smlnj/distinfo smlnj-110.73/boot.sparc-unix.tgz ./lang/oracle-jre8/distinfo jce_policy-8.zip ./lang/oracle-jre8/distinfo jre-8u202-linux-i586.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-linux-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-macosx-x64.tar.gz ./lang/oracle-jre8/distinfo jre-8u202-solaris-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-i586.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-linux-x64.tar.gz ./lang/oracle-jdk8/distinfo jdk-8u202-solaris-x64.tar.gz ./lang/ghc80/distinfo ghc-7.10.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-i386-unknown-freebsd.tar.xz ./lang/ghc80/distinfo ghc-8.0.2-boot-x86_64-unknown-freebsd.tar.xz ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc5-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/rust/distinfo rust-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-illumos.tar.gz ./lang/rust/distinfo rust-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-aarch64_be-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-arm-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-armv7-unknown-linux-gnueabihf.tar.gz ./lang/rust/distinfo rust-std-1.53.0-i686-unknown-linux-gnu.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-powerpc-unknown-netbsd90.tar.gz ./lang/rust/distinfo rust-std-1.53.0-sparc64-unknown-netbsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-apple-darwin.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-freebsd.tar.gz ./lang/rust/distinfo rust-std-1.53.0-x86_64-unknown-linux-gnu.tar.gz ./lang/smlnj11072/distinfo smlnj-110.72/boot.ppc-unix.tgz ./lang/smlnj11072/distinfo smlnj-110.72/boot.sparc-unix.tgz ./lang/ghc84/distinfo ghc-8.0.2-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc84/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.10.3-boot-i386-unknown-freebsd.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-i386-unknown-solaris2.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-powerpc-apple-darwin.tar.xz ./lang/ghc7/distinfo ghc-7.6.3-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-8.10.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-aarch64-unknown-netbsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-i386-unknown-freebsd.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-apple-darwin.tar.xz ./lang/ghc90/distinfo ghc-9.0.1-boot-x86_64-unknown-freebsd.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.7.76-netbsd-7-sparc64-20150301.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk-1.8.181-netbsd-8-aarch64-20180917.tar.xz ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.6-amd64-20140719.tar.bz2 ./lang/openjdk8/distinfo openjdk7/bootstrap-jdk7u60-bin-dragonfly-3.8-amd64-20140719.tar.bz2 ./lang/go-bin/distinfo go1.14.2.darwin-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-386.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-amd64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-arm64.tar.gz ./lang/go-bin/distinfo go1.14.2.linux-armv6l.tar.gz ./lang/go-bin/distinfo go1.14.2.netbsd-arm64.tar.gz ./lang/go-bin/distinfo go1.16beta1.darwin-arm64.tar.gz ./lang/gcc6-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.dragonfly.41.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc6-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/ghc810/distinfo ghc-8.8.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/sun-jre7/distinfo UnlimitedJCEPolicyJDK7.zip ./lang/sun-jre7/distinfo jre-7u80-linux-x64.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-i586.tar.gz ./lang/sun-jre7/distinfo jre-7u80-solaris-x64.tar.gz ./lang/ghc88/distinfo ghc-8.4.4-boot-i386-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-apple-darwin.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-freebsd.tar.xz ./lang/ghc88/distinfo ghc-8.4.4-boot-x86_64-unknown-solaris2.tar.xz ./lang/gcc-aux/distinfo ada-bootstrap.i386.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.i386.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.dragonfly.36A.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.100B.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.freebsd.84.tar.bz2 ./lang/gcc-aux/distinfo ada-bootstrap.x86_64.solaris.511.tar.bz2 ./lang/gcc6/distinfo ecj-4.5.jar ./lang/openjdk11/distinfo bootstrap-jdk-1.11.0.7.10-netbsd-9-aarch64-20200509.tar.xz ./lang/sun-jdk7/distinfo jdk-7u80-linux-x64.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-i586.tar.gz ./lang/sun-jdk7/distinfo jdk-7u80-solaris-x64.tar.gz
Revision 1.17 / (download) - annotate - [select for diffs], Thu Oct 7 14:20:57 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.16: +1 -2
lines
Diff to previous 1.16 (colored)
lang: Remove SHA1 hashes for distfiles
Revision 1.16 / (download) - annotate - [select for diffs], Tue Aug 10 11:56:16 2021 UTC (2 years, 1 month ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3
Changes since 1.15: +5 -5
lines
Diff to previous 1.15 (colored)
janet: update to 1.16.1 ## 1.16.1 - 2021-06-09 - Add `maclintf` - a utility for adding linting messages when inside macros. - Print source code of offending line on compiler warnings and errors. - Fix some issues with linting and re-add missing `make docs`. - Allow controlling linting with dynamic bindings `:lint-warn`, `:lint-error`, and `:lint-levels`. - Add `-w` and `-x` command line flags to the `janet` binary to set linting thresholds. linting thresholds are as follows: - :none - will never be trigger. - :relaxed - will only trigger on `:relaxed` lints. - :normal - will trigger on `:relaxed` and `:normal` lints. - :strict - will trigger on `:strict`, `:normal`, and `:relaxed` lints. This will catch the most issues but can be distracting.
Revision 1.15 / (download) - annotate - [select for diffs], Sun Jun 6 13:45:58 2021 UTC (2 years, 3 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.14: +5 -5
lines
Diff to previous 1.14 (colored)
janet: update to 1.16.0 ## 1.16.0 - 2021-05-30 - Add color documentation to the `doc` macro - enable/disable with `(dyn :doc-color)`. - Remove simpler HTML docs from distribution - use website or built-in documentation instead. - Add compiler warnings and deprecation levels. - Add `as-macro` to make using macros within quasiquote easier to do hygienically. - Expose `JANET_OUT_OF_MEMORY` as part of the Janet API. - Add `native-deps` option to `decalre-native` in `jpm`. This lets native libraries link to other native libraries when building with jpm. - Remove the `tarray` module. The functionality of typed arrays will be moved to an external module that can be installed via `jpm`. - Add `from-pairs` to core. - Add `JPM_OS_WHICH` environment variable to jpm to allow changing auto-detection behavior. - The flychecker will consider any top-level calls of functions that start with `define-` to be safe to execute and execute them. This allows certain patterns (like spork/path) to be better processed by the flychecker.
Revision 1.14 / (download) - annotate - [select for diffs], Fri Mar 19 10:35:53 2021 UTC (2 years, 6 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.13: +5 -5
lines
Diff to previous 1.13 (colored)
janet: Update to 1.15.4 ## 1.15.4 - 2021-03-16 - Increase default nesting depth of pretty printing to `JANET_RECURSION_GUARD` - Update meson.build - Add option to automatically add shebang line in installed scripts with `jpm`. - Add `partition-by` and `group-by` to the core. - Sort keys in pretty printing output. ## 1.15.3 - 2021-02-28 - Fix a fiber bug that occured in deeply nested fibers - Add `unref` combinator to pegs. - Small docstring changes.
Revision 1.13 / (download) - annotate - [select for diffs], Thu Feb 18 17:36:34 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.12: +5 -5
lines
Diff to previous 1.12 (colored)
janet: Update to 1.15.2 ## 1.15.2 - 2021-02-15 - Fix bug in windows version of `os/spawn` and `os/execute` with setting environment variables. - Fix documentation typos. - Fix peg integer reading combinators when used with capture tags. ## 1.15.0 - 2021-02-08 - Fix `gtim` and `ltim` bytecode instructions on non-integer values. - Clean up output of flychecking to be the same as the repl. - Change behavior of `debug/stacktrace` with a nil error value. - Add optional argument to `parser/produce`. - Add `no-core` option to creating standalone binaries to make execution faster. - Fix bug where a buffer overflow could be confused with an out of memory error. - Change error output to `file:line:column: message`. Column is in bytes - tabs are considered to have width 1 (instead of 8).
Revision 1.12 / (download) - annotate - [select for diffs], Fri Feb 5 13:40:07 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.11: +5 -5
lines
Diff to previous 1.11 (colored)
janet: Update to 1.14.2 ## 1.14.2 - 2021-01-23 - Allow `JANET_PROFILE` env variable to load a profile before loading the repl. - Update `tracev` macro to allow `def` and `var` inside to work as expected. - Use `(dyn :peg-grammar)` for passing a default grammar to `peg/compile` instead of loading `default-peg-grammar` directly from the root environment. - Add `ev/thread` for combining threading with the event loop. - Add `ev/do-thread` to make `ev/thread` easier to use. - Automatically set supervisor channel in `net/accept-loop` and `net/server` correctly.
Revision 1.11 / (download) - annotate - [select for diffs], Fri Jan 22 16:16:11 2021 UTC (2 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.10: +5 -5
lines
Diff to previous 1.10 (colored)
janet: Update to 1.14.1 ## 1.14.1 - 2021-01-18 - Add `doc-of` for reverse documentation lookup. - Add `ev/give-supervsior` to send a message to the supervising channel. - Add `ev/gather` and `chan` argument to `ev/go`. This new argument allows "supervisor channels" for fibers to enable structured concurrency. - Make `-k` flag work on stdin if no files are given. - Add `flycheck` function to core. - Make `backmatch` and `backref` more expressive in pegs. - Fix buggy `string/split`. - Add `fiber/last-value` to get the value that was last yielded, errored, or signaled by a fiber. - Remove `:generate` verb from `loop` macros. Instead, use the `:in` verb which will now work on fibers as well as other data structures. - Define `next`, `get`, and `in` for fibers. This lets `each`, `map`, and similar iteration macros can now iterate over fibers. - Remove macro `eachy`, which can be replaced by `each`. - Add `dflt` argument to find-index. - Deprecate `file/popen` in favor of `os/spawn`. - Add `:all` keyword to `ev/read` and `net/read` to make them more like `file/read`. However, we do not provide any `:line` option as that requires buffering. - Change repl behavior to make Ctrl-C raise SIGINT on posix. The old behavior for Ctrl-C, to clear the current line buffer, has been moved to Ctrl-Q. - Importing modules that start with `/` is now the only way to import from project root. Before, this would import from / on disk. Previous imports that did not start with `.` or `/` are now unambiguously importing from the syspath, instead of checking both the syspath and the project root. This is backwards incompatible and dependencies should be updated for this. - Change hash function for numbers. - Improve error handling of `dofile`. - Bug fixes in networking and subprocess code. - Use markdown formatting in more places for docstrings.
Revision 1.10 / (download) - annotate - [select for diffs], Fri Dec 18 19:21:35 2020 UTC (2 years, 9 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Changes since 1.9: +5 -5
lines
Diff to previous 1.9 (colored)
janet: Update to 1.13.1 ## 1.13.1 - 2020-12-13 - Pretty printing a table with a prototype will look for `:_name` instead of `:name` in the prototype table to tag the output. - `match` macro implementation changed to be tail recursive. - Adds a :preload loader which allows one to manually put things into `module/cache`. - Add `buffer/push` function. - Backtick delimited strings and buffers are now reindented based on the column of the opening delimiter. Whitespace in columns to the left of the starting column is ignored unless there are non-space/non-newline characters in that region, in which case the old behavior is preserved. - Argument to `(error)` combinator in PEGs is now optional. - Add `(line)` and `(column)` combinators to PEGs to capture source line and column. This should make error reporting a bit easier. - Add `merge-module` to core. - During installation and release, merge janetconf.h into janet.h for easier install. - Add `upscope` special form. - `os/execute` and `os/spawn` can take streams for redirecting IO. - Add `:parser` and `:read` parameters to `run-context`. - Add `os/open` if ev is enabled. - Add `os/pipe` if ev is enabled. - Add `janet_thread_current(void)` to C API - Add integer parsing forms to pegs. This makes parsing many binary protocols easier. - Lots of updates to networking code - now can use epoll (or poll) on linux and IOCP on windows. - Add `ev/` module. This exposes a fiber scheduler, queues, timeouts, and other functionality to users for single threaded cooperative scheduling and asynchronous IO. - Add `net/accept-loop` and `net/listen`. These functions break down `net/server` into it's essential parts and are more flexible. They also allow further improvements to these utility functions. - Various small bug fixes.
Revision 1.9 / (download) - annotate - [select for diffs], Sat Oct 3 10:29:08 2020 UTC (3 years ago) by nia
Branch: MAIN
Changes since 1.8: +5 -5
lines
Diff to previous 1.8 (colored)
janet: Update to 1.12.2 ## 1.12.2 - 2020-09-20 - Add janet\_try and janet\_restore to C API. - Fix `os/execute` regression on windows. - Add :pipe option to `os/spawn`. - Fix docstring typos. ## 1.12.1 - 2020-09-07 - Make `zero?`, `one?`, `pos?`, and `neg?` polymorphic. - Add C++ support to jpm and improve C++ interop in janet.h. - Add `%t` formatter to `printf`, `string/format`, and other formatter functions. - Expose `janet_cfuns_prefix` in C API. - Add `os/proc-wait` and `os/proc-kill` for interacting with processes. - Add `janet_getjfile` to C API. - Allow redirection of stdin, stdout, and stderr by passing keywords in the env table in `os/spawn` and `os/execute`. - Add `os/spawn` to get a core/process back instead of an exit code as in `os/execute`. When called like this, `os/execute` returns immediately. - Add `:x` flag to os/execute to raise error when exit code is non-zero. - Don't run `main` when flychecking. - Add `:n` flag to `file/open` to raise an error if file cannot be opened. - Fix import macro to not try and coerce everything to a string. - Allow passing a second argument to `disasm`. - Add `cancel`. Resumes a fiber but makes it immediately error at the yield point. - Allow multi-line paste into built in repl. - Add `(curenv)`. - Change `net/read`, `net/chunk`, and `net/write` to raise errors in the case of failures. - Add `janet_continue_signal` to C API. This indirectly enables C functions that yield to the event loop to raise errors or other signals. - Update meson build script to fix bug on Debian's version of meson - Add `xprint`, `xprin`, `xprintf`, and `xprinf`. - `net/write` now raises an error message if write fails. - Fix issue with SIGPIPE on macOS and BSDs.
Revision 1.8 / (download) - annotate - [select for diffs], Sat Aug 8 17:56:42 2020 UTC (3 years, 1 month ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Changes since 1.7: +5 -6
lines
Diff to previous 1.7 (colored)
janet: Update to 1.11.3 ## 1.11.3 - 2020-08-03 - Add `JANET_HASHSEED` environment variable when `JANET_PRF` is enabled. - Expose `janet_cryptorand` in C API. - Properly initialize PRF in default janet program - Add `index-of` to core library. - Add `-fPIC` back to core CFLAGS (non-optional when compiling default client with Makefile) - Fix defaults on Windows for ARM - Fix defaults on NetBSD.
Revision 1.7 / (download) - annotate - [select for diffs], Sun Jul 26 22:47:24 2020 UTC (3 years, 2 months ago) by nia
Branch: MAIN
Changes since 1.6: +6 -5
lines
Diff to previous 1.6 (colored)
janet: Update to 1.11.1 ## 1.11.1 - 2020-07-25 - Fix jpm and git with multiple git installs on Windows - Fix importing a .so file in the current directory - Allow passing byte sequence types directly to typed-array constructors. - Fix bug sending files between threads. - Disable PRF by default. - Update the soname. ## 1.11.0 - 2020-07-18 - Add `forever` macro. - Add `any?` predicate to core. - Add `jpm list-pkgs` subcommand to see which package aliases are in the listing. - Add `jpm list-installed` subcommand to see which packages are installed. - Add `math/int-min`, `math/int-max`, `math/int32-min`, and `math/int32-max` for getting integer limits. - The gc interval is now autotuned, to prevent very bad gc behavior. - Improvements to the bytecode compiler, Janet will now generate more efficient bytecode. - Add `peg/find`, `peg/find-all`, `peg/replace`, and `peg/replace-all` - Add `math/nan` - Add `forv` macro - Add `symbol/slice` - Add `keyword/slice` - Allow cross compilation with Makefile. - Change `compare-primitve` to `cmp` and make it more efficient. - Add `reverse!` for reversing an array or buffer in place. - `janet_dobytes` and `janet_dostring` return parse errors in \*out - Add `repeat` macro for iterating something n times. - Add `eachy` (each yield) macro for iterating a fiber. - Fix `:generate` verb in loop macro to accept non symbols as bindings. - Add `:h`, `:h+`, and `:h*` in `default-peg-grammar` for hexidecimal digits. - Fix `%j` formatter to print numbers precisely (using the `%.17g` format string to printf).
Revision 1.6 / (download) - annotate - [select for diffs], Fri Jun 19 13:26:11 2020 UTC (3 years, 3 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
janet: Update to 1.10.1 ## 1.10.1 - 2020-06-18 - Expose `janet_table_clear` in API. - Respect `JANET_NO_PROCESSES` define when building - Fix `jpm` rules having multiple copies of the same dependency. - Fix `jpm` install in some cases. - Add `array/trim` and `buffer/trim` to shrink the backing capacity of these types to their current length. ## 1.10.0 - 2020-06-14 - Hardcode default jpm paths on install so env variables are needed in fewer cases. - Add `:no-compile` to `create-executable` option for jpm. - Fix bug with the `trace` function. - Add `:h`, `:a`, and `:c` flags to `thread/new` for creating new kinds of threads. By default, threads will now consume much less memory per thread, but sending data between threads may cost more. - Fix flychecking when using the `use` macro. - CTRL-C no longer exits the repl, and instead cancels the current form. - Various small bug fixes - New MSI installer instead of NSIS based installer. - Make `os/realpath` work on windows. - Add polymorphic `compare` functions for comparing numbers. - Add `to` and `thru` peg combinators. - Add `JANET_GIT` environment variable to jpm to use a specific git binary (useful mainly on windows). - `asm` and `disasm` functions now use keywords instead of macros for keys. Also some slight changes to the way constants are encoded (remove wrapping `quote` in some cases). - Expose current macro form inside macros as (dyn :macro-form) - Add `tracev` macro. - Fix compiler bug that emitted incorrect code in some cases for while loops that create closures. - Add `:fresh` option to `(import ...)` to overwrite the module cache. - `(range x y 0)` will return an empty array instead of hanging forever. - Rename `jpm repl` to `jpm debug-repl`.
Revision 1.5 / (download) - annotate - [select for diffs], Wed May 20 09:44:22 2020 UTC (3 years, 4 months ago) by nia
Branch: MAIN
Changes since 1.4: +5 -5
lines
Diff to previous 1.4 (colored)
janet: Update to 1.9.1 ## 1.9.1 - 2020-05-12 - Add :prefix option to declare-source - Re-enable minimal builds with the debugger. - Add several flags for configuring Janet on different platforms. - Fix broken meson build from 1.9.0 and add meson to CI. - Fix compilation issue when nanboxing is disabled. ## 1.9.0 - 2020-05-10 - Add `:ldflags` option to many jpm declare functions. - Add `errorf` to core. - Add `lenprefix` combinator to PEGs. - Add `%M`, `%m`, `%N`, and `%n` formatters to formatting functions. These are the same as `%Q`, `%q`, `%P`, and `%p`, but will not truncate long values. - Add `fiber/root`. - Add beta `net/` module to core for socket based networking. - Add the `parse` function to parse strings of source code more conveniently. - Add `jpm rule-tree` subcommand. - Add `--offline` flag to jpm to force use of the cache. - Allow sending pointers and C functions across threads via `thread/send`. - Fix bug in `getline`. - Add `sh-rule` and `sh-phony` to jpm's dialect of Janet. - Change C api's `janet_formatb` -> `janet_formatbv`, and add new function `janet_formatb` to C api. - Add `edefer` macro to core. - A struct/table literal/constructor with duplicate keys will use the last value given. Previously, this was inconsistent between tables and structs, literals and constructor functions. - Add debugger to core. The debugger functions are only available in a debug repl, and are prefixed by a `.`. - Add `sort-by` and `sorted-by` to core. - Support UTF-8 escapes in strings via `\uXXXX` or `\UXXXXXX`. - Add `math/erf` - Add `math/erfc` - Add `math/log1p` - Add `math/next` - Add os/umask - Add os/perm-int - Add os/perm-string - Add :int-permissions option for os/stat. - Add `jpm repl` subcommand, as well as `post-deps` macro in project.janet files. - Various bug fixes.
Revision 1.4 / (download) - annotate - [select for diffs], Sun Apr 5 13:36:27 2020 UTC (3 years, 5 months ago) by nia
Branch: MAIN
Changes since 1.3: +5 -5
lines
Diff to previous 1.3 (colored)
janet: Update to 1.8.1 ## 1.8.1 - 2020-03-31 - Fix bugs for big endian systems - Fix 1.8.0 regression on BSDs
Revision 1.3 / (download) - annotate - [select for diffs], Mon Mar 30 09:22:21 2020 UTC (3 years, 6 months ago) by nia
Branch: MAIN
Changes since 1.2: +5 -6
lines
Diff to previous 1.2 (colored)
janet: Update to 1.8.0 ## 1.8.0 - 2020-03-29 - Add `reduce2`, `accumulate`, and `accumulate2`. - Add lockfiles to `jpm` via `jpm make-lockfile` and `jpm load-lockfile`. - Add `os/realpath` (Not supported on windows). - Add `os/chmod`. - Add `chr` macro. - Allow `_` in the `match` macro to match anything without creating a binding or doing unification. Also change behavior of matching nil. - Add `:range-to` and `:down-to` verbs in the `loop` macro. - Fix `and` and `or` macros returning nil instead of false in some cases. - Allow matching successfully against nil values in the `match` macro. - Improve `janet_formatc` and `janet_panicf` formatters to be more like `string/format`. This makes it easier to make nice error messages from C. - Add `signal` - Add `fiber/can-resume?` - Allow fiber functions to accept arguments that are passed in via `resume`. - Make flychecking slightly less strict but more useful - Correct arity for `next` - Correct arity for `marshal` - Add `flush` and `eflush` - Add `prompt` and `return` on top of signal for user friendly delimited continuations. - Fix bug in buffer/blit when using the offset-src argument. - Fix segfault with malformed pegs.
Revision 1.2 / (download) - annotate - [select for diffs], Wed Mar 4 11:23:02 2020 UTC (3 years, 7 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.1: +2 -2
lines
Diff to previous 1.1 (colored)
janet: Add link to github issue (thanks leah)
Revision 1.1 / (download) - annotate - [select for diffs], Tue Mar 3 09:44:02 2020 UTC (3 years, 7 months ago) by nia
Branch: MAIN
lang: Add janet. Janet is a functional and imperative programming language. Janet makes a good system scripting language, or a language to embed in other programs. Think Lua or Guile. Janet also can be used for rapid prototying, dynamic systems, and other domains where lisp shines.