File:  [cvs.NetBSD.org] / pkgsrc / lang / erlang / Makefile.versions
Revision 1.68: download - view: text, annotated - select for diffs
Mon Oct 23 14:41:05 2023 UTC (17 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: HEAD
erlang: updated to 26.1.2

https://github.com/erlang/otp/releases/tag/OTP-26.1.2

# $NetBSD: Makefile.versions,v 1.68 2023/10/23 14:41:05 adam Exp $

# When making any update to the versions below (even patch level),
# please check to see if the erlang-doc or erlang-man packages also
# need their distinfo and PLIST files regenerated, as they almost
# always will.
DIST_VERSION_MAJOR=	26
DIST_VERSION_MINOR=	1
DIST_VERSION_PATCH=	2

.include "versions.mk"

PLIST_SUBST+=	VERSION=${DIST_VERSION_MAJOR}

.for name version in ${_VERSIONS}
VERSION.${name}=	${version}
PLIST_SUBST+=		VERSION.${name}=${version}
.endfor

# Generate PLIST
.for pkg version in ${_VERSIONS}
PRINT_PLIST_AWK+=	{if ($$0 ~ /\/${pkg}-${version}\//) {sub(/\/${pkg}-${version}\//,"/${pkg}-$${VERSION.${pkg}}/", $$0);}}
# documentation:
PRINT_PLIST_AWK+=	{gsub(/\/${pkg}-${version}\.pdf/,"/${pkg}-$${VERSION.${pkg}}.pdf", $$0);}
.endfor
PRINT_PLIST_AWK+=	{if ($$0 ~ /\/releases\/${DIST_VERSION_MAJOR}\//) {sub(/\/releases\/${DIST_VERSION_MAJOR}\//,"/releases/$${VERSION}/", $$0);}}
# documentation:
PRINT_PLIST_AWK+=	{gsub(/\/otp-system-documentation-${VERSION.erts}\.pdf/,"/otp-system-documentation-$${VERSION.erts}.pdf", $$0);}

CVSweb <webmaster@jp.NetBSD.org>