File:  [cvs.NetBSD.org] / pkgsrc / lang / erlang-doc / Makefile
Revision 1.32: download - view: text, annotated - select for diffs
Wed Dec 20 18:46:53 2023 UTC (16 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
erlang*: update to 26.2.1

Contains a Terrapin fix for erlang ssh.

26.2.1

 ---------------------------------------------------------------------
 --- POTENTIAL INCOMPATIBILITIES -------------------------------------
 ---------------------------------------------------------------------

  OTP-18897    Application(s): ssh

               With this change (being response to CVE-2023-48795),
               ssh can negotiate "strict KEX" OpenSSH extension with
               peers supporting it; also
               'chacha20-poly1305@openssh.com' algorithm becomes a
               less preferred cipher.

               If strict KEX availability cannot be ensured on both
               connection sides, affected encryption modes(CHACHA and
               CBC) can be disabled with standard ssh configuration.
               This will provide protection against vulnerability, but
               at a cost of affecting interoperability. See
               Configuring algorithms in SSH.


 ---------------------------------------------------------------------
 --- OTP-26.2.1 ------------------------------------------------------
 ---------------------------------------------------------------------

 --- Fixed Bugs and Malfunctions ---

  OTP-18903    Application(s): otp

               Updated copyright and license information.


 ---------------------------------------------------------------------
 --- erts-14.2.1 -----------------------------------------------------
 ---------------------------------------------------------------------

 The erts-14.2.1 application can be applied independently of other
 applications on a full OTP 26 installation.

 --- Fixed Bugs and Malfunctions ---

  OTP-18902    Application(s): erts

               Removed unnecessary PCRE source tar-ball.

26.2

 Highlights #

    process_info/2 now supports lookup of values for specific keys in the process dictionary.

Potential incompatibilities: #

    common_test now returns an error when a suite with a badly defined group is executed.

# $NetBSD: Makefile,v 1.32 2023/12/20 18:46:53 wiz Exp $

DISTNAME=	otp_doc_html_${DIST_VERSION_MAJOR}.${DIST_VERSION_MINOR}${!empty(DIST_VERSION_PATCH):?.:}${DIST_VERSION_PATCH}
PKGNAME=	${DISTNAME:S/otp_doc_html_/erlang-doc-/}
CATEGORIES=	lang
MASTER_SITES+=	${MASTER_SITE_GITHUB:=erlang/otp/releases/download/OTP-${PKGVERSION_NOREV}/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://www.erlang.org/
COMMENT=	Documentation for Erlang, a concurrent functional programming language
LICENSE=	apache-2.0

DIST_SUBDIR=	erlang

# needs erlang installed for its directory structure
DEPENDS+=	erlang>=${PKGVERSION_NOREV}:../../lang/erlang

NO_CONFIGURE=	yes
NO_BUILD=	yes
USE_TOOLS+=	pax

INSTALLATION_DIRS=	lib/erlang

do-install:
	cd ${WRKDIR} && pax -rw doc erts-* lib ${DESTDIR}${PREFIX}/lib/erlang/

.include "../../lang/erlang/Makefile.versions"
# overrides


.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>