[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / clisp

File: [cvs.NetBSD.org] / pkgsrc / lang / clisp / PLIST (download)

Revision 1.15, Mon Jun 23 19:34:00 2008 UTC (15 years, 9 months ago) by ghen
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.14: +2 -1 lines

Update CLISP to 2.45, from Aleksej Saushev <asau@inbox.ru> via PR pkg/39005.

Changes since previous (2.44.1) release:

User visible changes
--------------------

* Experimental Just-In-Time Compilation of byte-compiled closures is now
  done using GNU lightning (this is a configure-time option).
  Thanks to Yann Dauphin <yann-nicolas.dauphin@polymtl.ca>.

* New command-line option -lp adds directories to *LOAD-PATHS*.
  See <http://clisp.cons.org/impnotes/clisp.html#opt-load-paths> for details.

* New function FFI:OPEN-FOREIGN-LIBRARY allows pre-opening of shared libraries.
  See <http://clisp.cons.org/impnotes/dffi.html#dffi-open-lib> for details.

* New macro EXT:COMPILE-TIME-VALUE allows computing values at file compilation.
  See <http://clisp.podval.org/impnotes/macros3.html#compile-time-value>
  for details.

* New function FFI:FOREIGN-POINTER-INFO allows some introspection.
  See <http://clisp.cons.org/impnotes/dffi.html#fptr-info> for details.

* Versioned library symbols are now accessible via the :VERSION argument of
  DEF-CALL-OUT and DEF-C-VAR.
  Thanks to Kaz Kylheku <kkylheku@gmail.com>.
  See <http://clisp.cons.org/impnotes/dffi.html#def-call-out> for details.

* New functions GRAY:STREAM-READ-SEQUENCE and GRAY:STREAM-WRITE-SEQUENCE have
  been added for portability reasons.
  Suggested by Anton Vodonosov <avodonosov@yandex.ru>.
  See <http://clisp.cons.org/impnotes/gray.html#st-rd-seq> for details.

* New user variable CUSTOM:*SUPPRESS-SIMILAR-CONSTANT-REDEFINITION-WARNING*
  controls whether the redefinition warning is issues when the new
  constant value is visually similar to the old one.
  See <http://clisp.cons.org/impnotes/defconstant.html#defconstant-similar>
  for details.

* REPL commands can now accept arguments.
  See <http://clisp.cons.org/impnotes/repl.html> for details.

* Updated the postgresql module to PostgreSQL 8.3.
  See <http://clisp.cons.org/impnotes/postgresql.html> for details.

* Module syscalls now interfaces to <stdio.h> (for the sake of FFI modules).
  See <http://clisp.cons.org/impnotes/syscalls.html#stdio> for details.
  There are others additions there also, but they are too numerous to
  be enumerated here.

* Bug fixes:
  + Fix handling of quoted objects by READ-PRESERVING-WHITESPACE. [ 1890854 ]
  + Fix rectangle count in NEW-CLX XLIB:SET-GCONTEXT-CLIP-MASK. [ 1918017 ]
  + Fix argument handling in NEW-CLX XLIB:QUERY-COLORS. [ 1931101 ]
  + Fix compilation on systems not supporting returning void. [ 1924506 ]
  + Fix TANH floating point overflow for large floats. [ 1683394 ]
  + Avoid extra aggressive bignum overflow reporting in READ. [ 1928735 ]
  + Improved floating point number formatting. [ 1790496, 1928759 ]
  + COMPILE no longer discards MACRO doc strings. [ 1936255 ]
  + Improved accuracy of LOG on complex numbers. [ 1934968 ]
  + Fix COERCE for compound float result-types. [ 1942246 ]
  + Fix $http_proxy parsing. [ 1959436 ]
  + Fix LISTEN on buffered streams when the last character was CRLF. [ 1961475 ]
  + Cross-compilation process has been restored to its former glory,

@comment $NetBSD: PLIST,v 1.15 2008/06/23 19:34:00 ghen Exp $
bin/clisp
lib/clisp/base/calls.o
lib/clisp/base/gettext.o
lib/clisp/base/libnoreadline.a
lib/clisp/base/lisp.a
lib/clisp/base/lisp.run
lib/clisp/base/lispinit.mem
lib/clisp/base/localcharset.o
lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
lib/clisp/base/readline.o
lib/clisp/base/regexi.o
lib/clisp/base/regexp.dvi
lib/clisp/base/uniname.o
lib/clisp/base/width.o
lib/clisp/clisp-link
lib/clisp/data/Symbol-Table.text
lib/clisp/data/UnicodeDataFull.txt
${PLIST.bdb}lib/clisp/full/bdb.o
lib/clisp/full/calls.o
${PLIST.mit-clx}lib/clisp/full/clx.o
${PLIST.new-clx}lib/clisp/full/clx.o
${PLIST.pcre}lib/clisp/full/cpcre.o
${PLIST.fastcgi}lib/clisp/full/fastcgi.o
${PLIST.fastcgi}lib/clisp/full/fastcgi_wrappers.o
lib/clisp/full/gettext.o
${PLIST.gdbm}lib/clisp/full/gdbm.o
${PLIST.gtk2}lib/clisp/full/gtk.o
lib/clisp/full/libnoreadline.a
lib/clisp/full/lisp.a
lib/clisp/full/lisp.run
lib/clisp/full/lispinit.mem
lib/clisp/full/localcharset.o
lib/clisp/full/makevars
lib/clisp/full/modules.h
lib/clisp/full/modules.o
${PLIST.pgsql}lib/clisp/full/postgresql.o
${PLIST.rawsock}lib/clisp/full/rawsock.o
lib/clisp/full/readline.o
lib/clisp/full/regexi.o
lib/clisp/full/regexp.dvi
lib/clisp/full/uniname.o
lib/clisp/full/width.o
${PLIST.wildcard}lib/clisp/full/wildcard.dvi
${PLIST.wildcard}lib/clisp/full/wildcard.o
${PLIST.zlib}lib/clisp/full/zlib.o
lib/clisp/linkkit/clisp.h
lib/clisp/linkkit/modprep.lisp
lib/clisp/linkkit/modules.c
man/man1/clisp.1
share/${PKGNAME}/emacs/clhs.el
share/${PKGNAME}/emacs/clisp-coding.el
share/${PKGNAME}/emacs/clisp-ffi.el
share/${PKGNAME}/emacs/clisp-indent.el
share/${PKGNAME}/emacs/clisp-indent.lisp
share/${PKGNAME}/vim/lisp.vim
share/doc/${PKGNAME}/ANNOUNCE
share/doc/${PKGNAME}/CLOS-guide.txt
share/doc/${PKGNAME}/COPYRIGHT
share/doc/${PKGNAME}/GNU-GPL
share/doc/${PKGNAME}/LISP-tutorial.txt
share/doc/${PKGNAME}/MAGIC.add
share/doc/${PKGNAME}/NEWS
share/doc/${PKGNAME}/README
share/doc/${PKGNAME}/README.de
share/doc/${PKGNAME}/README.es
share/doc/${PKGNAME}/SUMMARY
share/doc/${PKGNAME}/clisp.1
share/doc/${PKGNAME}/clisp.dvi
share/doc/${PKGNAME}/clisp.html
share/doc/${PKGNAME}/clisp.pdf
share/doc/${PKGNAME}/clisp.png
share/doc/${PKGNAME}/clisp.ps
share/doc/${PKGNAME}/editors.txt
share/doc/${PKGNAME}/impnotes.css
share/doc/${PKGNAME}/impnotes.html
share/locale/da/LC_MESSAGES/clisp.mo
share/locale/da/LC_MESSAGES/clisplow.mo
share/locale/de/LC_MESSAGES/clisp.mo
share/locale/de/LC_MESSAGES/clisplow.mo
share/locale/en/LC_MESSAGES/clisp.mo
share/locale/en/LC_MESSAGES/clisplow.mo
share/locale/es/LC_MESSAGES/clisp.mo
share/locale/es/LC_MESSAGES/clisplow.mo
share/locale/fr/LC_MESSAGES/clisp.mo
share/locale/fr/LC_MESSAGES/clisplow.mo
share/locale/nl/LC_MESSAGES/clisp.mo
share/locale/nl/LC_MESSAGES/clisplow.mo
share/locale/ru/LC_MESSAGES/clisp.mo
share/locale/ru/LC_MESSAGES/clisplow.mo
@dirrm share/doc/${PKGNAME}
@dirrm share/${PKGNAME}/vim
@dirrm share/${PKGNAME}/emacs
@dirrm share/${PKGNAME}
@dirrm lib/clisp/linkkit
@dirrm lib/clisp/full
@dirrm lib/clisp/data
@dirrm lib/clisp/base
@dirrm lib/clisp