[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / lang / a60

File: [cvs.NetBSD.org] / pkgsrc / lang / a60 / Makefile (download)

Revision 1.18, Sat Feb 21 13:07:02 2015 UTC (9 years, 1 month ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.17: +4 -4 lines

(pkgsrc)
 - Update MASTER_SITES and HOMEPAGE
 - patches/patch-bltin.h  added to #include <time.h>
(upstream)
 - Update 0.20a to 0.23a
   ---------------------
Mon Jul 28 20:10:34 CEST 2014  Erik Schoenfelder  <schoenfr@web.de>

	* version increased to 0.23a

	* configure.in, Makefile.in: modified to work with newer autoconf
	version and creation of documentation. moved to more appropriate
	zip instead of old zoo format (oh yeah, those old dayes...).

	* a60-mkc.inc, a60.texinfo, test/*: add FILE_n input / output
	handling allowing channels 2 to 15 mapped to files.

Thu Jul 10 21:19:45 CEST 2014  Erik Schoenfelder  <schoenfr@web.de>

	* <many-files> change old e-mail addresses
	  schoenfr@ibr.cs.tu-bs.de and schoenfr@gaertner.de to a more
	  appropriate schoenfr@web.de address.

	* bltin.c, a60-mkc.inc, a60.texinfo: add builtin function
	  intinteger().

	* test/input.a60: add ininteger() test.

Thu Apr 21 00:42:11 MEST 2005  Erik Schoenfelder  <schoenfr@web.de>

	* a60.texinfo: fixed typo where write incorrectly state it
  	  would return an integer value.

	  Again, thanks to "Warren R. Carithers" <wrc@cs.rit.edu> for
	  pointing this out.

Wed Apr 13 18:49:44 MEST 2005  Erik Schoenfelder  <schoenfr@web.de>

	* insymbol(): the index now starts with 0, so the index
	  correspondents to outsymbol.

	* a60.texinfo: fixed typo where insymbol incorrectly state it
	  would return an integer value.

	* test/runtest.sh: addes test case input.a60

        * Thanks to "Warren R. Carithers" <wrc@cs.rit.edu> for
	  pointing this out.

# $NetBSD: Makefile,v 1.18 2015/02/21 13:07:02 mef Exp $

DISTNAME=	a60-0.23a
CATEGORIES=	lang
MASTER_SITES=	http://www.bertnase.de/a60/

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	Algol 60 interpreter
HOMEPAGE=	http://www.bertsane.de/a60/
LICENSE=	gnu-gpl-v2

GNU_CONFIGURE=	yes

CPPFLAGS+=	-Dunix

INFO_FILES=	yes

INSTALLATION_DIRS=	bin share/a60 share/doc/a60 share/examples/a60 \
			${PKGINFODIR} ${PKGMANDIR}/man1

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/a60 ${DESTDIR}${PREFIX}/bin/
	${INSTALL_DATA} ${WRKSRC}/a60-mkc.inc				\
		${DESTDIR}${PREFIX}/share/a60/
	set -e; cd ${WRKSRC}; for f in					\
		RRA60.info RRA60.info-[0-9]*				\
		a60.info a60.info-[0-9]*;				\
	do								\
		${TEST} ! -f "$$f" ||					\
		${INSTALL_DATA} "$$f" ${DESTDIR}${PREFIX}/${PKGINFODIR};\
	done
	${INSTALL_MAN} ${WRKSRC}/a60.man				\
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/a60.1
	cd ${WRKSRC}/examples && ${INSTALL_DATA} *.a60 README		\
		${DESTDIR}${PREFIX}/share/examples/a60/
	${INSTALL_DATA} ${WRKSRC}/xa60.*				\
		${DESTDIR}${PREFIX}/share/examples/a60/
	cd ${WRKSRC} && ${INSTALL_DATA} a60.ps RRA60.ps			\
		${DESTDIR}${PREFIX}/share/doc/a60/

.include "../../mk/bsd.pkg.mk"