File:
[cvs.NetBSD.org] /
pkgsrc /
inputmethod /
skk-jisyo-cdb /
Makefile
Revision
1.7:
download - view:
text,
annotated -
select for diffs
Wed Nov 25 12:50:58 2015 UTC (9 years ago) by
jperkin
Branches:
MAIN
CVS tags:
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
HEAD
Remove mk/find-prefix.mk usage from the inputmethod category.
The find-prefix infrastructure was required in a pkgviews world where
packages installed from pkgsrc could have different installation
prefixes, and this was a way for a dependency prefix to be determined.
Now that pkgviews has been removed there is no longer any need for the
overhead of this infrastructure. Instead we use BUILDLINK_PREFIX.pkg
for dependencies pulled in via buildlink, or LOCALBASE/PREFIX where the
dependency is coming from pkgsrc.
Provides a reasonable performance win due to the reduction of `pkg_info
-qp` calls, some of which were redundant anyway as they were duplicating
the same information provided by BUILDLINK_PREFIX.pkg.
# $NetBSD: Makefile,v 1.7 2015/11/25 12:50:58 jperkin Exp $
#
DISTNAME= SKK-JISYO.L.${SKKJISYO_VERS}
PKGNAME= skk-jisyo-cdb-${SKKJISYO_VERS}
CATEGORIES= japanese inputmethod
MASTER_SITES= ${MASTER_SITE_FREEBSD_LOCAL:=matusita/skk-jisyo/}
EXTRACT_SUFX= .bz2
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= http://openlab.ring.gr.jp/skk/wiki/wiki.cgi?page=SKK%BC%AD%BD%F1
COMMENT= Dictionary collection for SKK
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}
BUILD_DEPENDS+= tinycdb-[0-9]*:../../databases/tinycdb
USE_LANGUAGES= # empty
SKKJISYO_VERS= 201212
INSTALLATION_DIRS+= ${PREFIX}/share/skk
do-build:
LC_ALL=C ${AWK} '/^[^;]/ { \
s = substr($$0, index($$0, " ") + 1); \
print "+" length($$1) "," length(s) ":" $$1 "->" s; \
} \
END { \
print ""; \
}' \
< ${WRKDIR}/SKK-JISYO.L.${SKKJISYO_VERS} | \
${LOCALBASE}/bin/cdb -c -t - \
${WRKDIR}/SKK-JISYO.L.${SKKJISYO_VERS}.cdb
do-install:
${INSTALL_DATA} ${WRKDIR}/SKK-JISYO.L.${SKKJISYO_VERS}.cdb \
${DESTDIR}${PREFIX}/share/skk/SKK-JISYO.L.cdb
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>