File:  [cvs.NetBSD.org] / pkgsrc / inputmethod / libime / Makefile
Revision 1.20: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:28 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.20 2025/01/23 23:27:28 riastradh Exp $

DISTNAME=	libime-1.1.5
PKGREVISION=	2
CATEGORIES=	inputmethod
MASTER_SITES=	https://download.fcitx-im.org/fcitx5/libime/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://github.com/fcitx/libime
COMMENT=	Generic inputmethod implementation library
LICENSE=	gnu-lgpl-v2.1

DICTDISTFILES+=	lm_sc.arpa-20230712.tar.xz
DICTDISTFILES+=	dict-20230412.tar.xz
DICTDISTFILES+=	table-20240108.tar.gz

DISTFILES=	${DEFAULT_DISTFILES}
EXTRACT_ONLY=	${DEFAULT_DISTFILES}
.for f in ${DICTDISTFILES}
DISTFILES+=	${f}
SITES.${f}=	https://download.fcitx-im.org/data/
.endfor

USE_LANGUAGES=	c c++
USE_TOOLS+=	pkg-config

PYTHON_VERSIONS_INCOMPATIBLE+=	27

post-extract:
.for f in ${DICTDISTFILES}
	cd ${WRKSRC}/data && \
		${LN} -sf ${DISTDIR}/${f} ${f}
.endfor

.include "../../devel/cmake/build.mk"

.include "../../archivers/zstd/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/extra-cmake-modules/buildlink3.mk"
.include "../../inputmethod/fcitx5/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>