[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / inputmethod / ibus

Annotation of pkgsrc/inputmethod/ibus/Makefile, Revision 1.56

1.56    ! ryoon       1: # $NetBSD: Makefile,v 1.55 2018/05/16 10:28:53 jperkin Exp $
1.1       obache      2:
1.32      obache      3: .include "Makefile.common"
1.1       obache      4:
                      5: COMMENT=       Intelligent Input Bus
                      6:
1.33      obache      7: DEPENDS+=      ${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3
1.54      tsutsui     8: BUILD_DEPENDS+=        cldr-emoji-annotation>=33.0.0.1:../../textproc/cldr-emoji-annotation
1.53      tsutsui     9: BUILD_DEPENDS+=        unicode-character-database-[0-9]*:../../textproc/unicode-character-database
1.48      tsutsui    10: BUILD_DEPENDS+=        unicode-emoji-[0-9]*:../../textproc/unicode-emoji
1.33      obache     11:
1.1       obache     12: GNU_CONFIGURE= yes
                     13: USE_LIBTOOL=   yes
1.56    ! ryoon      14: # XXX fails without GNU msgfmt
        !            15: _TOOLS_USE_PKGSRC.msgfmt=      yes
1.55      jperkin    16: USE_TOOLS+=    pkg-config intltool gmsgfmt gmake msgmerge
1.1       obache     17: USE_LANGUAGES= c c++
                     18: USE_PKGLOCALEDIR=      yes
                     19:
                     20: GCONF_SCHEMAS+=                ibus.schemas
                     21: PKGCONFIG_OVERRIDE+=   ibus-1.0.pc.in
                     22:
                     23: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFBASEDIR}
1.3       obache     24: CONFIGURE_ARGS+=       --localedir=${PREFIX}/${PKGLOCALEDIR}/locale
1.32      obache     25: CONFIGURE_ARGS+=       --enable-dconf
                     26: CONFIGURE_ARGS+=       --enable-gconf
1.7       obache     27: CONFIGURE_ARGS+=       --enable-gtk2
1.32      obache     28: CONFIGURE_ARGS+=       --enable-gtk3
1.14      obache     29: CONFIGURE_ARGS+=       --enable-surrounding-text
1.32      obache     30: CONFIGURE_ARGS+=       --enable-introspection=yes
1.37      obache     31: CONFIGURE_ARGS+=       --with-python=${PYTHONBIN}
1.48      tsutsui    32: CONFIGURE_ARGS+=       --with-unicode-emoji-dir=${PREFIX}/share/unicode/emoji
                     33: CONFIGURE_ARGS+=       --with-emoji-annotation-dir=${PREFIX}/share/unicode/cldr/common/annotations
1.53      tsutsui    34: CONFIGURE_ARGS+=       --with-ucd-dir=${PREFIX}/share/unicode/ucd
1.1       obache     35:
1.14      obache     36: SUBST_CLASSES+=                dbus
                     37: SUBST_STAGE.dbus=      post-configure
                     38: SUBST_FILES.dbus=      src/ibusshare.c
                     39: SUBST_SED.dbus=                -e 's,/var/lib/dbus/machine-id,${VARBASE}/db/dbus/machine-id,g'
1.1       obache     40:
1.14      obache     41: BUILD_DEFS+=   PKG_SYSCONFBASE VARBASE
1.32      obache     42: MANCOMPRESSED= yes
                     43:
                     44: INSTALL_MAKE_FLAGS+=   sysconfdir=${PREFIX}/share/examples/ibus
                     45: MAKE_DIRS+=            ${PKG_SYSCONFDIR}/dconf/db/ibus.d
                     46: MAKE_DIRS+=            ${PKG_SYSCONFDIR}/dconf/profile
                     47: CONF_FILES+=           ${PREFIX}/share/examples/ibus/dconf/db/ibus.d/00-upstream-settings \
                     48:                        ${PKG_SYSCONFDIR}/dconf/db/ibus.d/00-upstream-settings
                     49: CONF_FILES+=           ${PREFIX}/share/examples/ibus/dconf/profile/ibus \
                     50:                        ${PKG_SYSCONFDIR}/dconf/profile/ibus
                     51:
                     52: .include "../../mk/compiler.mk"
                     53: .if !empty(CC_VERSION:Mgcc-4.1.[0-9]*)
                     54: BUILDLINK_TRANSFORM+=  rm:-Wno-unused-but-set-variable
                     55: .endif
1.1       obache     56:
1.7       obache     57: BUILDLINK_API_DEPENDS.GConf+=          GConf>=2.12
1.1       obache     58: .include "../../devel/GConf/schemas.mk"
1.32      obache     59: .include "../../devel/glib2/schemas.mk"
1.41      obache     60: .include "../../devel/dconf/database.mk"
1.32      obache     61: .include "../../devel/dconf/buildlink3.mk"
                     62: BUILDLINK_API_DEPENDS.gobject-introspection+=  gobject-introspection>=0.9.6
                     63: BUILDLINK_DEPMETHOD.gobject-introspection+=    build
                     64: .include "../../devel/gobject-introspection/buildlink3.mk"
1.1       obache     65: .include "../../devel/gettext-lib/buildlink3.mk"
1.14      obache     66: BUILDLINK_API_DEPENDS.glib2+=          glib2>=2.26.0
1.7       obache     67: .include "../../devel/glib2/buildlink3.mk"
1.1       obache     68: .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
                     69: PY_PATCHPLIST= yes
1.32      obache     70: .include "../../sysutils/libnotify/buildlink3.mk"
1.1       obache     71: .include "../../textproc/iso-codes/buildlink3.mk"
                     72: GTK2_IMMODULES=        yes
                     73: .include "../../x11/gtk2/modules.mk"
1.38      obache     74: .include "../../x11/gtk2/buildlink3.mk"
1.36      obache     75: GTK3_IMMODULES=        yes
1.32      obache     76: .include "../../x11/gtk3/modules.mk"
1.38      obache     77: .include "../../x11/gtk3/buildlink3.mk"
1.1       obache     78: .include "../../x11/libX11/buildlink3.mk"
1.33      obache     79: .include "../../lang/python/application.mk"
1.37      obache     80: .include "../../lang/python/extension.mk"
1.1       obache     81: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>