[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / inputmethod / ibus-python

File: [cvs.NetBSD.org] / pkgsrc / inputmethod / ibus-python / Makefile (download)

Revision 1.16, Sat Mar 2 02:16:32 2019 UTC (17 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.15: +1 -2 lines

ibus, ibus-python: update to 1.5.20.

pkgsrc changes:

- remove patches already applied to the release
- workaround upstream issue #2082
- explicitly require cldr-emoji-annotation >34.0.0.0
  to sync emoji dict files in ibus/PLIST
- remove GConf dependencies as mentioned in 1.5.20 changes

Upstream changes:
 https://github.com/ibus/ibus/releases/tag/1.5.20

1.5.20

* Support Shift-Space to insert a Space on Emojier preedit e6badb4
* Do not add emojis in compose category to emoji variants 8375f39
* Implement mouse click with Hangul in ibus side a40631e 4c40afb c7d8771
  9ae2d46 0fd043c
* Delete Gconf dependencies and migrate intltool to gettext a8e8b69
  74a00cc a671081 aa24a52 3914d3a b608666 a78e7f8 7b9c034 b30eb5d
* Do not delete IBUS_CAP_SURROUNDING_TEXT 7b3b8c8
* Show compose preedit with custom compose file ba41173 28b0744
* Fix Atom and Slack for Flatpak be7fb81 60e246e
* Delete Super-space notification 4d3a8ff
* Fix misc build issues aa0f425 6e31597 c1b5543 3172c3b 4d7c1e0
* Fix misc bugs 7edaefd 28d2217 809d880 1c6565e 0f5084e 6aab10f
* Fix typos in comment lines (ZhaoQiang) 639960a
* use iso 639-3 to have names for more languages (glasseyes) 1cd5254
* introspection: Tell the GI scanner to include the C headers
  (Mathieu Bridon) 4ef976a
* Add Uzbek layouts (bmansurov) 4592ce5
* Allow using non-abstract UNIX domain sockets (Anton Mikhalev) 7a38e4d
* typo: sevrer to server (scootergrisen) 64f4e41

# $NetBSD: Makefile,v 1.16 2019/03/02 02:16:32 tsutsui Exp $

.include "../../inputmethod/ibus/Makefile.common"

PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/ibus/ibus-python/}

COMMENT=	Python library for Intelligent Input Bus
LICENSE=	gnu-lgpl-v2.1

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		pkg-config intltool msgfmt gmake
GNU_CONFIGURE=		yes

DEPENDS+=	ibus>=${PKGVERSION_NOREV}:../../inputmethod/ibus
DEPENDS+=	${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3
DEPENDS+=	${PYPKGPREFIX}-gtk2-[0-9]*:../../x11/py-gtk2

PKGCONFIG_OVERRIDE+=	ibus-1.0.pc.in

CONFIGURE_ARGS+=	--disable-gtk2
CONFIGURE_ARGS+=	--disable-gtk3
CONFIGURE_ARGS+=	--disable-xim
CONFIGURE_ARGS+=	--disable-nls
CONFIGURE_ARGS+=	--disable-libnotify
CONFIGURE_ARGS+=	--disable-engine
CONFIGURE_ARGS+=	--disable-surround-text
CONFIGURE_ARGS+=	--disable-emoji-dict
CONFIGURE_ARGS+=	--disable-unicode-dict

.include "../../mk/compiler.mk"
.if !empty(CC_VERSION:Mgcc-4.1.[0-9]*)
BUILDLINK_TRANSFORM+=	rm:-Wno-unused-but-set-variable
.endif

NO_BUILD=	yes
INSTALL_DIRS=	bindings ibus

CONFIGURE_ARGS+=	--disable-dconf
CONFIGURE_ARGS+=	--enable-python-library
CONFIGURE_ENV+=		PYTHON2=${PYTHONBIN}

PYTHON_VERSIONS_INCOMPATIBLE=	34 35 36 37 # py-gtk2

PY_PATCHPLIST=	yes
.include "../../lang/python/extension.mk"
BUILDLINK_API_DEPENDS.py-dbus+=	${PYPKGPREFIX}-dbus>=0.83.0
.include "../../sysutils/py-dbus/buildlink3.mk"
.include "../../textproc/iso-codes/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"