File:  [cvs.NetBSD.org] / pkgsrc / inputmethod / fcitx5-table-extra / Makefile
Revision 1.14: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:28 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.14 2025/01/23 23:27:28 riastradh Exp $

DISTNAME=	fcitx5-table-extra-5.1.3
PKGREVISION=	2
CATEGORIES=	inputmethod
MASTER_SITES=	https://download.fcitx-im.org/fcitx5/fcitx5-table-extra/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://download.fcitx-im.org/fcitx5/fcitx5-table-extra/
COMMENT=	Extra Chinese table for Fcitx5
LICENSE=	gnu-gpl-v2

DEPENDS+=	fcitx5-[0-9]*:../../inputmethod/fcitx5
DEPENDS+=	libime-[0-9]*:../../inputmethod/libime

USE_PKGLOCALEDIR=	yes
USE_LANGUAGES=		c c++

.include "../../devel/cmake/build.mk"

.include "../../devel/extra-cmake-modules/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>