File:  [cvs.NetBSD.org] / pkgsrc / inputmethod / fcitx5-configtool / Makefile
Revision 1.26: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:27 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.26 2025/01/23 23:27:27 riastradh Exp $

DISTNAME=	fcitx5-configtool-5.1.3
PKGREVISION=	5
CATEGORIES=	inputmethod
MASTER_SITES=	https://download.fcitx-im.org/fcitx5/fcitx5-configtool/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://github.com/fcitx/fcitx5-configtool
COMMENT=	Config tool for fcitx5
LICENSE=	gnu-gpl-v2

USE_PKGLOCALEDIR=	yes
USE_LANGUAGES=		c c++
USE_TOOLS+=		pkg-config

CMAKE_CONFIGURE_ARGS+=		-DENABLE_KCM=off

# CMAKE_INSTALL_RPATH does not work.
SUBST_CLASSES+=		rpath
SUBST_STAGE.rpath=	pre-configure
SUBST_MESSAGE.rpath=	Setting RPATH
SUBST_FILES.rpath+=	src/migrator/lib/CMakeLists.txt
SUBST_VARS.rpath+=	COMPILER_RPATH_FLAG PREFIX QTDIR

.include "../../devel/extra-cmake-modules/buildlink3.mk"
#.include "../../devel/kcoreaddons/buildlink3.mk"
#.include "../../devel/kdeclarative/buildlink3.mk"
#.include "../../devel/ki18n/buildlink3.mk"
#.include "../../devel/kpackage/buildlink3.mk"
.include "../../inputmethod/fcitx5-qt/buildlink3.mk"
.include "../../textproc/iso-codes/buildlink3.mk"
#.include "../../x11/kirigami2/buildlink3.mk"
.include "../../x11/kitemviews/buildlink3.mk"
.include "../../x11/kwidgetsaddons/buildlink3.mk"
.include "../../x11/libxkbfile/buildlink3.mk"
#.include "../../x11/qt5-qtquickcontrols2/buildlink3.mk"
.include "../../x11/qt5-qtx11extras/buildlink3.mk"
.include "../../x11/xkeyboard-config/buildlink3.mk"
.include "../../devel/cmake/build.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>