File:  [cvs.NetBSD.org] / pkgsrc / inputmethod / fcitx5-chinese-addons / Makefile
Revision 1.37: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:26 2025 UTC (7 weeks, 2 days ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.37 2025/01/23 23:27:26 riastradh Exp $

DISTNAME=	fcitx5-chinese-addons-5.1.3
PKGREVISION=	9
CATEGORIES=	inputmethod
MASTER_SITES=	https://download.fcitx-im.org/fcitx5/fcitx5-chinese-addons/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://github.com/fcitx/fcitx5-chinese-addons
COMMENT=	Pinyin and table input method support for fcitx5
LICENSE=	gnu-gpl-v2 AND gnu-lgpl-v2.1

DIST_SUBDIR=	${PKGNAME_NOREV}

DISTFILES+=	${DEFAULT_DISTFILES}
MOREDISTFILES+=	py_stroke-20121124.tar.gz
MOREDISTFILES+=	py_table-20121124.tar.gz
.for f in ${MOREDISTFILES}
DISTFILES+=	${f}
SITES.${f}=	https://download.fcitx-im.org/data/
.endfor
EXTRACT_ONLY=	${DEFAULT_DISTFILES}

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		pkg-config
USE_LANGUAGES=		c c++

post-extract:
.for f in ${MOREDISTFILES}
	cd ${WRKSRC}/modules/pinyinhelper && \
		${LN} -sf ${DISTDIR}/${DIST_SUBDIR}/${f} ${f}
.endfor

.include "../../devel/cmake/build.mk"
.include "../../converters/opencc/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/extra-cmake-modules/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../inputmethod/fcitx5-lua/buildlink3.mk"
.include "../../inputmethod/fcitx5-qt/buildlink3.mk"
.include "../../inputmethod/libime/buildlink3.mk"
.include "../../textproc/fmtlib/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../x11/qt5-qtdeclarative/buildlink3.mk"
.include "../../x11/qt5-qtlocation/buildlink3.mk"
.include "../../x11/qt5-qtwebchannel/buildlink3.mk"
.include "../../x11/qt5-qtwebengine/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>