[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / trustedQSL

Annotation of pkgsrc/ham/trustedQSL/Makefile, Revision 1.28

1.28    ! wiz         1: # $NetBSD: Makefile,v 1.27 2017/08/24 20:03:25 adam Exp $
1.1       mef         2:
1.21      mef         3: DISTNAME=              tqsl-2.2.1
1.27      adam        4: PKGREVISION=           5
1.1       mef         5: CATEGORIES=            ham
1.28    ! wiz         6: MASTER_SITES=          https://sourceforge.net/projects/trustedqsl/files/TrustedQSL/v${PKGVERSION_NOREV}/
1.1       mef         7:
                      8: MAINTAINER=            makoto@ki.nu
1.28    ! wiz         9: HOMEPAGE=              https://sourceforge.net/projects/trustedqsl/
1.1       mef        10: COMMENT=               TrustedQSL, uploading QSL Data to LoTW of ARRL
1.2       mef        11: LICENSE=               arrl-license
1.1       mef        12:
1.9       mef        13: # A macro _S in /usr/include/ctype.h conflicts with one in apps/tqsltrace.h
                     14: # NOT_FOR_PLATFORM+=   NetBSD-5.*
                     15:
1.1       mef        16: USE_TOOLS+=            perl gmake cmake
                     17: USE_LANGUAGES+=                c c++
                     18: USE_LIBTOOL=           yes
                     19: USE_CMAKE=             yes
                     20:
                     21: # There is an unresolved build failure, where -R for /usr/pkg/lib does
                     22: # not precede /usr/X11R7/lib, and on a netbsd-5 system with base xorg,
                     23: # an old version of pixman is found by the pkgsrc cairo.  The root
                     24: # cause (aside from having two pixman versions installed) is ad hoc -L
                     25: # usage in Makefile.am, without matching -R.
                     26:
                     27: do-configure:
1.22      jperkin    28:        (cd ${WRKSRC} ; \
1.1       mef        29:        cmake \
                     30:        -DBDB_PREFIX=${PREFIX} \
1.9       mef        31:        -DBDB_INCLUDE_DIR=${PREFIX}/include \
1.1       mef        32:        -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE \
                     33:        -DCMAKE_INSTALL_PREFIX=${PREFIX} \
                     34:        -DCMAKE_INSTALL_RPATH=${PREFIX}/lib \
                     35:        -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=FALSE \
1.22      jperkin    36:        -DCMAKE_INSTALL_MANDIR:PATH=${PKGMANDIR} \
1.1       mef        37:        .)
                     38:
                     39: post-install:
                     40:        (cd ${WRKSRC} ;\
                     41:        ${INSTALL_DATA} LICENSE.txt ${DESTDIR}${PREFIX}/share/TrustedQSL/ \
                     42:        )
1.17      mef        43:        # Conflicting PLIST with wxGTK28-2.8.12nb8:
1.21      mef        44:        ${RM} -f ${DESTDIR}${PREFIX}/share/locale/*/LC_MESSAGES/wxstd.mo
1.17      mef        45:
1.1       mef        46: .include "../../textproc/expat/buildlink3.mk"
                     47: .include "../../databases/db5/buildlink3.mk"
1.18      mef        48: .include "../../mk/wxGTK.mk"
1.1       mef        49: .include "../../www/curl/buildlink3.mk"
                     50:
                     51: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>