[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / hamlib

File: [cvs.NetBSD.org] / pkgsrc / ham / hamlib / Makefile (download)

Revision 1.18, Sat Mar 11 01:53:39 2006 UTC (18 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.17: +5 -1 lines

The configure script insists on a Python interpreter even if it doesn't
need one. Overriding the PYTHON environment variable helps. This allows
the package to build on NetBSD 3.0.

# $NetBSD: Makefile,v 1.18 2006/03/11 01:53:39 rillig Exp $
#

DISTNAME=	hamlib-1.2.5
CATEGORIES=	ham
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=hamlib/}
#EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	wulf@NetBSD.org
HOMEPAGE=	http://hamlib.sourceforge.net/
COMMENT=	API for digital communications equipment

USE_TOOLS+=	gmake
GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes

CONFIGURE_ARGS+=--without-tcl-binding \
		--without-perl-binding \
		--without-python-binding

# The configure script is broken. It even requires a Python interpreter
# when none is needed.
CONFIGURE_ENV+=	PYTHON=/nonexistent

pre-install:
	${INSTALL_DATA_DIR} ${PREFIX}/include/hamlib

.include "../../mk/bsd.pkg.mk"