[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / gr-osmosdr

File: [cvs.NetBSD.org] / pkgsrc / ham / gr-osmosdr / Makefile (download)

Revision 1.18, Mon Jul 1 04:08:26 2019 UTC (4 years, 5 months ago) by ryoon
Branch: MAIN
Changes since 1.17: +2 -2 lines

Recursive revbump from boost-1.70.0

# $NetBSD: Makefile,v 1.18 2019/07/01 04:08:26 ryoon Exp $

DISTNAME=		gr-osmosdr-0.1.4
PKGREVISION=		14
CATEGORIES=		ham
MASTER_SITES+=		http://git.osmocom.org/gr-osmosdr/snapshot/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://git.osmocom.org/gr-osmosdr
COMMENT=		SDR Hardware support for OsmoSDR and so many more
LICENSE=		gnu-gpl-v2

USE_LANGUAGES=		c c++
USE_TOOLS=		cmake
USE_CMAKE=		yes

# Suppress warning for developer
CMAKE_ARGS+=	-Wno-dev
# --   * Ettus USRP Devices
CMAKE_ARGS+=	-DGNURADIO_UHD_INCLUDE_DIRS=${PREFIX}/include/uhd
CMAKE_ARGS+=	-DGNURADIO_BLOCKS_INCLUDE_DIRS=${PREFIX}/include

PLIST_SUBST+=	PYSITELIB=${PYSITELIB}

# Python 36 and 37 result in build errors; 27 builds ok.
PYTHON_VERSIONS_INCOMPATIBLE=	36 37
REPLACE_PYTHON+=	apps/osmocom_siggen_base.py

.include	"../../devel/boost-headers/buildlink3.mk"
.include	"../../devel/boost-libs/buildlink3.mk"
.include	"../../devel/libusb1/buildlink3.mk"
.include	"../../devel/orc/buildlink3.mk"

# \todo Clearly threre is some ordering scheme.  Explain it.

.include	"../../ham/uhd/buildlink3.mk"
.include	"../../lang/python/application.mk"
.include	"../../lang/python/extension.mk"

.include	"../../ham/rtl-sdr/buildlink3.mk"
.include	"../../ham/libmirisdr/buildlink3.mk"
.include	"../../ham/osmo-sdr/buildlink3.mk"
# \todo Re-enable gr-fcdproplus when it works, or optionize it.
# gr-fcdproplus does not build at the moment
#.include	"../../ham/gr-fcdproplus/buildlink3.mk"
.include	"../../ham/hackrf/buildlink3.mk"

.include	"../../ham/gnuradio-core/buildlink3.mk"
.include	"../../ham/gnuradio-fcd/buildlink3.mk"
.include	"../../ham/gnuradio-uhd/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"