File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-video-sdl / Makefile
Revision 1.80: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:19 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.80 2024/08/20 17:46:19 gdt Exp $

PKGNAME=	gnuradio-video-sdl-${VERSION}
PKGREVISION=	4
COMMENT=	SDL (Simple DirectMedia Layer) bindings for GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GR_VIDEO_SDL=ON
CMAKE_CONFIGURE_ARGS+=	-DSDL_INCLUDE_DIR=${PREFIX}/include/SDL
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GRC=ON

PLIST_MINUS+=	companion

.include "../../devel/SDL/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>