File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-utils / Makefile
Revision 1.69: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:19 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.69 2024/08/20 17:46:19 gdt Exp $

PKGNAME=	gnuradio-utils-${VERSION}
PKGREVISION=	4
COMMENT=	Utilities in GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

DEPENDS+=	${PYPKGPREFIX}-click-[0-9]*:../../devel/py-click
DEPENDS+=	${PYPKGPREFIX}-click-plugins-[0-9]*:../../devel/py-click-plugins
DEPENDS+=	${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
DEPENDS+=	${PYPKGPREFIX}-matplotlib-[0-9]*:../../graphics/py-matplotlib
DEPENDS+=	${PYPKGPREFIX}-qwt-qt5-[0-9]*:../../x11/py-qwt-qt5
DEPENDS+=	${PYPKGPREFIX}-yaml-[0-9]*:../../textproc/py-yaml

#CONF_FILES+=	${EGDIR}/modtool.conf	${PKG_SYSCONFDIR}/modtool.conf

CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GR_BLOCKTOOL=ON
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GR_MODTOOL=ON
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GR_UTILS=ON

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>