[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-uhd

File: [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-uhd / Makefile (download)

Revision 1.47, Sun Jan 29 21:16:50 2023 UTC (3 months, 4 weeks ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.46: +2 -1 lines

*: Recursive revbup from graphics/freetype2

# $NetBSD: Makefile,v 1.47 2023/01/29 21:16:50 ryoon Exp $

PKGNAME=	gnuradio-uhd-${VERSION}
PKGREVISION=	1
COMMENT=	Uhd-based encoding and decoding algorithms for GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

CMAKE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_ARGS+=	-DENABLE_GR_UHD=ON
CMAKE_ARGS+=	-DENABLE_PYTHON=ON
CMAKE_ARGS+=	-DENABLE_GRC=ON

PLIST_MINUS+=	companion

.if ${OPSYS} != "Darwin"
# XXX dbj -- i'm not sure why this is necessary, but hard coding
# the .so causes problems on Darwin.  I've also set UHD_DIR in
# the uhd buildlink3.mk file, so it finds the buildlink header files.

CMAKE_ARGS+=	-DUHD_LIBRARIES=${PREFIX}/lib/libuhd.so
CMAKE_ARGS+=	-DUHD_INCLUDE_DIRS=${PREFIX}/include/uhd/usrp
.endif

.include "../../ham/uhd/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"