File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-qtgui / Makefile
Revision 1.79: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:18 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.79 2024/08/20 17:46:18 gdt Exp $

PKGNAME=	gnuradio-qtgui-${VERSION}
PKGREVISION=	4
COMMENT=	Qt GUI module of GNU Radio

DEPENDS+=	${PYPKGPREFIX}-qt5-[0-9]*:../../x11/py-qt5

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

#CONF_FILES+=	${EGDIR}/gr-qtgui.conf	${PKG_SYSCONFDIR}/gr-qtgui.conf

CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GR_QTGUI=ON
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GRC=ON

PLIST_MINUS+=	companion

pre-configure: Qt5Qwt6.pc
.PHONY: Qt5Qwt6.pc
Qt5Qwt6.pc:
	ln -sf ${QWT_DIR}/lib/pkgconfig/Qt5Qwt6.pc ${BUILDLINK_DIR}/lib/pkgconfig/Qt5Qwt6.pc

.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../x11/qwt6-qt5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>