The NetBSD Project

CVS log for pkgsrc/ham/gnuradio-pdu/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-pdu

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Apr 11 11:20:52 2023 UTC (19 months, 3 weeks ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +1 -2 lines
(ham/gnuradio-*) (adhoc) adjust PLIST  - blocks_throttle2.block.yml

-share/gnuradio/grc/blocks/blocks_throttle2.block.yml

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Apr 7 12:58:01 2023 UTC (19 months, 3 weeks ago) by mef
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
(ham/gnuradio-core) Updated 3.10.5.1 to 3.10.6.0

## [3.10.6.0] - 2023-03-31

### Changed

#### Runtime
- Add Python loggers to top_block and hier_block2
- Change the default log level (in the config file) to INFO instead of DEBUG
- Logging improvements in the scheduler
- Correctly determine native page size for Windows

#### GRC
- Fixed: opening the source of a hierachical block using the toolbar button produced an error
- Use the logger, instead of print statements, in generated top blocks
- Remove libX11 load from generated Python code - this was unncessary and produced warnings
- Choose Editor dialog stays above parent

#### gr-analog
- Signal Source: option to hide the message port

#### gr-blocks
- Throttle: supports max time or number of samples per work iteration, useful for reducing latency at low sample rates
- Delay block: option to hide the message port
- File Meta Sink: fix missing Python import in template code

#### gr-channels
- Default taps should be 1.0, not 1.0 + j1.0

#### gr-digital
- Async Decoder: several changes to improve performance robustness (see the commit log for more details)

#### gr-fec
- Tagged Decoder: correctly calculate the frame size for terminated CC decoder

#### gr-filter
- Fixed reverse parameters in fir_filter_with_buffer and pfb_arb_resampler, which could cause crashes
- Fixed PFB Arbitrary Resampler was ignoring attenuation parameter

#### gr-iio
- Set gain mode as specified (was always manual)
- Use the specified gain parameter for second channel (was same as first channel)

#### gr-qtgui
- Histogram Sink: calculate range of bins correctly to avoid strange distributions
- Save (to image) dialogs add file extensions and have a Save button (i.e., they work now)

#### gr-soapy
- Sources: add tags when the frequency changes

#### gr-uhd
- Support for more RFNoC blocks
  - Fosphor, which produces data to drive an on-screen, OpenGL-based renderer which is expected to be in the next release
  - Moving Average
  - Switchboard
  - Split Stream
- FFT: add properties for direction, magnitude and scaling
- RX Stream: flush after timeout
- Fully support multi-channel TX/RX (params were available for one one channel)

#### gr-vocoder
- Add a number of new codec modes for Codec2 and FreeDV

#### gr-zmq
- Selectable bind/connect to support more flexible ZMQ patterns and NAT'd networks
- Stream sources produce when available, instead of waiting for a buffer to fill, helping with latency

#### Modtool
- Use interp and decim keywords correctly when generating blocks

#### Build system and packaging
- Uninstall removes icons and desktop files

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu May 26 15:20:09 2022 UTC (2 years, 6 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
(ham/gnuradio-core) Updated 3.10.1.1  to 3.10.2.0

## [3.10.2.0] - 2022-04-09
### Changed
#### Project Scope

- Clayton Smith continues the effort to replace Boost usage with
  modern C++ equivalents. In a related effort, he has continued the
  logging modernization started by Marcus M端ller. In his spare time,
  he has tackled some tricky, intermittent CI failures, some of which
  turned out to be real bugs. Much of this work is invisible to end
  users, but is extremely useful in making GNU Radio more reliable and
  maintainable. Special thanks are due to Clayton for a lot of hard
  work this cycle.

- Use exceptions instead of `exit()` in several places.
- Fixed a variety of Python deprecation warnings.

- Packager note: `jsonschema` is required for the JSON Config and YAML
  Config blocks. Those blocks will be disabled if `jsonschema` is not
  found.

#### gnuradio-runtime
- Correct size/usage for single-mapped buffers (part of the new Custom
  Buffers feature).

- Correct buffer size allocation. This was actually the single change
  in v3.10.1.1, which did not get its own CHANGELOG entry.

#### GRC
- Improve discovery of xterm and related programs.

- Save generated hierarchical block code to the block library instead
  of the directory containing the current GRC flowgraph.

- New JSON Config and YAML Config blocks that load configuration
  variables from files at runtime. Those variables may then be used in
  block parameters.

- Store the GNU Radio version in flowgraph metadata when saving.

- Minor change in Python evaluation code to allow `affinity`,
  `minoutbuf` and `maxoutbuf` to be adjusted via script parameters.


#### Build system and packaging
- Require C++-17 for `gnuradio-runtime` and code compiled against it (via cmake flags).
- Add `pythonschema` to build- and run-time dependencies.

#### gr-blocks
- Add exponential distribution to Message Strobe Random block's `delay` selection.
- Quiet down debug messages in File Sink.
- Skip alignment check in File Source when the input file is not seekable (e.g., it is a pipe).

#### gr-filter
- Fix crash in Rational Resampler logging

#### gr-digital
- Add generic CRC blocks: CRC Append and CRC Check.

#### gr-qtgui
- Improve text/background color on Range widget.
- Digital Number Control emits message with new, instead of previous, value.

- Message Edit Box  sends message only when return  is pressed, rather
  than whenever focus is lost.

- Vector Sink allows legend to be disabled.
- Type error fixes (Python 3.10 is stricter about int casting).

#### gr-trellis

- Provide Python bindings for PCCC Encoder and Viterbi Combo.

#### gr-vocoder

- Add C++ generation support to gr-vocoder

#### Code generation tools

- Support strongly-typed enums in Python bindings

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Mar 12 23:04:45 2022 UTC (2 years, 8 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -1 lines
gnuradio*: update to 3.10.1.1

Bugfix release for the 3.10.x.y release series.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Jan 16 18:06:26 2022 UTC (2 years, 10 months ago) by tnn
Branches: MAIN
gnuradio: update to 3.10.0.0

- gr-pdu: Protocol Data Units library
- gr-iio: Linux industrial I/O library (but not packaged in pkgsrc)
- Custom Buffers Support
- switch from Log4CPP to spdlog

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>