File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-doxygen / Makefile
Revision 1.85: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:17 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.85 2024/08/20 17:46:17 gdt Exp $

PKGNAME=	gnuradio-doxygen-${VERSION}
PKGREVISION=	4
COMMENT=	Doxygen documentation of GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

TOOL_DEPENDS+=	dvipsk-[0-9]*:../../print/dvipsk
TOOL_DEPENDS+=	doxygen>=1.9.5:../../devel/doxygen
TOOL_DEPENDS+=	graphviz-[0-9]*:../../graphics/graphviz
TOOL_DEPENDS+=	tex-newunicodechar-[0-9]*:../../print/tex-newunicodechar
TOOL_DEPENDS+=	tex-xcolor-[0-9]*:../../print/tex-xcolor
TOOL_DEPENDS+=	texlive-collection-latex-[0-9]*:../../meta-pkgs/texlive-collection-latex
TOOL_DEPENDS+=	web2c-[0-9]*:../../print/web2c

CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_CONFIGURE_ARGS+=	-DENABLE_DOXYGEN=ON

# Doxygen output is never reproducible.
PLIST_SRC=	${WRKDIR}/PLIST.STATIC

post-install: doxygen-plist
.PHONY: doxygen-plist
doxygen-plist:
	cd ${DESTDIR}${PREFIX} && \
	${FIND} share/doc/gnuradio-${PKGVERSION_NOREV}/html -type f -print > ${WRKDIR}/PLIST.STATIC
	cd ${DESTDIR}${PREFIX} && \
	${FIND} share/doc/gnuradio-${PKGVERSION_NOREV}/xml -type f -print >> ${WRKDIR}/PLIST.STATIC

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>