File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-doxygen / Makefile
Revision 1.84: download - view: text, annotated - select for diffs
Tue Jul 16 10:02:02 2024 UTC (7 months ago) by prlw1
Branches: MAIN
CVS tags: HEAD
Revbump for fmtlib 11.0.1
Pointed out by David Gutteridge on pkgsrc-changes

# $NetBSD: Makefile,v 1.84 2024/07/16 10:02:02 prlw1 Exp $

PKGNAME=	gnuradio-doxygen-${VERSION}
PKGREVISION=	4
COMMENT=	Doxygen documentation of GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

TOOL_DEPENDS+=	dvipsk-[0-9]*:../../print/dvipsk
TOOL_DEPENDS+=	doxygen>=1.9.5:../../devel/doxygen
TOOL_DEPENDS+=	graphviz-[0-9]*:../../graphics/graphviz
TOOL_DEPENDS+=	tex-newunicodechar-[0-9]*:../../print/tex-newunicodechar
TOOL_DEPENDS+=	tex-xcolor-[0-9]*:../../print/tex-xcolor
TOOL_DEPENDS+=	texlive-collection-latex-[0-9]*:../../meta-pkgs/texlive-collection-latex
TOOL_DEPENDS+=	web2c-[0-9]*:../../print/web2c

CMAKE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_ARGS+=	-DENABLE_DOXYGEN=ON

# Doxygen output is never reproducible.
PLIST_SRC=	${WRKDIR}/PLIST.STATIC

post-install: doxygen-plist
.PHONY: doxygen-plist
doxygen-plist:
	cd ${DESTDIR}${PREFIX} && \
	${FIND} share/doc/gnuradio-${PKGVERSION_NOREV}/html -type f -print > ${WRKDIR}/PLIST.STATIC
	cd ${DESTDIR}${PREFIX} && \
	${FIND} share/doc/gnuradio-${PKGVERSION_NOREV}/xml -type f -print >> ${WRKDIR}/PLIST.STATIC

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>