File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-core / Makefile
Revision 1.126: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:17 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.126 2024/08/20 17:46:17 gdt Exp $

PKGNAME=	gnuradio-core-${VERSION}
PKGREVISION=	4
COMMENT=	Core part of GNU Radio, all others need this

PLIST_MINUS=	# empty
.include	"Makefile.common"

#CONF_FILES+=	${EGDIR}/gnuradio-runtime.conf	${PKG_SYSCONFDIR}/gnuradio-runtime.conf
#CONF_FILES+=	${EGDIR}/gr-audio-jack.conf	${PKG_SYSCONFDIR}/gr-audio-jack.conf
#CONF_FILES+=	${EGDIR}/gr-audio-portaudio.conf ${PKG_SYSCONFDIR}/gr-audio-portaudio.conf
#CONF_FILES+=	${EGDIR}/gr-audio.conf		${PKG_SYSCONFDIR}/gr-audio.conf

.include "../../mk/oss.buildlink3.mk"
.if ${OSS_TYPE} != "none"
#CONF_FILES+=	${EGDIR}/gr-audio-oss.conf	${PKG_SYSCONFDIR}/gr-audio-oss.conf
PLIST_SRC=	${PKGDIR}/PLIST ${PKGDIR}/PLIST.oss
.endif

# set default as minimum
CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF

# Take care CONF_FILES stuff (The same code in Nocore.mk)
#post-install:
#	${MV} ${DESTDIR}${PREFIX}/etc/gnuradio/conf.d/* \
#	      ${DESTDIR}${PREFIX}/${EGDIR}/

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>