The NetBSD Project

CVS log for pkgsrc/ham/gnuradio-core/Attic/Makefile.version

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-core

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.15, Sun Aug 30 20:43:46 2020 UTC (3 years, 6 months ago) by tnn
Branch: MAIN
CVS Tags: HEAD
Changes since 1.14: +1 -1 lines
FILE REMOVED

gnuradio-core: update to 3.8.1.0

Here is a very high level list of changes:

## Changed
### Project Scope
- C++11
- merged the wholeness of the `next` branch
- Dependency version bumps: CMake, GCC, MSVC, Swig, Boost
- New dependencies: MPIR/GMP, Qt5, gsm, codec2
- Removed dependencies: libusb, Qt4, CppUnit
- Python: Python 2 & Python 3 compatible. 3.8 will be the last Py2k-compatible
  release series
- gengen was replaced by templates (if you don't know gengen, don't do any
  research; save yourself that sorrow)
- Modern CMake (as far as feasible at this point)
- VOLK version updated to v2.0.0
- .clang-format file now dictates coding style
- clang-format'ed the whole tree.
- installed CMake files now tell about configuration

### gnuradio-runtime
- reworked fractional tag time handling, especially in the context of resamplers

### GRC
- C++ generation as option
- YAML instead of XML
- removed `blks2`
- much better canvas tooling
- consistent gobject usage
- ROUNDED ARROWS

### gr-qtgui
- moving from Qt4 to Qt5

### gr-utils
- `gr_modtool` now vastly improved

### gr-vocoder
- improved versatility
- removed in-tree libgsm, libcodec2, use system-wide libs

## Removed
### Project Scope
- Modules `gr-comedi`, `gr-fcd` and `gr-wxgui` are gone
### gr-comedi
- nobody could remember who used this, or for what. It has seen 0 active code
  contributions in the 3.7 lifecycle
### gr-digital
- python-based `packet_encoder` and related tools: Bugs that were sporadic and
  never fixed, so after long deprecation, we're removing it
### gr-fcd
- since it's currently untestable by the CI, it's being removed, as there was no
  code contributions. Generally, we strive to include all batteries with GNU
  Radio. Re-integration within a more general SDR interface would be desirable.
### gr-utils
- removed PyQwt (dead) based tools
### gr-wxgui
- Unmaintained, breaks on increasingly many systems, always was slower than
  Qtgui. We've been starting to tell people to migrate to Qt since at
  least 2015. Now, we're finally removing it.

Revision 1.14 / (download) - annotate - [select for diffs], Sun Nov 3 19:32:07 2019 UTC (4 years, 4 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

ham: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.13 / (download) - annotate - [select for diffs], Fri Jun 21 16:02:16 2019 UTC (4 years, 9 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

(ham/gnuradio-*) Updated 3.7.13.4 to 3.7.13.5

## [3.7.13.5] - 2019-04-20

### Fixed
#### Project Scope
- PMT: in multiple places, we triggered undef. behaviour by accessing the first element of potentially empty uvectors
#### gr-audio
- Windows audio for higher output multiples broken
#### gr-blocks
- QA: `udp_source_sink` flakiness
#### gr-dtv
- Several broken optimizations
- 64-APSK partially wrong ordering
- OOB access in interleaver
- uncovered worst case LDPC LUT generation
#### gr-qtgui
- Compiler Warnings

#### gr-fec
- `polar_encoder`/`_common`: Memory leak
#### gr-uhd
- GRC bindings: DC filter was could not be disabled with IQ imbalance correction disabled

### Added
#### gnuradio-runtime
- ctrlport: int64 for `rpcbasic_inserter`

### Changed
#### GRC
- Removed generation time from generated python code

Revision 1.12 / (download) - annotate - [select for diffs], Sat Jul 21 13:09:01 2018 UTC (5 years, 8 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Updated ham/gnuradio-* to 3.7.113.4

## [3.7.13.4] - 2018-07-15
### Fixed
#### Project Scope
- Fix Boost 1.67 linking issue
#### gnuradio-runtime

- Logging: fixed issues where messages weren't properly written to
  stdout/stderr due to incorrect strings

#### gr-analog
- `fmdet_cf`'s derivative coefficients were wrong.

#### gr-blocks
- `skiphead` used to incorrectly handle tags, now properly shifts

#### gr-digital
- `qa_packet_format`: Unit test used to potentially lock up due to
   incorrect condit ionals
- `clock_recovery_cc`, `crc32_bb`: Accessing the `[0]` element of an
   empty vector is UB, even if you don't use the result afterwards.

#### gr-fec
- `polar_encoder`/`_common`: Fixed multiple out-of-bound accesses due
   to insufficient vector length checks

#### gr-filter
- `fft_filter`, `filter_delay`: Accessing the `[0]` element of an
  empty vector is UB, even if you don't use the result afterwards.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Jul 16 07:55:22 2018 UTC (5 years, 8 months ago) by mef
Branch: MAIN
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Update ham/gnuradio-* from 3.7.11 to 3.7.13.3

## [3.7.13.3] - 2018-06-13

### Fixed
#### Project Scope
- For non-C++11 compilers, the new cstdint include doesn't work out; conditionalized it.

## [3.7.13.2] - 2018-05-31

### Fixed
#### Project Scope
- Actually bumped version in CMakeLists.txt to 3.7.13.2; the 3.7.13.1 tag was tagged off-branch; maintainer failure to simultaneously push a commit that raises the internal version number to 3.7.14.0: this had to be reverted ASAP.

## [3.7.13.1] - 2018-05-31

### Fixed
#### Project Scope
- Actually bumped version in CMakeLists.txt

## [3.7.13.0] - 2018-05-31

### Fixed
#### Project Scope
- `boost::posix_time::[milli]second` takes integer numbers, and we now at least cast the floats to integers, as Boost 1.67 forced us to realize we're (incorrectly) using floating point her
- CMake: using regex to match compiler against "Clang" now enables correct build on OS X
#### GRC
- Fixed GRC bug which broke WX and Qt (by altering the template code), in multiple (less than awesome) steps
#### gr-blocks
- `float_array_to_int`: int32 limits were wrongly hardcoded.
- Fixed the undefined behaviour happening in `float_to_complex` when accessing the second input_items element in the single-input case

## [3.7.12.0] - 2018-04-01

### Software Engineering
- Changed Changelog format
- Introducing Semantic Versioning
- Change of development model: Rather than merging bugfixes to maint, merging maint to master, and next, if applicable, we'll be moving forward more in a typical management model: Development happens on master, and bugfixes are cherrypicked onto the maint-${RELEASE} branch. More info: http://lists.gnu.org/archive/html/discuss-gnuradio/2018-02/msg00133.html
- First attempt at having a .clang-format file to improve code contribution style quality. This is Work In Progress.

### Fixed
#### Project Scope
- Buildability on systems where custom CMake command would try to find "" (empty string) as executable
- Buildable with C++11 compilers (though deprecation warning-rich, due to `unique_ptr`)
- several previously improperly handled include directories now actually included in individual lib/CMakeLists
- Unit test/QA now parallelizable
- Logger works with log4cpp <= 1.1.2 both in and out of tree
- Python linkage under MinGW64
- Documentation Directory now uniformly "docs/" (instead of sometimes "doc/")
- `log` vs `logf` performance bugs
- on-time `pmt::mp("string")` calls (instead of cached PMTs) performance bug
- Doxygen build now reproducible
#### GRC
- Dialogs' parent windows
- Embedded Python Blocks now work in hierarchical GRC flow graphs
#### gnuradio-runtime
- `random.h`: Uniform integer Generation depended on Boost version > min version
- `random.h`: time-dependency when seeding with `0` replaced with actual standard seed
- block startup now synchronized via barrier
- New tag propagation policy "custom" for own implementation
- `get_tags_in_range` used `v.resize(0)` to clear vectors, which lead to unnecessary memory reallocations
- `logger_ptr` now always a pointer, no matter whether logging is enabled; fixes heap corruption bug
- `buffer[_reader]_sptr` superfluous grab/release performance bug
- BSD threading and shared mem compatibility
- PMT: `equal()` comparison
#### gr-utils
- Sorted files in `gr_modtool` makexml processing, leading to improved reproducibility of builds
#### gr-audio
- OS X: memcpy bug
- OS X: debug mode
- Non-Linux ALSA compatibibilty
#### gr-analog
- `fmdet_cf` now has GRC file
- `fastnoise_source`: non-threadsafe `libc` `rand()` replaced by XOROSHIRO128+
#### gr-blocks
- `simple_copy` Ctrlport example
- Metadata sink/source not closing file on `close()`
- `multiply_matrix` formerly used "magic int" value where its API expected enum (and that int wasn't covered)
- TCP connection ASIO bug
- `tags_strobe`: superfluous tags addition
- `vector_sink`: multithreading hazards on `data` access
- `tuntap_pdu`: MTU-sized IP packet reception
- `socket_pdu`: Garbage Collect closed TCP connections
#### gr-channels
- IQ imbalance block formula now mathematically correct now mathematically correct
- `selective_fading_model`: proper scaling of path length
#### gr-digital
- `additive_scrambler_bb`: tag triggered reset
- `stream_to_tagged_stream`: tag offset after `unlock()`
- `blks2/packet.py`: Flushing for small packets
- `interpolating_resampler`: GCC 4.0 compile error
- `constellation`: 16QAM demapper was wrong for one constellation point
- `chunks_to_symbols`: mutex-guard LUT against modification during use
- MSVC compatibility throug `and` -> `&&` etc
- `crc32_bb`: handle unpacked bytes correctly
- `ofdm_carrier_allocator`: catching wrong allocations instead of crashing
#### gr-dtv
- All examples now are installed
- DVB-T2: Removed L1 post scrambling in spec v1.1.1 mode
#### gr-fcd
- Building on non-Linux systems
- Extended symbol bug in Reed-Solomon encoder
- DVB-T Cell identifier
#### gr-fcd
- Building on non-Linux systems
#### gr-fec
- `channel_construction.py`: return int frozen bit output
- `GSL_LDFLAGS` propagation
- `polar_decoder` used to be flaky
#### gr-fft
- locking of fftw wisdom
- `window.cc`: removed NaN due to FP math
- compilation under MinGW
- `logpwrfft.py` reference scaling integer division bug
#### gr-filter
- Simpson's rule code removed in favor of GSL call
#### gr-qtgui
- Time sink: Segfault with tag trigger
#### gr-uhd
- Antenna selection in UHD apps
- `uhd_fft` scalar gain-capability
- Device selection for multi-device operations in UHD apps
- TX streamer creation
#### gr-zeromq
- Multi-part messages reception

### Added
#### Project Scope
- Ninja (https://ninja-build.org) now a supported build system
#### gnuradio-runtime
- Python can now get `gr.WORK_CALLED_PRODUCE` and `gr.DONE`
#### gr-utils
- `gr_modtool`: Autocompletion, line editing
- `gr_modtool`: `copyrightholder` option
#### GRC
- "Create Duplicate"
- "Save a copy"
- BokehGUI
#### gr-blocks
- New `tag_share` block: take tags from one two input streams to one output stream
- `tag_gate`: tag filtering
- `file_source`: configurable `file_begin` stream tag
- `moving_average`: Vector mode (with element-wise MA)
- `plateau_detector`: threshold get/set
#### gr-digital
- `costas_loop_cc`: Optional loop variable outputs
- New `correlate_access_code_tag` block
- `glfsr` exposed through Python
#### gr-dtv
- 256QAM mode for ITU-T J.83B transmitter
#### gr-fec
- negative Polynomials in `cc_encoder`
#### gr-filter
- `symbol_sync_{cc|ff}`
#### gr-uhd
- `uhd_app.py`: selectable time/clock sources
- make `recv()` call's timeout parameterizable
- message-based RX tuning through sink, TX through source

### Changed
#### Project Scope
- VOLK version requirement: 1.4.0
- Minimal required SWIG version now 2.0.4
- GSL optional dependency
- Threw out completely unused `gr_??int` types
- Doxygen build no longer contains timestamps
- Doxygen build now reproducible
- Though factually before, now officially include ZeroMQ and Sphinx as optional dependencies in docs
#### gnuradio-runtime
- Python gateway allows variable number of ports
#### gr-utils
- `gr_modtool`: Block template now uses `numpy.float32` instead of float. 32bit float is actually the default GNU Radio type.e.
#### gr-blocks
- `vector_sink` can preallocate memory for desired amount of items
#### gr-digital
- `header_format_default` now sps>1-capable
- `correlate_acces_code` uses `GR_LOG`
#### gr-uhd
- `uhd_fft`: respect `lo_offset` in `set_bandwidth`
- `usrp_source`: freq tag now actually reflects last set frequency, even on multiple channels
#### gr-qtgui
- Labels: now with 98.121212388% improved floating point formatting
- Time Sink: Stem plot option exposed

### Deprecated
#### gnuradio-runtime
- `gr::sys_pri`

Revision 1.10 / (download) - annotate - [select for diffs], Wed Mar 15 14:07:12 2017 UTC (7 years ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Updated ham/gnuradio from 3.7.10.1 to 3.7.11
--------------------------------------------
ChangeLog v3.7.11

This is a feature release of the 3.7 API series, and incorporates all
the bug fixes implemented in the 3.7.10.2 maintenance release.

Contributors
    (omitted in this commit log, sorry)

Changes

The GNU Radio project tracks changes via Github pull requests. You can
get details on each of the below by going to:

https://github.com/gnuradio/gnuradio

Note: Please see the release notes for 3.7.10.2 for details on the bug
fixes included in this release.

gnuradio-runtime
    #1077 Support dynamically loaded gnuradio installs (Josh Blum)

gnuradio-companion
    #1118 Support vector types in embedded Python blocks (Clayton Smith)

gr-audio
    #1051 Re-implemented defunct Windows audio source (Geof Gnieboer)
    #1052 Implemented block in Windows audio sink (Geof Gnieboer)

gr-blocks
    #896 Added PDU block setters and GRC callbacks (Jacob Gilbert)
    #900 Exposed non-vector multiply const to GRC (Ron Economos)
    #903 Deprecated old-style message queue blocks (Johnathan Corgan)
    #1067 Deprecated blks2 namespace blocks (Johnathan Corgan)

gr-digital
    #910 Deprecated correlateandsync block 3.8 (Johnathan Corgan)
    #912 Deprecated modulation blocks for 3.8 (Sebastian Müller)
    #1069 Improved build memory usage with swig split (Michael Dickens)
    #1097 Deprecated mpskreceivercc block (Johnathan Corgan)
    #1099 Deprecated old-style OFDM receiver blocks (Martin Braun)

gr-dtv
    #875 Added ability to cross-compile gr-dtv (Ron Economos)
    #876 Improved ATSC transmitter performance (Ron Economos)
    #894 Refactored DVB-T RS decoder to use gr-fec (Ron Economos)
    #898 Improved error handling and logging (Ron Economos)
    #900 Improved DVB-T performance (Ron Economos)
    #907 Updated examples to use QT (Ron Economos)
    #1025 Refactor DVB-T2 interleaver (Ron Economos)

gr-filter
    #885 Added set parameter msg port to fractional resampler (Sebastian Müller)

gr-trellis
    #908 Updated examples to use QT (Martin Braun)

gr-uhd
    #872 Added relative phase plots to uhd_fft (Martin Braun)
    #1032 Replace zero-timeout double-recv() with one recv() (Martin Braun)
    #1053 UHD apps may now specify multiple subdevs (Martin Braun)
    #1101 Support TwinRX LO sharing parameters (Andrej Rode)
    #1139 Use UHD internal normalized gain methods (Martin Braun)

gr-utils
    #897 Improved python docstring generation in gr_modtool

Revision 1.9 / (download) - annotate - [select for diffs], Fri Jan 13 22:03:35 2017 UTC (7 years, 2 months ago) by mef
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Updated ham/gnuradio-core (and other gnuradio-*) to 3.7.10.1
------------------------------------------------------------
ChangeLog v3.7.10.1

This is the first bug-fix release for v3.7.10
This contains bug fixes primarily for GRC and DTV.
- GRC
 * Catch more exceptions thrown by ConfigParser when reading corrupted
   grc.conf files.
 * Fix the docstring update error for empty categories.
 * Fix grcc to call refactored GRC code.
 * Convert initially opened files to absolute paths to prevent
   attempting to read from tmp.
 * Move startup checks back in to gnuradio-companion script from grc/checks.py.

- DTV
 * Fix a segfault that occurs from out-of-bounds access in
   dvbt_bit_inner_interleaver forecast by forecasting an enumerated list
   of all input streams.
 * Fix VL-SNR framing.

- Digital
 * Enable update rate in block_recovery_mm blocks to keep tags close to
   the the proper clock-recovered sample time. Tag offsets will still be
   off between calls to work, but each work call updates the tag rate.

- Analog
 * Fix the derivative calculation in fmdet block.

- Builds
 * Fix linking GSL to gr-fec.
 * Use gnu99 C standard rather than gnu11 standard to maintain
   support for GCC 4.6.3.

- Other
   Minor spelling and documentation fixes.
   Fix uhd_siggen_gui when using lo_locked.

(pkgsrc changes on gnuradio-core/Makefile.common)
 - Following lines added
   CXXFLAGS+=               -pthread
   .include       "../../devel/cppunit/buildlink3.mk"
   .include       "../../math/gsl/buildlink3.mk"

Revision 1.8 / (download) - annotate - [select for diffs], Tue Jul 12 11:36:46 2016 UTC (7 years, 8 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Updated to ham/gnuradio* to 3.7.10
----------------------------------
ChangeLog is available at
   http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_10

Revision 1.7 / (download) - annotate - [select for diffs], Mon Mar 7 13:14:31 2016 UTC (8 years ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

(pkgsrc)
 - Adjust PLIST
 - Remove PKGREVISION from gnuradio-core/Makefile
 - 3.7.8 to 3.7.9.1    for gnuradio-core/Makefile.version

(upstream)
 - Update {ham,meta-pkgs}/gnuradio* from 3.7.8 to 3.7.9.1
   ------------------------------------------------------
   ChangeLog for V 3.7.9.1 is at
     http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_9_1

   ChangeLog for V 3.7.9 is at
     http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_9

   Several news are at
     http://gnuradio.org/redmine/projects/gnuradio/news

Revision 1.6 / (download) - annotate - [select for diffs], Tue Sep 1 04:13:43 2015 UTC (8 years, 6 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

(pkgsrc)
 - (File/REPLACE_PYTHON) delete non existent files
 - (Makefile)
    * CONF_FILES setup deleted (etc files no longer installed,
       but found at examples directory now)
    * MASTER_SITES updated
    * ${DESTDIR} is removed from one of CMAKE_ARGS
      -DGR_LIBRARY_DIR=${DESTDIR}${PREFIX}/lib

(upstream)
 - Update gnuradio-core from 3.7.6 to 3.7.8
  ---------------------
  ChangLog 3.7.7 to 3.7.8 is not known
  Release Note for 3.7.7 is at
    http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_7

Revision 1.5 / (download) - annotate - [select for diffs], Sat Mar 7 05:10:45 2015 UTC (9 years ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

(pkgsrc)
 - Following patch added to give sphinx-build name (with ${PYVERSSUFFIX) attached)
   gnuradio-core/patches/patch-cmake_Modules_FindSphinx.cmake
 - Depending doxygen-1.8.9.1nb1 now
 - gnuradio-doxygen is updated 3.7.5.2nb1 to 3.7.6
(upstream)
 - Update gnuradio-* from 3.7.5.2 to 3.7.6
  ---------------------------------------
GNU Radio releases 3.7.6 and 3.7.5.2 are available for download:

   (several tens of lines omitted for URL and List of contributors)

Release 3.7.5.2 is a bug-fix only maintenance patch following 3.7.5.1,
and will be the last one for the 3.7.5 release.  Release 3.7.6
incorporates all these fixes and adds significant new features.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Jan 24 12:22:05 2015 UTC (9 years, 2 months ago) by mef
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Update gnuradio-* from 3.7.5.1 to 3.7.5.2
-----------------------------------------
GNU Radio releases 3.7.6 and 3.7.5.2 are available for download:

   ( several tens of lines omitted for URL and List of contributors)

Release 3.7.5.2 is a bug-fix only maintenance patch following 3.7.5.1,
and will be the last one for the 3.7.5 release.  Release 3.7.6
incorporates all these fixes and adds significant new features.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Jan 16 12:54:52 2015 UTC (9 years, 2 months ago) by mef
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Update 3.7.5 to 3.7.5.1
-----------------------
2014-10-21 GnuRadio 3.7.5.1 is available
  http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_5_1

audio: Fixes string format bug in ALSA error messages.
blocks: Added callback to vector source GRC bindings
blocks: benchmark scripts using wrong includes.
blocks: convert asserts to throwing runtime errors in keep_m_in_n ctor.
blocks: fixed relative rate in keep_m_in_n. It's m-in-n, not n-in-m.
blocks: fixed up keem_m_in_n to handle relative rate and correct number of items in calls to work.
blocks: removed use of 'and', 'or', and 'not' for &&, ||, and !.
cmake: Additional search path for QWT include files.
cmake: OSS is not for APPLE or WINDOWS.
cmake: Use APPLE, not matching Darwin
cmake: modtool: On Apple only, set install name and use rpath correctly.
cmake: modtool: allow the use of a MODULES_DIR to specify where cmake modules are installed.
cmake: modtool: make sure our local CMake Modules path comes first.
cmake: modtool: update copyright date.
digital: adapt clock recovery QA
digital: applying same fix of the complex M&M clock recovery block as the float vrsion.
digital: clock recovery delete unused variables
digital: clock recovery fix relative limit
digital: clock recovery more verbose documentation
docs: Make explicit we only support Qt4
dtv: fix internal GR component dependencies
fec: qa: fix use of Bool type to be actual boolean Python values
fec: removed ber_tools; unnecessary and not exported. Replaced compber with call to VOLK's popcount.
filter: Fixes setting sample delay declaration for PFB synthesizer in GRC.
filter: Fixes setting sample delay declaration for the PFB channelizer and in GRC.
grc: disable port type caching on init
grc: fix lagging drag and drop
grc: fix missing xterm (Bug #725)
grc: fix search entry box for old PyGTK versions
grc: no icon in search entry box for old PyGTK versions
grc: update all flowgraphs when hiding port labels
grc: yet another py26 incompatibility
qtgui: fixed an issue with the number sink mistreating non-float inputs.
qtgui: increased max tabs from 5 to 20 in tab widget
runtime: fix installation location of the gr_log_default.conf log configuration file.
uhd: removed use of 'and', 'or', and 'not' for &&, ||, and !.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Oct 17 09:51:56 2014 UTC (9 years, 5 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Make ALSA selectable by PKG_OPTIONS and disabled by default. This makes sound come out (on NetBSD).

Revision 1.1 / (download) - annotate - [select for diffs], Mon Oct 13 12:46:33 2014 UTC (9 years, 5 months ago) by mef
Branch: MAIN

(pkgsrc) Update GNU Radio 3.3.0 (2010-09-15) to 3.7.5
  See the thread for modularity issues etc:
  http://mail-index.netbsd.org/pkgsrc-users/2014/09/07/msg020346.html

(upstream)
Release of 3.7.5  2014-09-05  http://gnuradio.org/redmine/news/43
  Changelog:
  http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_5
Release of 3.7.4  2014-07-15  http://gnuradio.org/redmine/news/38
Release of 3.7.3  2014-03-16  http://gnuradio.org/redmine/news/35

Release of 3.7.2  2013-11-10  http://gnuradio.org/redmine/news/30
Release of 3.7.1  2013-08-29  http://gnuradio.org/redmine/news/26
Release of 3.7.0  2013-07-03  http://gnuradio.org/redmine/news/25

Release of 3.6.0  2012-04-21  http://gnuradio.org/redmine/news/13
Release of 3.5.0  2011-12-08  http://gnuradio.org/redmine/news/6
Release of 3.4.0  2011-10-09  http://gnuradio.org/redmine/news/2

Release of 3.3.0  2010-06-03  ftp://ftp.gnu.org/gnu/gnuradio/
Release of 3.3.0-rc0
                  2010-05-13  http://gnuradio.org/redmine/news/1

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>