[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-core

Annotation of pkgsrc/ham/gnuradio-core/Makefile.common, Revision 1.28

1.28    ! dbj         1: # $NetBSD: Makefile.common,v 1.27 2020/08/30 20:43:46 tnn Exp $
1.1       mef         2: # This Makefile fragment is included in the package Makefiles for
                      3: # GNU Radio distributed packages (they all share common configure and build
                      4: # settings).
1.27      tnn         5:
1.1       mef         6: # used by ham/gnuradio-channels/Makefile
                      7: # used by ham/gnuradio-companion/Makefile
                      8: # used by ham/gnuradio-core/Makefile
                      9: # used by ham/gnuradio-ctrlport/Makefile
                     10: # used by ham/gnuradio-digital/Makefile
                     11: # used by ham/gnuradio-doxygen/Makefile
                     12: # used by ham/gnuradio-dtv/Makefile
1.27      tnn        13: # used by ham/gnuradio-fcd/Makefile
1.1       mef        14: # used by ham/gnuradio-fec/Makefile
                     15: # used by ham/gnuradio-qtgui/Makefile
                     16: # used by ham/gnuradio-trellis/Makefile
                     17: # used by ham/gnuradio-uhd/Makefile
                     18: # used by ham/gnuradio-utils/Makefile
                     19: # used by ham/gnuradio-video-sdl/Makefile
                     20: # used by ham/gnuradio-vocoder/Makefile
                     21: # used by ham/gnuradio-wavelet/Makefile
                     22: # used by ham/gnuradio-zeromq/Makefile
                     23:
1.27      tnn        24: .include       "../../ham/gnuradio-core/version.mk"
1.1       mef        25:
                     26: DISTNAME?=     gnuradio-${VERSION}
                     27: CATEGORIES+=   ham
1.27      tnn        28: #MASTER_SITES= http://s3-dist.gnuradio.org/
                     29: #MASTER_SITES+=        http://gnuradio.org/releases/gnuradio/
                     30: MASTER_SITES=  ${MASTER_SITE_GITHUB:=gnuradio/}
                     31: GITHUB_PROJECT=        gnuradio
                     32: GITHUB_RELEASE=        v${VERSION}
1.1       mef        33:
                     34: MAINTAINER?=   pkgsrc-users@NetBSD.org
1.23      rillig     35: HOMEPAGE?=     https://www.gnu.org/software/gnuradio/
1.1       mef        36: LICENSE=       gnu-gpl-v3
                     37:
1.22      rillig     38: USE_LANGUAGES=         c c++
                     39: USE_TOOLS=             perl gmake cmake pkg-config
                     40: USE_CMAKE=             yes
                     41: LDFLAGS.NetBSD+=       -lrt
1.20      mef        42:
1.27      tnn        43: DEPENDS+=      ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah3
1.17      mef        44: DEPENDS+=      ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six
1.1       mef        45: # gr_filter_design in gnuradio-core ask for:
1.27      tnn        46: DEPENDS+=      ${PYPKGPREFIX}-qwt-qt5-[0-9]*:../../x11/py-qwt-qt5
                     47: DEPENDS+=      ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
                     48: DEPENDS+=      ${PYPKGPREFIX}-cairo-[0-9]*:../../graphics/py-cairo
                     49: DEPENDS+=      ${PYPKGPREFIX}-yaml-[0-9]*:../../textproc/py-yaml
                     50: DEPENDS+=      ${PYPKGPREFIX}-numpy-[0-9]*:../../math/py-numpy
                     51: DEPENDS+=      ${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3
1.1       mef        52:
                     53: DISTINFO_FILE=         ${.CURDIR}/../../ham/gnuradio-core/distinfo
                     54: PATCHDIR=              ${.CURDIR}/../../ham/gnuradio-core/patches
                     55:
1.28    ! dbj        56: PYTHON_VERSIONS_ACCEPTED= 37 38
1.1       mef        57: PLIST_SUBST+=  PYVERSSUFFIX=${PYVERSSUFFIX}
                     58: PLIST_SUBST+=  PYSITELIB=${PYSITELIB}
                     59: PY_PATCHPLIST= yes
                     60:
                     61: CONFIGURE_DIRS=        build
                     62:
1.11      mef        63: EGDIR=                 share/gnuradio/examples
1.1       mef        64: PKG_SYSCONFSUBDIR=     gnuradio/conf.d
                     65:
1.14      mef        66: CXXFLAGS+=             -pthread
1.27      tnn        67: CFLAGS+=               -pthread
1.1       mef        68: LDFLAGS.DragonFly+=    -lboost_system
                     69: LDFLAGS.SunOS+=                -lboost_system
1.3       mef        70: CXXFLAGS.SunOS+=       -pthreads
1.1       mef        71:
                     72: INSTALLATION_DIRS+=    ${EGDIR}
                     73:
                     74: # --------       R E S E T  CMAKE_ARGS  H E R E  -------------
                     75: CMAKE_ARGS=
                     76:
                     77: # set default as minimum
                     78: # See  http://gnuradio.org/redmine/projects/gnuradio/wiki/BuildGuide
                     79: #      http://gnuradio.org/redmine/projects/gnuradio/wiki/CygwinInstallMain
                     80:
                     81: CMAKE_ARGS+=   -DENABLE_GNURADIO_RUNTIME=ON
                     82: CMAKE_ARGS+=   -DENABLE_GR_ANALOG=ON
                     83: CMAKE_ARGS+=   -DENABLE_GR_AUDIO=ON
                     84: CMAKE_ARGS+=   -DENABLE_GR_BLOCKS=ON
                     85: CMAKE_ARGS+=   -DENABLE_GR_FFT=ON
                     86: CMAKE_ARGS+=   -DENABLE_GR_FILTER=ON
                     87: CMAKE_ARGS+=   -DENABLE_PYTHON=ON
1.25      tnn        88: CMAKE_ARGS+=   -DENABLE_VOLK=ON -DENABLE_INTERNAL_VOLK=OFF
1.17      mef        89: CMAKE_ARGS+=   -DCMAKE_HAVE_PTHREADS_CREATE=OFF
1.1       mef        90:
                     91: # Default setting (for pkgsrc)
                     92: CMAKE_ARGS+=   -Wno-dev
                     93: CMAKE_ARGS+=   -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE
                     94: CMAKE_ARGS+=   -DCMAKE_INCLUDE_PATH=${PREFIX}/include/portaudio2
                     95: CMAKE_ARGS+=   -DCMAKE_LIBRARY_PATH=${PREFIX}/lib/portaudio2
                     96: CMAKE_ARGS+=   -DCMAKE_INSTALL_RPATH=${PREFIX}/lib:${PREFIX}/lib/portaudio2
                     97: CMAKE_ARGS+=   -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE
                     98: CMAKE_ARGS+=   -DLIBUSB_INCLUDE_DIR=${PREFIX}/include/libusb-1.0
                     99:
1.20      mef       100: CMAKE_ARGS+=   -DGR_LIBRARY_DIR=${PREFIX}/lib -lrt
1.9       wiedi     101: CMAKE_ARGS+=   -DGR_PREFSDIR=${PREFIX}/share/gnuradio/examples/
1.1       mef       102:
1.17      mef       103: # adhoc setup not to pick non default version (say python3.6)
                    104: # at configure
1.27      tnn       105: #MAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PREFIX}/bin/python${PYVERSSUFFIX}
1.17      mef       106:
1.1       mef       107: CMAKE_ARGS+=   -DZEROMQ_INCLUDE_DIRS=${PREFIX}/include
                    108: CMAKE_ARG_PATH=        ../
                    109:
                    110: .include "options.mk"
                    111:
1.27      tnn       112: # Fixes build errors w/ clang
                    113: SUBST_CLASSES+=                boost
                    114: SUBST_MESSAGE.boost=   prepend boost placeholders with namespace
                    115: SUBST_FILES.boost=     */lib/*.cc
                    116: SUBST_SED.boost=       -e 's, _1), boost::placeholders::_1),'
                    117: SUBST_STAGE.boost=     pre-configure
                    118:
1.2       mef       119: # disable/enable ALSA, see also patches/patch-gr-audio_lib_CMakeLists.txt
                    120: SUBST_CLASSES+=                alsa
                    121: SUBST_MESSAGE.alsa=    Arrange the patched line depepending on alsa is in PKG_OPTIONS or not
                    122: SUBST_FILES.alsa+=     gr-audio/lib/CMakeLists.txt
                    123: ## The value of ${ALSA_ENABLED} is either '#' or '' by options.mk.
                    124: SUBST_SED.alsa=                -e 's,@@ALSA@@,${ALSA_ENABLED},'
1.16      jperkin   125: SUBST_STAGE.alsa=      pre-configure
1.2       mef       126:
1.7       mef       127: SUBST_CLASSES+=                pyvers
                    128: SUBST_FILES.pyvers=    cmake/Modules/FindSphinx.cmake
                    129: SUBST_MESSAGE.pyvers=  Fix SPHINX_EXECUTABLE NAMES(sphinx-build)
                    130: SUBST_VARS.pyvers+=    PYVERSSUFFIX
                    131: SUBST_STAGE.pyvers=    pre-configure
                    132:
1.27      tnn       133: REPLACE_PYTHON=                */*.py */*/*.py */*/*/*.py */*/*/*/*.py */*/*/*/*/*.py \
1.24      joerg     134:                        */*/*/*/*/*/*.py */*/*/*/*/*/*/*.py */*/*/*/*/*/*/*/*.py
1.1       mef       135:
                    136: pre-configure:
1.24      joerg     137:        ${MKDIR} ${WRKSRC}/build
1.1       mef       138:
                    139: do-install:
1.24      joerg     140:        cd ${WRKSRC}/${BUILD_DIRS} && ${GMAKE} DESTDIR=${DESTDIR} install
1.1       mef       141:
                    142: .include       "../../audio/gsm/buildlink3.mk"
                    143: .include       "../../audio/jack/buildlink3.mk"
1.21      nia       144: .include       "../../audio/portaudio/buildlink3.mk"
1.1       mef       145:
                    146: .include       "../../devel/boost-headers/buildlink3.mk"
                    147: .include       "../../devel/boost-libs/buildlink3.mk"
1.14      mef       148: .include       "../../devel/cppunit/buildlink3.mk"
1.27      tnn       149: .include       "../../devel/gmp/buildlink3.mk"
                    150: .include       "../../devel/swig3/buildlink3.mk"
1.1       mef       151:
                    152: .include       "../../lang/python/application.mk"
                    153: .include       "../../math/fftwf/buildlink3.mk"
1.14      mef       154: .include       "../../math/gsl/buildlink3.mk"
1.25      tnn       155: .include       "../../math/volk/buildlink3.mk"
1.27      tnn       156: .include       "../../textproc/log4cpp/buildlink3.mk"
                    157: .include       "../../textproc/icu/buildlink3.mk"
                    158: .include       "../../graphics/cairo/buildlink3.mk"
                    159: .include       "../../graphics/cairo-gobject/buildlink3.mk"
                    160: .include       "../../x11/gtk3/buildlink3.mk"

CVSweb <webmaster@jp.NetBSD.org>