[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-core

Annotation of pkgsrc/ham/gnuradio-core/Makefile.common, Revision 1.24

1.24    ! joerg       1: # $NetBSD: Makefile.common,v 1.23 2020/01/18 23:32:39 rillig Exp $
1.1       mef         2: # This Makefile fragment is included in the package Makefiles for
                      3: # GNU Radio distributed packages (they all share common configure and build
                      4: # settings).
                      5: # used by ham/gnuradio-atsc/Makefile
                      6: # used by ham/gnuradio-channels/Makefile
                      7: # used by ham/gnuradio-companion/Makefile
                      8: # used by ham/gnuradio-core/Makefile
                      9: # used by ham/gnuradio-ctrlport/Makefile
                     10:
                     11: # used by ham/gnuradio-digital/Makefile
                     12: # used by ham/gnuradio-doxygen/Makefile
                     13: # used by ham/gnuradio-dtv/Makefile
                     14: # used by ham/gnuradio-fcd/Makefile
                     15: # used by ham/gnuradio-fec/Makefile
                     16:
                     17: # used by ham/gnuradio-fcd/Makefile
                     18: # used by ham/gnuradio-noaa/Makefile
                     19: # used by ham/gnuradio-pager/Makefile
                     20: # used by ham/gnuradio-qtgui/Makefile
                     21: # used by ham/gnuradio-trellis/Makefile
                     22:
                     23: # used by ham/gnuradio-uhd/Makefile
                     24: # used by ham/gnuradio-utils/Makefile
                     25: # used by ham/gnuradio-video-sdl/Makefile
                     26: # used by ham/gnuradio-vocoder/Makefile
                     27: # used by ham/gnuradio-wavelet/Makefile
                     28:
                     29: # used by ham/gnuradio-wxgui/Makefile
                     30: # used by ham/gnuradio-zeromq/Makefile
                     31:
                     32: .include       "../../ham/gnuradio-core/Makefile.version"
                     33:
                     34: DISTNAME?=     gnuradio-${VERSION}
                     35: CATEGORIES+=   ham
1.22      rillig     36: MASTER_SITES=  http://s3-dist.gnuradio.org/
                     37: MASTER_SITES=  http://gnuradio.org/releases/gnuradio/
1.1       mef        38:
                     39: MAINTAINER?=   pkgsrc-users@NetBSD.org
1.23      rillig     40: HOMEPAGE?=     https://www.gnu.org/software/gnuradio/
1.1       mef        41: LICENSE=       gnu-gpl-v3
                     42:
1.22      rillig     43: USE_LANGUAGES=         c c++
                     44: USE_TOOLS=             perl gmake cmake pkg-config
                     45: USE_CMAKE=             yes
                     46: LDFLAGS.NetBSD+=       -lrt
1.20      mef        47:
1.1       mef        48:
                     49: DEPENDS+=      ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah
1.17      mef        50: DEPENDS+=      ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
                     51: DEPENDS+=      ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six
1.1       mef        52: # gr_filter_design in gnuradio-core ask for:
                     53: DEPENDS+=      ${PYPKGPREFIX}-qwt-qt4-[0-9]*:../../x11/py-qwt-qt4
                     54:
                     55: DISTINFO_FILE=         ${.CURDIR}/../../ham/gnuradio-core/distinfo
                     56: PATCHDIR=              ${.CURDIR}/../../ham/gnuradio-core/patches
                     57:
1.22      rillig     58: PYTHON_VERSIONS_ACCEPTED= 27 # not yet ported as of 3.3.0
1.1       mef        59: PLIST_SUBST+=  PYVERSSUFFIX=${PYVERSSUFFIX}
                     60: PLIST_SUBST+=  PYSITELIB=${PYSITELIB}
                     61: PY_PATCHPLIST= yes
                     62:
                     63: CONFIGURE_DIRS=        build
                     64:
1.11      mef        65: EGDIR=                 share/gnuradio/examples
1.1       mef        66: PKG_SYSCONFSUBDIR=     gnuradio/conf.d
                     67:
1.14      mef        68: CXXFLAGS+=             -pthread
1.1       mef        69: LDFLAGS.DragonFly+=    -lboost_system
                     70: LDFLAGS.SunOS+=                -lboost_system
1.3       mef        71: CXXFLAGS.SunOS+=       -pthreads
1.1       mef        72:
                     73: INSTALLATION_DIRS+=    ${EGDIR}
                     74:
                     75: # --------       R E S E T  CMAKE_ARGS  H E R E  -------------
                     76: CMAKE_ARGS=
                     77:
                     78: # set default as minimum
                     79: # See  http://gnuradio.org/redmine/projects/gnuradio/wiki/BuildGuide
                     80: #      http://gnuradio.org/redmine/projects/gnuradio/wiki/CygwinInstallMain
                     81:
                     82: CMAKE_ARGS+=   -DENABLE_GNURADIO_RUNTIME=ON
                     83: CMAKE_ARGS+=   -DENABLE_GR_ANALOG=ON
                     84: CMAKE_ARGS+=   -DENABLE_GR_AUDIO=ON
                     85: CMAKE_ARGS+=   -DENABLE_GR_BLOCKS=ON
                     86: CMAKE_ARGS+=   -DENABLE_GR_FFT=ON
                     87: CMAKE_ARGS+=   -DENABLE_GR_FILTER=ON
                     88: CMAKE_ARGS+=   -DENABLE_PYTHON=ON
                     89: CMAKE_ARGS+=   -DENABLE_VOLK=ON
1.17      mef        90: CMAKE_ARGS+=   -DCMAKE_HAVE_PTHREADS_CREATE=OFF
1.1       mef        91:
                     92: # Default setting (for pkgsrc)
                     93: CMAKE_ARGS+=   -Wno-dev
                     94: CMAKE_ARGS+=   -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE
                     95: CMAKE_ARGS+=   -DCMAKE_INCLUDE_PATH=${PREFIX}/include/portaudio2
                     96: CMAKE_ARGS+=   -DCMAKE_LIBRARY_PATH=${PREFIX}/lib/portaudio2
                     97: CMAKE_ARGS+=   -DCMAKE_INSTALL_RPATH=${PREFIX}/lib:${PREFIX}/lib/portaudio2
                     98: CMAKE_ARGS+=   -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE
                     99: CMAKE_ARGS+=   -DLIBUSB_INCLUDE_DIR=${PREFIX}/include/libusb-1.0
                    100:
1.20      mef       101: CMAKE_ARGS+=   -DGR_LIBRARY_DIR=${PREFIX}/lib -lrt
1.9       wiedi     102: CMAKE_ARGS+=   -DGR_PREFSDIR=${PREFIX}/share/gnuradio/examples/
1.1       mef       103:
1.17      mef       104: # adhoc setup not to pick non default version (say python3.6)
                    105: # at configure
                    106: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PREFIX}/bin/python${PYVERSSUFFIX}
                    107:
1.1       mef       108: CMAKE_ARGS+=   -DZEROMQ_INCLUDE_DIRS=${PREFIX}/include
                    109: CMAKE_ARG_PATH=        ../
                    110:
                    111: .include "options.mk"
                    112:
1.2       mef       113: # disable/enable ALSA, see also patches/patch-gr-audio_lib_CMakeLists.txt
                    114: SUBST_CLASSES+=                alsa
                    115: SUBST_MESSAGE.alsa=    Arrange the patched line depepending on alsa is in PKG_OPTIONS or not
                    116: SUBST_FILES.alsa+=     gr-audio/lib/CMakeLists.txt
                    117: ## The value of ${ALSA_ENABLED} is either '#' or '' by options.mk.
                    118: SUBST_SED.alsa=                -e 's,@@ALSA@@,${ALSA_ENABLED},'
1.16      jperkin   119: SUBST_STAGE.alsa=      pre-configure
1.2       mef       120:
1.7       mef       121: SUBST_CLASSES+=                pyvers
                    122: SUBST_FILES.pyvers=    cmake/Modules/FindSphinx.cmake
                    123: SUBST_MESSAGE.pyvers=  Fix SPHINX_EXECUTABLE NAMES(sphinx-build)
                    124: SUBST_VARS.pyvers+=    PYVERSSUFFIX
                    125: SUBST_STAGE.pyvers=    pre-configure
                    126:
1.24    ! joerg     127: REPLACE_PYTHON =       */*.py */*/*.py */*/*/*.py */*/*/*/*.py */*/*/*/*/*.py \
        !           128:                        */*/*/*/*/*/*.py */*/*/*/*/*/*/*.py */*/*/*/*/*/*/*/*.py
1.1       mef       129:
                    130: pre-configure:
1.24    ! joerg     131:        ${MKDIR} ${WRKSRC}/build
1.1       mef       132:
                    133: do-install:
1.24    ! joerg     134:        cd ${WRKSRC}/${BUILD_DIRS} && ${GMAKE} DESTDIR=${DESTDIR} install
1.1       mef       135:
                    136: .include       "../../audio/gsm/buildlink3.mk"
                    137: .include       "../../audio/jack/buildlink3.mk"
1.21      nia       138: .include       "../../audio/portaudio/buildlink3.mk"
1.1       mef       139:
                    140: .include       "../../devel/boost-headers/buildlink3.mk"
                    141: .include       "../../devel/boost-libs/buildlink3.mk"
1.14      mef       142: .include       "../../devel/cppunit/buildlink3.mk"
1.1       mef       143: # VOLK needs orc.h, so in the common
                    144: .include       "../../devel/orc/buildlink3.mk"
                    145: .include       "../../devel/swig2/buildlink3.mk"
                    146:
                    147: .include       "../../lang/python/application.mk"
                    148: .include       "../../math/fftwf/buildlink3.mk"
1.14      mef       149: .include       "../../math/gsl/buildlink3.mk"

CVSweb <webmaster@jp.NetBSD.org>