The NetBSD Project

CVS log for pkgsrc/ham/gnuradio-companion/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-companion

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.21: download - view: text, markup, annotated - select for diffs
Sun Jan 7 12:24:20 2024 UTC (11 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +1 -10 lines
(ham/gnuradio-core) Updated 3.10.8.0 to 3.10.9.1

(no info for 3.10.9.1)

## [3.10.9.0] - 2023-12-24

### Changed

#### Project
- Python minimum version is now 3.7.2, vs 3.6.5, to support type hints. Even
Python 3.7 is EOL, so this is not expected to affect people using newer versions of
GNU Radio.
- Add tox.ini, so that editors use the same formatting as github CI.
- Use pointers to pass s32fc arguments to VOLK in gr-blocks, gr-digital, and
gr-dtv to avoid undefined behavior. The fix is conditional on VOLK 3.1.0, which
add a new supporting function.

#### Runtime
- Disallow None for pmt_t arguments in Python.
- Support spdlog installations with internal or external libfmt.

#### GRC
- Use text labels to specify types for block parameters, instead of background colors
which were difficult to read/remember.
- Enable setting of documentation URLs, relative or absolute in yaml. This allows
OOTs to use the documentation link in the block parameter dialog.
- Disallow use of block ids that are Python keywords and "gnuradio".
- Add type annotations in some places (required bump to Python 3.7.2).
- Use C version of YAML loader (yaml.CSafeLoader) for better performance.
- Connections may have properties for supported connection domains. This feature
was added for RFNoC connections. Standard stream and message connections do not
support this feature, but they may in future versions.
- Check grc file version. The above feature required a version bump to "2". Where
no connection properties are used, version "1" is still emitted. Note that previous
versions of GRC do not check for file version. RFNoC flowgraphs with connection
properties will fail to load in previous versions as a result.
- Fix bug where an impressive number of backslashes were added to some filenames.

#### gr-dtv
- Read expected data as little-endian

#### gr-fec
- Add FEC_API to CCSDS Reed-Solomon functions so they can be used by OOTs.

#### gr-qtgui
- QT GUI Msg Push Button: add a callback for Message Value to allow it to
change at runtime.

#### gr-uhd
- RFNoC Rx-Streamer: Add start stream options
- Add back-edge property to RFNoC connections

#### Build system and packaging
- Update conda build. Re-rendered with conda-build 3.27.0, conda-smithy 3.28.0,
and conda-forge-pinning 2023.11.07.18.09.01.
- Use utf-8 encoding when writing files in gr_python_install.

#### Testing
There has been a great effort to identify why tests fail intermittently, or only
on certain platforms. This has lead to a number of improved test, and identification
of a number of real bugs.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon Apr 24 06:36:55 2023 UTC (19 months, 2 weeks ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -1 lines
gnuradio-companion: fix PLIST

blocks_throttle2.block.yml needs to be in this package to make
other gnuradio packages build.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Tue Apr 11 11:20:51 2023 UTC (20 months ago) by mef
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +1 -2 lines
(ham/gnuradio-*) (adhoc) adjust PLIST  - blocks_throttle2.block.yml

-share/gnuradio/grc/blocks/blocks_throttle2.block.yml

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sat Apr 8 06:02:35 2023 UTC (20 months ago) by mef
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -1 lines
(ham/gnuradio-companion) Add blocks_throttle2.block.yml on PLIST

share/gnuradio/grc/blocks/blocks_throttle2.block.yml is not included
gnuradio-core, current trick will result PLIST flict on this file.
Sorry. I'll pursue monolithic version instead
Cvs: ----------------------------------------------------------------------
Cvs: Cvsroot  Cvs.Netbsd.Org:/Cvsroot
Cvs: Please Use "PR category/123" to have the commitmsg appended to PR 123

Revision 1.17: download - view: text, markup, annotated - select for diffs
Fri Apr 7 12:58:01 2023 UTC (20 months ago) by mef
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -21 lines
(ham/gnuradio-core) Updated 3.10.5.1 to 3.10.6.0

## [3.10.6.0] - 2023-03-31

### Changed

#### Runtime
- Add Python loggers to top_block and hier_block2
- Change the default log level (in the config file) to INFO instead of DEBUG
- Logging improvements in the scheduler
- Correctly determine native page size for Windows

#### GRC
- Fixed: opening the source of a hierachical block using the toolbar button produced an error
- Use the logger, instead of print statements, in generated top blocks
- Remove libX11 load from generated Python code - this was unncessary and produced warnings
- Choose Editor dialog stays above parent

#### gr-analog
- Signal Source: option to hide the message port

#### gr-blocks
- Throttle: supports max time or number of samples per work iteration, useful for reducing latency at low sample rates
- Delay block: option to hide the message port
- File Meta Sink: fix missing Python import in template code

#### gr-channels
- Default taps should be 1.0, not 1.0 + j1.0

#### gr-digital
- Async Decoder: several changes to improve performance robustness (see the commit log for more details)

#### gr-fec
- Tagged Decoder: correctly calculate the frame size for terminated CC decoder

#### gr-filter
- Fixed reverse parameters in fir_filter_with_buffer and pfb_arb_resampler, which could cause crashes
- Fixed PFB Arbitrary Resampler was ignoring attenuation parameter

#### gr-iio
- Set gain mode as specified (was always manual)
- Use the specified gain parameter for second channel (was same as first channel)

#### gr-qtgui
- Histogram Sink: calculate range of bins correctly to avoid strange distributions
- Save (to image) dialogs add file extensions and have a Save button (i.e., they work now)

#### gr-soapy
- Sources: add tags when the frequency changes

#### gr-uhd
- Support for more RFNoC blocks
  - Fosphor, which produces data to drive an on-screen, OpenGL-based renderer which is expected to be in the next release
  - Moving Average
  - Switchboard
  - Split Stream
- FFT: add properties for direction, magnitude and scaling
- RX Stream: flush after timeout
- Fully support multi-channel TX/RX (params were available for one one channel)

#### gr-vocoder
- Add a number of new codec modes for Codec2 and FreeDV

#### gr-zmq
- Selectable bind/connect to support more flexible ZMQ patterns and NAT'd networks
- Stream sources produce when available, instead of waiting for a buffer to fill, helping with latency

#### Modtool
- Use interp and decim keywords correctly when generating blocks

#### Build system and packaging
- Uninstall removes icons and desktop files

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sun Oct 9 07:56:09 2022 UTC (2 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +4 -3 lines
gnuradio: updated to 3.10.4.0

3.10.4.0

Project Scope

Replace get_initial_sptr() calls with make_block_sptr() calls. There were a number of places the incorrect function was being used.

Runtime

Use correctly typed arguments to log messages to prevent build errors.

GRC

Add xfce4-terminal and urxvt to the list of terminal emulators discovered during the build process.
Suppress GUI hint errors that were being shown in the terminal window.
Use integers for screenshot size (floats were causing Cairo errors).

Build system and packaging

Reformat cmake files and make cmake formatting part of the workflow.
Allow GNU Radio to be a part of other cmake-based projects.
Correct linking to libiio and libad9361 on macOS.
Update method for determining Python installation directory. This should work correctly now on (all?) distro releases.

gr-blocks

New Block Interleaver/Deinterleaver interleaves blocks of symbols
Correct calculation of items_remaining in File Source, which allows seek() to work correctly.
Add an example for Wavefile Sink

gr-digital

Deprecate the CRC32 and CRC16 blocks, which will be removed in the future. There are more general CRC blocks which do the same thing (and more).

gr-filter

Fix demo for PFB channelizer

gr-iio

FMCOMMS2 Sink assumes CS16 data is scaled to 32768, rather than 2048.
FMCOMMS2 returns the correct samples for the second channel in 2-channel mode.

gr-trellis

Correct Python bindings for trellis::metrics.

gr-qtgui

Range widget can now output messages when value changes.
Add C++ code generation for Time Sink
Regenerate Python bindings for some blocks when necessary.
Waterfall Sink correctly uses half spectrum for float input.

gr-uhd

Add Python bindings for the UHD find() functino.

gr-zeromq

Support newer get() and older/deprecated getsockopt() functions in cppzmq depending on availability.

Modtool

Parse IO signatures with or without gr:: prefix.

Documentation

Update certain file lists to keep build paths out of documentation.

Testing

Update Conda recipe for Qt 5.15 and re-render CI support files.
Add testing on Ubuntu 22.04.
Link tests directly against spdlog with not linking to GR runtime.
Ignore Python "missing whitespace after keywork" formatting error.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Thu May 26 15:20:08 2022 UTC (2 years, 6 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +3 -1 lines
(ham/gnuradio-core) Updated 3.10.1.1  to 3.10.2.0

## [3.10.2.0] - 2022-04-09
### Changed
#### Project Scope

- Clayton Smith continues the effort to replace Boost usage with
  modern C++ equivalents. In a related effort, he has continued the
  logging modernization started by Marcus M端ller. In his spare time,
  he has tackled some tricky, intermittent CI failures, some of which
  turned out to be real bugs. Much of this work is invisible to end
  users, but is extremely useful in making GNU Radio more reliable and
  maintainable. Special thanks are due to Clayton for a lot of hard
  work this cycle.

- Use exceptions instead of `exit()` in several places.
- Fixed a variety of Python deprecation warnings.

- Packager note: `jsonschema` is required for the JSON Config and YAML
  Config blocks. Those blocks will be disabled if `jsonschema` is not
  found.

#### gnuradio-runtime
- Correct size/usage for single-mapped buffers (part of the new Custom
  Buffers feature).

- Correct buffer size allocation. This was actually the single change
  in v3.10.1.1, which did not get its own CHANGELOG entry.

#### GRC
- Improve discovery of xterm and related programs.

- Save generated hierarchical block code to the block library instead
  of the directory containing the current GRC flowgraph.

- New JSON Config and YAML Config blocks that load configuration
  variables from files at runtime. Those variables may then be used in
  block parameters.

- Store the GNU Radio version in flowgraph metadata when saving.

- Minor change in Python evaluation code to allow `affinity`,
  `minoutbuf` and `maxoutbuf` to be adjusted via script parameters.


#### Build system and packaging
- Require C++-17 for `gnuradio-runtime` and code compiled against it (via cmake flags).
- Add `pythonschema` to build- and run-time dependencies.

#### gr-blocks
- Add exponential distribution to Message Strobe Random block's `delay` selection.
- Quiet down debug messages in File Sink.
- Skip alignment check in File Source when the input file is not seekable (e.g., it is a pipe).

#### gr-filter
- Fix crash in Rational Resampler logging

#### gr-digital
- Add generic CRC blocks: CRC Append and CRC Check.

#### gr-qtgui
- Improve text/background color on Range widget.
- Digital Number Control emits message with new, instead of previous, value.

- Message Edit Box  sends message only when return  is pressed, rather
  than whenever focus is lost.

- Vector Sink allows legend to be disabled.
- Type error fixes (Python 3.10 is stricter about int casting).

#### gr-trellis

- Provide Python bindings for PCCC Encoder and Viterbi Combo.

#### gr-vocoder

- Add C++ generation support to gr-vocoder

#### Code generation tools

- Support strongly-typed enums in Python bindings

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Mar 12 23:04:45 2022 UTC (2 years, 9 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -0 lines
gnuradio*: update to 3.10.1.1

Bugfix release for the 3.10.x.y release series.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sun Jan 16 18:06:25 2022 UTC (2 years, 10 months ago) by tnn
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +0 -12 lines
gnuradio: update to 3.10.0.0

- gr-pdu: Protocol Data Units library
- gr-iio: Linux industrial I/O library (but not packaged in pkgsrc)
- Custom Buffers Support
- switch from Log4CPP to spdlog

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sat Dec 11 14:57:49 2021 UTC (3 years ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +1 -0 lines
gnuradio*: update to 3.9.4.0

Minor update bringing C++ code cleanups, bug fixes
and some performance improvements.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Apr 7 16:14:07 2021 UTC (3 years, 8 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +15 -8 lines
gnuradio-*: update to 3.9.1.0

Changed
  C++14
  C11
  VOLK now “regular” dependency, not in-tree submodule
  numpy now also a CMake-checked hard dependency for Python support
  Exception Handling: throw by value, catch by reference (clang-tidy check)
  C++11: Emplace in vectors where you can; brings performance boni, but not included in clang-tidy-checks
  An exception-throwing block will now terminate the flow graph process, configurable through top_block
  gr-utils cleanup, folder restructuring
  config version checks installed CMake file will accept “at least this version” now
  PyBind11 replaces SWIG
  Full tree conversion from SWIG to Pybind11 bindings
  Doxygen now uses MathJax, full LaTeX installation no longer required
GRC
  start flowgraph in folder where it resides
gnuradio-runtime
  When calculating offsets in non-integer rate FEC, lround
  default seed for gr::random now actually as documented time-dependent
  loggers moved from gr::block to gr::basic_block
  PMT serialization
  PMT dicts no longer indistinguishable from pairs
  PMT symbol hashing no longer suffers under oddball own implementations
gr-audio
  Increased ALSA buffer nperiods
gr-blocks
  add, add_const VOLK’ized, templated
      this seems to break things in other places, even if it proves to be mathematically identical
  wavfile infrastructure: libsndfile now dependency
gr-digital
  transcendental block: default to 32 bit float complex, not double
  Linear equalizer: separate adaptive algorithm, allows for using e.g. trained sequences instead of the classical LMS, CMA
  DFE: better structure for decision history
gr-dtv
  LDPC encoder: template functions instead of #defined macros
  LDPC encoder: smaller tables through uint16_t for index tables
gr-fec
  API uint8_t, not char
gr-fft
  FFT blocks/functions templatized
gr-filter
  logging format
  rational_resampler_base -> rational_resampler
gr-uhd
  Required UHD version bumped to 3.9.7
  logging format

Deprecated
  gr-analog
    sig_source: freq port will be removed in the future
  gr-audio
    audio-sink, -source: Windows audio sink/source deprecated, the portaudio
      sink/source works even better under windows anyway
  gr-digital
    In favor of symbol_sync, deprecate:
      clock_recovery_mm
      msk_timing_recovery
      pfb_clock_sync

Added
  C++ Generation all over the place
  PyBind bindings + generator
gnuradio-runtime
  block_gateway: set_max_output_buffer
  GR_PREFS_PATH environment variable sensitivity to configure the path to the
    config file
  gnuradio-config-info --print-all
GRC
  option to toggle ID visibilities globally
  Validation check for QT GUI hints
  Python snippets
block header parsing tool
  block header parsing tool (GSoC 2019)
gr_modtool
  option to convert blacklisted files
gr-analog
  sig_source: cmd port adds support for dicts, setting of frequency, amplitude,
    offset and phase parameters
gr-blocks
  selector now has control message ports
  Rotator-based freq shift convenience wrapper
  Message-to-Variable and vice versa blocks
  DC Spike removal
  IQ Swap
  Complex to interleaved char / short: scaling option
  Delay block: control message port
  Phase Shift block with message port
  wavfile_sink, _source can now deal with a lot of audio formats: uncompressed
    WAV/AIFF, µ- and A-law compressed audio, OGG/Vorbis, FLAC, even octave files
  Stream Demux, which demuxes streams according to lengths vector
  rotator: phase() getter
gr-digital
  OFDM: multiple CP lengths
  ofdm_equalizer_simpledfe: enable_soft_output
  Constellation Encoder
  Constellation: normalization options
gr-fec
  {en,de}code_rs_8, {en,de}code_rs_ccsds: Reed-Solomon en- and decoders
gr-fft
  Windows:
    Gaussian
    Flat Top
    Tukey
  Window build() call now with default beta
gr-filter
  GRC: File taps loader block
  Low pass FFT filter convenience wrapper
  ichar / ishort decimator
  phase continuity for freq_xlating_fir_filter
gr-network
  gr-network: a whole new networking blocks module!
      TCP
      UDP
  Much better lockup/multithreading support than 3.7-era blks2
gr-qtgui
  Azimuth/Elevation plot
  Autocorrelation plot
  Compass visualization
  Dial control
  Gauge: dial, level
  Distance plot
  LED-like indicator
  Message-passing check box
  Message-passing numeric control
  Message-passing push button
  Toggle Button
  Eye sink
  Vertical slider
gr-uhd
  Filter API
  UHD 4.0 support
  Power Reference API
  Bidirectional setting messages on both sink, source
gr-vocoder
  Codec2 dev branch support
  FreeDV: In/output rates can differ
  FreeDV: text message output
gr-zeromq
  C++ GRC templates
  Tag filtering for tag-forwarding blocks

Removed
  VOLK is no longer a submodule
  Sphinx: consolidate into doxygen, or wiki-maintained block list.
  Python 2
  SWIG
  gru python module
gnuradio-runtime
  circular_file.cc
  math/common_factor.hpp
gr-blocks
  bin_statistics_f
  log2_const
gr-digital
  PFB clock sync: set_taps
  deprecated old OFDM infrastructur
    ofdm_frame_acquisition
    ofdm_frame_sink
    ofdm_insert_preamble
    ofdm_sync_fixed
    ofdm_sync_pn
    ofdm_sync_pnac
    ofdm_sync_ml
    ofdm_receiver
  digital_voice
gr-fft
  malloc_float, _double: rely on VOLK
  Goertzel: dtor superfluous
gr-filter
  deprecated window function duplicates (use them from gr-fft!)

Fixed
  CMake: Qwt, Log4Cpp detection
  ctrlport strings unicodified
  Freedesktop install script was not executed
  Redundant icons installed
  Path substitution on Windows was backslash-broken
  YAML definitions: more than I can count
  Cross-building: py interpreter at runtime != build time
gnuradio-runtime
  ctrlport: unholy stored reference to stack-allocated object removed
  Sine table generation for fixed point math
  gr_unittest: floatAlmostEqual had a lot of false passes due abuse of all()
  get_tags_in_range for delay < (end-start)
  Premature tag pruning
  release flattened flowgraph after stopping, fixes restartability/shutdown
    problem
  PMT serialization portability
  latency issue caused by setting block alias on msg block
  Windows logging errors
  ctrlport: Thrift >= 0.13 broke
GRC
  Tab widget ID visibilities
  A lot of YAML templates
  Default setting in qtgui chooser restored
  Boolean parameters no longer switch buttons
  Nested namespace handling
  Don’t rely on set ordering in tests
  configparser import
  input box color theme on dark themes
  Search box typing doesn’t inadvertedly interact with the rest of GRC anymore
gr_modtool
  Empty argument lists allowed
  Boost UTF replaced CppUnit, this needed to be done here, too
gr-analog
  wfm left/right, filters
gr-audio
  portaudio: lock acquisition was improper
gr-blocks
  Throttle now uses monotonic clock
  Tag debug only saved last work call’s tags
  File sink flushes on stop
  gr_read_file_metadata.py used to lose rx_time precision
  File source big file handling under Windows
  file_*: fseek errors used to be ignored
gr-digital
  map_bb: thread safety, buffer overflows
  additive_scrambler: reset was broken
  Constellation scalefactor wasn’t always initialized
  long-standing qa_header_payload_demux bug addressed by waiting for both RX and
    TX, not only either
  false triggers in correlate_access_code
gr-dtv
  rate mismatch in ATSC flowgraphs
gr-fec
  async_decoder Heap corruption
  cc_encoder: constraint length K > 8 led to wrong output
gr-fft
  thread safety of copy assignment/ctor
  log power FFT Python
gr-filter
  variable_band_pass_filter GRC complex taps input
  RRC filter gain for alpha = 1
gr-qtgui
  Remove copies of image data in returns by using move semantics
  Remove bogus overriding in drawing functions of plot_raster, _waterfall
  Edit MSG box: don’t require key to be set
  Don’t check for Python2 libs
  Number Sink ignored averaging setting
gr-uhd
  UHD apps: Py3 fixes
  USRP blocks: multichannel objects not properly populating channels
gr-video-sdl
  YUV formats fixed
gr-zeromq
  Don’t depend on deprecated ZMQ functionality
  Unhandled exceptions now handled, much calmer
  Avoid infinite blocking in tb.stop() by using ZMQ_LINGER

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sun Aug 30 20:48:22 2020 UTC (4 years, 3 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +431 -81 lines
gnuradio-companion: update to 3.8.1.0

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Jul 16 07:55:22 2018 UTC (6 years, 4 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -1 lines
Update ham/gnuradio-* from 3.7.11 to 3.7.13.3

## [3.7.13.3] - 2018-06-13

### Fixed
#### Project Scope
- For non-C++11 compilers, the new cstdint include doesn't work out; conditionalized it.

## [3.7.13.2] - 2018-05-31

### Fixed
#### Project Scope
- Actually bumped version in CMakeLists.txt to 3.7.13.2; the 3.7.13.1 tag was tagged off-branch; maintainer failure to simultaneously push a commit that raises the internal version number to 3.7.14.0: this had to be reverted ASAP.

## [3.7.13.1] - 2018-05-31

### Fixed
#### Project Scope
- Actually bumped version in CMakeLists.txt

## [3.7.13.0] - 2018-05-31

### Fixed
#### Project Scope
- `boost::posix_time::[milli]second` takes integer numbers, and we now at least cast the floats to integers, as Boost 1.67 forced us to realize we're (incorrectly) using floating point her
- CMake: using regex to match compiler against "Clang" now enables correct build on OS X
#### GRC
- Fixed GRC bug which broke WX and Qt (by altering the template code), in multiple (less than awesome) steps
#### gr-blocks
- `float_array_to_int`: int32 limits were wrongly hardcoded.
- Fixed the undefined behaviour happening in `float_to_complex` when accessing the second input_items element in the single-input case

## [3.7.12.0] - 2018-04-01

### Software Engineering
- Changed Changelog format
- Introducing Semantic Versioning
- Change of development model: Rather than merging bugfixes to maint, merging maint to master, and next, if applicable, we'll be moving forward more in a typical management model: Development happens on master, and bugfixes are cherrypicked onto the maint-${RELEASE} branch. More info: http://lists.gnu.org/archive/html/discuss-gnuradio/2018-02/msg00133.html
- First attempt at having a .clang-format file to improve code contribution style quality. This is Work In Progress.

### Fixed
#### Project Scope
- Buildability on systems where custom CMake command would try to find "" (empty string) as executable
- Buildable with C++11 compilers (though deprecation warning-rich, due to `unique_ptr`)
- several previously improperly handled include directories now actually included in individual lib/CMakeLists
- Unit test/QA now parallelizable
- Logger works with log4cpp <= 1.1.2 both in and out of tree
- Python linkage under MinGW64
- Documentation Directory now uniformly "docs/" (instead of sometimes "doc/")
- `log` vs `logf` performance bugs
- on-time `pmt::mp("string")` calls (instead of cached PMTs) performance bug
- Doxygen build now reproducible
#### GRC
- Dialogs' parent windows
- Embedded Python Blocks now work in hierarchical GRC flow graphs
#### gnuradio-runtime
- `random.h`: Uniform integer Generation depended on Boost version > min version
- `random.h`: time-dependency when seeding with `0` replaced with actual standard seed
- block startup now synchronized via barrier
- New tag propagation policy "custom" for own implementation
- `get_tags_in_range` used `v.resize(0)` to clear vectors, which lead to unnecessary memory reallocations
- `logger_ptr` now always a pointer, no matter whether logging is enabled; fixes heap corruption bug
- `buffer[_reader]_sptr` superfluous grab/release performance bug
- BSD threading and shared mem compatibility
- PMT: `equal()` comparison
#### gr-utils
- Sorted files in `gr_modtool` makexml processing, leading to improved reproducibility of builds
#### gr-audio
- OS X: memcpy bug
- OS X: debug mode
- Non-Linux ALSA compatibibilty
#### gr-analog
- `fmdet_cf` now has GRC file
- `fastnoise_source`: non-threadsafe `libc` `rand()` replaced by XOROSHIRO128+
#### gr-blocks
- `simple_copy` Ctrlport example
- Metadata sink/source not closing file on `close()`
- `multiply_matrix` formerly used "magic int" value where its API expected enum (and that int wasn't covered)
- TCP connection ASIO bug
- `tags_strobe`: superfluous tags addition
- `vector_sink`: multithreading hazards on `data` access
- `tuntap_pdu`: MTU-sized IP packet reception
- `socket_pdu`: Garbage Collect closed TCP connections
#### gr-channels
- IQ imbalance block formula now mathematically correct now mathematically correct
- `selective_fading_model`: proper scaling of path length
#### gr-digital
- `additive_scrambler_bb`: tag triggered reset
- `stream_to_tagged_stream`: tag offset after `unlock()`
- `blks2/packet.py`: Flushing for small packets
- `interpolating_resampler`: GCC 4.0 compile error
- `constellation`: 16QAM demapper was wrong for one constellation point
- `chunks_to_symbols`: mutex-guard LUT against modification during use
- MSVC compatibility throug `and` -> `&&` etc
- `crc32_bb`: handle unpacked bytes correctly
- `ofdm_carrier_allocator`: catching wrong allocations instead of crashing
#### gr-dtv
- All examples now are installed
- DVB-T2: Removed L1 post scrambling in spec v1.1.1 mode
#### gr-fcd
- Building on non-Linux systems
- Extended symbol bug in Reed-Solomon encoder
- DVB-T Cell identifier
#### gr-fcd
- Building on non-Linux systems
#### gr-fec
- `channel_construction.py`: return int frozen bit output
- `GSL_LDFLAGS` propagation
- `polar_decoder` used to be flaky
#### gr-fft
- locking of fftw wisdom
- `window.cc`: removed NaN due to FP math
- compilation under MinGW
- `logpwrfft.py` reference scaling integer division bug
#### gr-filter
- Simpson's rule code removed in favor of GSL call
#### gr-qtgui
- Time sink: Segfault with tag trigger
#### gr-uhd
- Antenna selection in UHD apps
- `uhd_fft` scalar gain-capability
- Device selection for multi-device operations in UHD apps
- TX streamer creation
#### gr-zeromq
- Multi-part messages reception

### Added
#### Project Scope
- Ninja (https://ninja-build.org) now a supported build system
#### gnuradio-runtime
- Python can now get `gr.WORK_CALLED_PRODUCE` and `gr.DONE`
#### gr-utils
- `gr_modtool`: Autocompletion, line editing
- `gr_modtool`: `copyrightholder` option
#### GRC
- "Create Duplicate"
- "Save a copy"
- BokehGUI
#### gr-blocks
- New `tag_share` block: take tags from one two input streams to one output stream
- `tag_gate`: tag filtering
- `file_source`: configurable `file_begin` stream tag
- `moving_average`: Vector mode (with element-wise MA)
- `plateau_detector`: threshold get/set
#### gr-digital
- `costas_loop_cc`: Optional loop variable outputs
- New `correlate_access_code_tag` block
- `glfsr` exposed through Python
#### gr-dtv
- 256QAM mode for ITU-T J.83B transmitter
#### gr-fec
- negative Polynomials in `cc_encoder`
#### gr-filter
- `symbol_sync_{cc|ff}`
#### gr-uhd
- `uhd_app.py`: selectable time/clock sources
- make `recv()` call's timeout parameterizable
- message-based RX tuning through sink, TX through source

### Changed
#### Project Scope
- VOLK version requirement: 1.4.0
- Minimal required SWIG version now 2.0.4
- GSL optional dependency
- Threw out completely unused `gr_??int` types
- Doxygen build no longer contains timestamps
- Doxygen build now reproducible
- Though factually before, now officially include ZeroMQ and Sphinx as optional dependencies in docs
#### gnuradio-runtime
- Python gateway allows variable number of ports
#### gr-utils
- `gr_modtool`: Block template now uses `numpy.float32` instead of float. 32bit float is actually the default GNU Radio type.e.
#### gr-blocks
- `vector_sink` can preallocate memory for desired amount of items
#### gr-digital
- `header_format_default` now sps>1-capable
- `correlate_acces_code` uses `GR_LOG`
#### gr-uhd
- `uhd_fft`: respect `lo_offset` in `set_bandwidth`
- `usrp_source`: freq tag now actually reflects last set frequency, even on multiple channels
#### gr-qtgui
- Labels: now with 98.121212388% improved floating point formatting
- Time Sink: Stem plot option exposed

### Deprecated
#### gnuradio-runtime
- `gr::sys_pri`

Revision 1.8: download - view: text, markup, annotated - select for diffs
Fri Jan 13 22:03:35 2017 UTC (7 years, 10 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +1 -4 lines
Updated ham/gnuradio-core (and other gnuradio-*) to 3.7.10.1
------------------------------------------------------------
ChangeLog v3.7.10.1

This is the first bug-fix release for v3.7.10
This contains bug fixes primarily for GRC and DTV.
- GRC
 * Catch more exceptions thrown by ConfigParser when reading corrupted
   grc.conf files.
 * Fix the docstring update error for empty categories.
 * Fix grcc to call refactored GRC code.
 * Convert initially opened files to absolute paths to prevent
   attempting to read from tmp.
 * Move startup checks back in to gnuradio-companion script from grc/checks.py.

- DTV
 * Fix a segfault that occurs from out-of-bounds access in
   dvbt_bit_inner_interleaver forecast by forecasting an enumerated list
   of all input streams.
 * Fix VL-SNR framing.

- Digital
 * Enable update rate in block_recovery_mm blocks to keep tags close to
   the the proper clock-recovered sample time. Tag offsets will still be
   off between calls to work, but each work call updates the tag rate.

- Analog
 * Fix the derivative calculation in fmdet block.

- Builds
 * Fix linking GSL to gr-fec.
 * Use gnu99 C standard rather than gnu11 standard to maintain
   support for GCC 4.6.3.

- Other
   Minor spelling and documentation fixes.
   Fix uhd_siggen_gui when using lo_locked.

(pkgsrc changes on gnuradio-core/Makefile.common)
 - Following lines added
   CXXFLAGS+=               -pthread
   .include       "../../devel/cppunit/buildlink3.mk"
   .include       "../../math/gsl/buildlink3.mk"

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jul 12 11:36:46 2016 UTC (8 years, 5 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +87 -110 lines
Updated to ham/gnuradio* to 3.7.10
----------------------------------
ChangeLog is available at
   http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_10

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Mar 7 13:14:31 2016 UTC (8 years, 9 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +10 -2 lines
(pkgsrc)
 - Adjust PLIST
 - Remove PKGREVISION from gnuradio-core/Makefile
 - 3.7.8 to 3.7.9.1    for gnuradio-core/Makefile.version

(upstream)
 - Update {ham,meta-pkgs}/gnuradio* from 3.7.8 to 3.7.9.1
   ------------------------------------------------------
   ChangeLog for V 3.7.9.1 is at
     http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_9_1

   ChangeLog for V 3.7.9 is at
     http://gnuradio.org/redmine/projects/gnuradio/wiki/ChangeLogV3_7_9

   Several news are at
     http://gnuradio.org/redmine/projects/gnuradio/news

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Dec 8 01:45:05 2015 UTC (9 years ago) by wiedi
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -1 lines
Add missing config file to PLIST

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Sep 1 04:14:54 2015 UTC (9 years, 3 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +4 -2 lines
Update gnuradio-* 3.7.6 to 3.7.8

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Mar 7 05:10:45 2015 UTC (9 years, 9 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -3 lines
(pkgsrc)
 - Following patch added to give sphinx-build name (with ${PYVERSSUFFIX) attached)
   gnuradio-core/patches/patch-cmake_Modules_FindSphinx.cmake
 - Depending doxygen-1.8.9.1nb1 now
 - gnuradio-doxygen is updated 3.7.5.2nb1 to 3.7.6
(upstream)
 - Update gnuradio-* from 3.7.5.2 to 3.7.6
  ---------------------------------------
GNU Radio releases 3.7.6 and 3.7.5.2 are available for download:

   (several tens of lines omitted for URL and List of contributors)

Release 3.7.5.2 is a bug-fix only maintenance patch following 3.7.5.1,
and will be the last one for the 3.7.5 release.  Release 3.7.6
incorporates all these fixes and adds significant new features.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Oct 28 06:41:20 2014 UTC (10 years, 1 month ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -0 lines
Fix problem raised by PR pkg/49313 by Ben Gergely,
if xdg-utils are installed already, grc_setup_freedesktop is installed.
(gnuradio-companion/Makefile)
(gnuradio-companion/PLIST)
 -  Add DEPENDS misc/xdg-utils
 -  Add REPLACE_BASH for above newly installed script
 -  Bump PKGREVISION

Related changes, problem was hidden if PKGREVISION was empty.
(gnuradio-core/Makefile.common) -> PLIST_SUBST
(gnuradio-core/Nocore.mk)       -> sed STRING
(gnuradio-core/PLIST)
  - shared library was suffixed as ${PKGVERSION}, but
    this should be ${PKGVERSION_NOREV} instead.
    Above files are affected.

(gnuradio-core/files/REPLACE_PYTHON)
  - Add one file
    grc/python/flow_graph.tmpl

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Oct 13 12:51:08 2014 UTC (10 years, 2 months ago) by mef
Branches: MAIN
Update GNU Radio 3.3.0 (2010-09-15) to 3.7.5
  See the thread for modularity issues etc:
  http://mail-index.netbsd.org/pkgsrc-users/2014/09/07/msg020346.html
See more info at recent  gnuradio-core/Makefile commit log, thanks.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>