File:  [cvs.NetBSD.org] / pkgsrc / ham / gnuradio-companion / Makefile
Revision 1.83: download - view: text, annotated - select for diffs
Tue Aug 20 17:46:17 2024 UTC (5 months, 3 weeks ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
gnuradio*: USE_CMAKE exorcism

  - change to cmake/build.mk
  - set CMAKE_CONFIGURE_ARGS instead of CMAKE_ARGS
  - stop creating/using a build dir manually and don't override install
  - comment out the "don't use ninja" arm, since that happens
    naturally and the ninja option should be removed

Tested by building meta-pkgs/gnuradio on NetBSD 10.

ok @tnn

# $NetBSD: Makefile,v 1.83 2024/08/20 17:46:17 gdt Exp $

PKGNAME=	gnuradio-companion-${VERSION}
PKGREVISION=	4
COMMENT=	User interface entry of GNU Radio

DEPENDS+=	${PYPKGPREFIX}-lxml-[0-9]*:../../textproc/py-lxml
DEPENDS+=	xdg-utils-[0-9]*:../../misc/xdg-utils

REPLACE_BASH=	grc/scripts/freedesktop/grc_setup_freedesktop.in

.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"

# gnuradio-companion
CMAKE_CONFIGURE_ARGS+=	-DENABLE_DEFAULT=OFF
CMAKE_CONFIGURE_ARGS+=	-DENABLE_GRC=ON

ICON_THEMES=	yes
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/gnome-icon-theme/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>